summaryrefslogtreecommitdiff
path: root/media-gfx/ansilove/ansilove-4.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 16:00:34 +0100
commit8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (patch)
treeced0310e563ec21deb23ca12d5459aebadba36f6 /media-gfx/ansilove/ansilove-4.1.7.ebuild
parent93c735f5f1ff867aadcc947348d984ff2c5a29cb (diff)
gentoo auto-resync : 30:03:2023 - 16:00:34
Diffstat (limited to 'media-gfx/ansilove/ansilove-4.1.7.ebuild')
-rw-r--r--media-gfx/ansilove/ansilove-4.1.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/ansilove/ansilove-4.1.7.ebuild b/media-gfx/ansilove/ansilove-4.1.7.ebuild
new file mode 100644
index 000000000000..d0d4327ea128
--- /dev/null
+++ b/media-gfx/ansilove/ansilove-4.1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="ANSI and ASCII art to PNG converter (using libansilove)"
+HOMEPAGE="https://www.ansilove.org/
+ https://github.com/ansilove/ansilove/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="dev-libs/libansilove"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DENABLE_SECCOMP=NO
+ )
+ cmake_src_configure
+}