summaryrefslogtreecommitdiff
path: root/media-gfx/blender/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /media-gfx/blender/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'media-gfx/blender/files')
-rw-r--r--media-gfx/blender/files/blender-2.79b-ffmpeg-4-compat.patch62
-rw-r--r--media-gfx/blender/files/blender-2.79b-fix-for-gcc9-new-openmp-data-sharing.patch31
-rw-r--r--media-gfx/blender/files/blender-2.79b-fix-opencollada.patch112
-rw-r--r--media-gfx/blender/files/blender-2.79b-gcc-8.patch22
-rw-r--r--media-gfx/blender/files/blender-fix-install-rules.patch16
5 files changed, 0 insertions, 243 deletions
diff --git a/media-gfx/blender/files/blender-2.79b-ffmpeg-4-compat.patch b/media-gfx/blender/files/blender-2.79b-ffmpeg-4-compat.patch
deleted file mode 100644
index 4ad05aafb15d..000000000000
--- a/media-gfx/blender/files/blender-2.79b-ffmpeg-4-compat.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff -urN a/intern/ffmpeg/ffmpeg_compat.h b/intern/ffmpeg/ffmpeg_compat.h
---- a/intern/ffmpeg/ffmpeg_compat.h 2018-03-23 15:22:25.000000000 +0000
-+++ b/intern/ffmpeg/ffmpeg_compat.h 2018-08-16 14:39:23.484489828 +0100
-@@ -109,6 +109,45 @@
-
- #endif
-
-+/* XXX TODO Probably fix to correct modern flags in code? Not sure how old FFMPEG we want to support though,
-+ * so for now this will do. */
-+
-+#ifndef FF_MIN_BUFFER_SIZE
-+# ifdef AV_INPUT_BUFFER_MIN_SIZE
-+# define FF_MIN_BUFFER_SIZE AV_INPUT_BUFFER_MIN_SIZE
-+# endif
-+#endif
-+
-+#ifndef FF_INPUT_BUFFER_PADDING_SIZE
-+# ifdef AV_INPUT_BUFFER_PADDING_SIZE
-+# define FF_INPUT_BUFFER_PADDING_SIZE AV_INPUT_BUFFER_PADDING_SIZE
-+# endif
-+#endif
-+
-+#ifndef CODEC_FLAG_GLOBAL_HEADER
-+# ifdef AV_CODEC_FLAG_GLOBAL_HEADER
-+# define CODEC_FLAG_GLOBAL_HEADER AV_CODEC_FLAG_GLOBAL_HEADER
-+# endif
-+#endif
-+
-+#ifndef CODEC_FLAG_GLOBAL_HEADER
-+# ifdef AV_CODEC_FLAG_GLOBAL_HEADER
-+# define CODEC_FLAG_GLOBAL_HEADER AV_CODEC_FLAG_GLOBAL_HEADER
-+# endif
-+#endif
-+
-+#ifndef CODEC_FLAG_INTERLACED_DCT
-+# ifdef AV_CODEC_FLAG_INTERLACED_DCT
-+# define CODEC_FLAG_INTERLACED_DCT AV_CODEC_FLAG_INTERLACED_DCT
-+# endif
-+#endif
-+
-+#ifndef CODEC_FLAG_INTERLACED_ME
-+# ifdef AV_CODEC_FLAG_INTERLACED_ME
-+# define CODEC_FLAG_INTERLACED_ME AV_CODEC_FLAG_INTERLACED_ME
-+# endif
-+#endif
-+
- /* FFmpeg upstream 1.0 is the first who added AV_ prefix. */
- #if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(54, 59, 100)
- # define AV_CODEC_ID_NONE CODEC_ID_NONE
-diff -urN a/source/blender/blenkernel/intern/writeffmpeg.c b/source/blender/blenkernel/intern/writeffmpeg.c
---- a/source/blender/blenkernel/intern/writeffmpeg.c 2018-03-23 15:22:25.000000000 +0000
-+++ b/source/blender/blenkernel/intern/writeffmpeg.c 2018-08-16 14:39:21.702484751 +0100
-@@ -605,7 +605,8 @@
- c->rc_buffer_aggressivity = 1.0;
- #endif
-
-- c->me_method = ME_EPZS;
-+ /* Deprecated and not doing anything since July 2015, deleted in recent ffmpeg */
-+ //c->me_method = ME_EPZS;
-
- codec = avcodec_find_encoder(c->codec_id);
- if (!codec)
diff --git a/media-gfx/blender/files/blender-2.79b-fix-for-gcc9-new-openmp-data-sharing.patch b/media-gfx/blender/files/blender-2.79b-fix-for-gcc9-new-openmp-data-sharing.patch
deleted file mode 100644
index 0ecc960d28e1..000000000000
--- a/media-gfx/blender/files/blender-2.79b-fix-for-gcc9-new-openmp-data-sharing.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/intern/elbeem/intern/solver_main.cpp b/intern/elbeem/intern/solver_main.cpp
-index 68f7c04..514087b 100644
---- a/intern/elbeem/intern/solver_main.cpp
-+++ b/intern/elbeem/intern/solver_main.cpp
-@@ -381,7 +381,7 @@ LbmFsgrSolver::mainLoop(const int lev)
- GRID_REGION_INIT();
- #if PARALLEL==1
- const int gDebugLevel = ::gDebugLevel;
--#pragma omp parallel default(none) num_threads(mNumOMPThreads) \
-+#pragma omp parallel num_threads(mNumOMPThreads) \
- reduction(+: \
- calcCurrentMass,calcCurrentVolume, \
- calcCellsFilled,calcCellsEmptied, \
-@@ -1126,7 +1126,7 @@ LbmFsgrSolver::preinitGrids()
- GRID_REGION_INIT();
- #if PARALLEL==1
- const int gDebugLevel = ::gDebugLevel;
--#pragma omp parallel default(none) num_threads(mNumOMPThreads) \
-+#pragma omp parallel num_threads(mNumOMPThreads) \
- reduction(+: \
- calcCurrentMass,calcCurrentVolume, \
- calcCellsFilled,calcCellsEmptied, \
-@@ -1164,7 +1164,7 @@ LbmFsgrSolver::standingFluidPreinit()
- GRID_REGION_INIT();
- #if PARALLEL==1
- const int gDebugLevel = ::gDebugLevel;
--#pragma omp parallel default(none) num_threads(mNumOMPThreads) \
-+#pragma omp parallel num_threads(mNumOMPThreads) \
- reduction(+: \
- calcCurrentMass,calcCurrentVolume, \
- calcCellsFilled,calcCellsEmptied, \
diff --git a/media-gfx/blender/files/blender-2.79b-fix-opencollada.patch b/media-gfx/blender/files/blender-2.79b-fix-opencollada.patch
deleted file mode 100644
index ab1704864a02..000000000000
--- a/media-gfx/blender/files/blender-2.79b-fix-opencollada.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-Opencollada 1.65 and later added a pure virtual function writeAnimationClip
-so the compiler is unable to create a DocumentImporter implementation.
-These patches are backported from blender 2.80-r1 which fix the issue.
-
-See https://developer.blender.org/rB10c50d7dbf7578b35b3bf19a1948f556f9eb203b
-and https://developer.blender.org/rB3552731551ef1845b493ffebf78be5a42527e9f2
-
-Thanks to Dennis Schridde for finding them.
-
---- blender-2.79b/source/blender/collada/CMakeLists.txt.orig 2020-07-23 18:00:09.421620416 +0200
-+++ blender-2.79b/source/blender/collada/CMakeLists.txt 2020-07-23 18:00:13.868584964 +0200
-@@ -25,6 +25,18 @@
-
- remove_strict_flags()
-
-+FIND_FILE(_opencollada_with_animation_clip
-+ NAMES
-+ COLLADAFWAnimationClip.h
-+ PATHS
-+ ${OPENCOLLADA_INCLUDE_DIRS}
-+ NO_DEFAULT_PATH
-+ )
-+
-+IF(_opencollada_with_animation_clip)
-+ add_compile_definitions(OPENCOLLADA_WITH_ANIMATION_CLIP)
-+ENDIF()
-+
- set(INC
- .
- ../blenkernel
---- blender-2.79b/source/blender/collada/DocumentImporter.h.orig 2018-03-23 16:10:23.000000000 +0100
-+++ blender-2.79b/source/blender/collada/DocumentImporter.h 2020-07-23 18:00:13.897584733 +0200
-@@ -108,6 +108,11 @@
-
- bool writeAnimationList(const COLLADAFW::AnimationList*);
-
-+#if OPENCOLLADA_WITH_ANIMATION_CLIP
-+ // Please enable this when building with Collada 1.6.65 or newer (also in DocumentImporter.cpp)
-+ bool writeAnimationClip(const COLLADAFW::AnimationClip *AnimationClip);
-+#endif
-+
- bool writeGeometry(const COLLADAFW::Geometry*);
-
- bool writeMaterial(const COLLADAFW::Material*);
---- blender-2.79b/source/blender/collada/DocumentImporter.cpp.orig 2018-03-23 16:22:25.000000000 +0100
-+++ blender-2.79b/source/blender/collada/DocumentImporter.cpp 2020-07-23 18:00:13.896584741 +0200
-@@ -1349,6 +1349,19 @@
-
-+#if OPENCOLLADA_WITH_ANIMATION_CLIP
-+// Since opencollada 1.6.68
-+// called on post-process stage after writeVisualScenes
-+bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *AnimationClip)
-+{
-+ if (mImportStage != General)
-+ return true;
-+
-+ return true;
-+ //return animation_clip_importer.write_animation_clip(animationClip); // TODO: implement import of AnimationClips
-+}
-+#endif
-+
- // this is called on postprocess, before writeVisualScenes
- bool DocumentImporter::writeController(const COLLADAFW::Controller *controller)
- {
- if (mImportStage != General)
- return true;
---- blender-2.79b/source/blender/collada/CMakeLists.txt.orig 2020-07-23 18:00:45.035336449 +0200
-+++ blender-2.79b/source/blender/collada/CMakeLists.txt 2020-07-23 18:00:52.459277244 +0200
-@@ -24,8 +24,7 @@
- # ***** END GPL LICENSE BLOCK *****
-
- remove_strict_flags()
--
--FIND_FILE(_opencollada_with_animation_clip
-+FIND_FILE(OPENCOLLADA_ANIMATION_CLIP
- NAMES
- COLLADAFWAnimationClip.h
- PATHS
-@@ -33,8 +32,11 @@
- NO_DEFAULT_PATH
- )
-
--IF(_opencollada_with_animation_clip)
-- add_compile_definitions(OPENCOLLADA_WITH_ANIMATION_CLIP)
-+IF(OPENCOLLADA_ANIMATION_CLIP)
-+ message(STATUS "Found opencollada: ${OPENCOLLADA_ANIMATION_CLIP} ")
-+ add_definitions(-DWITH_OPENCOLLADA_ANIMATION_CLIP)
-+ELSE()
-+ message(STATUS "opencollada: Build without animation clip support")
- ENDIF()
-
- set(INC
---- blender-2.79b/source/blender/collada/DocumentImporter.h.orig 2020-07-23 18:00:13.897584733 +0200
-+++ blender-2.79b/source/blender/collada/DocumentImporter.h 2020-07-23 18:00:52.487277021 +0200
-@@ -108,7 +108,7 @@
-
- bool writeAnimationList(const COLLADAFW::AnimationList*);
-
--#if OPENCOLLADA_WITH_ANIMATION_CLIP
-+#if WITH_OPENCOLLADA_ANIMATION_CLIP
- // Please enable this when building with Collada 1.6.65 or newer (also in DocumentImporter.cpp)
- bool writeAnimationClip(const COLLADAFW::AnimationClip *AnimationClip);
- #endif
---- blender-2.79b/source/blender/collada/DocumentImporter.cpp.orig 2020-07-23 18:00:13.896584741 +0200
-+++ blender-2.79b/source/blender/collada/DocumentImporter.cpp 2020-07-23 18:00:52.486277028 +0200
-@@ -1349,5 +1349,5 @@
-
--#if OPENCOLLADA_WITH_ANIMATION_CLIP
-+#if WITH_OPENCOLLADA_ANIMATION_CLIP
- // Since opencollada 1.6.68
- // called on post-process stage after writeVisualScenes
- bool DocumentImporter::writeAnimationClip(const COLLADAFW::AnimationClip *AnimationClip)
diff --git a/media-gfx/blender/files/blender-2.79b-gcc-8.patch b/media-gfx/blender/files/blender-2.79b-gcc-8.patch
deleted file mode 100644
index 3a64ad2f796d..000000000000
--- a/media-gfx/blender/files/blender-2.79b-gcc-8.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- blender-2.79b-orig/intern/cycles/util/util_sseb.h 2018-03-24 02:22:25.000000000 +1100
-+++ blender-2.79b/intern/cycles/util/util_sseb.h 2018-05-30 20:43:33.888717930 +1000
-@@ -116,7 +116,7 @@
- __forceinline const sseb unpackhi( const sseb& a, const sseb& b ) { return _mm_unpackhi_ps(a, b); }
-
- template<size_t i0, size_t i1, size_t i2, size_t i3> __forceinline const sseb shuffle( const sseb& a ) {
-- return _mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0));
-+ return _mm_castsi128_ps(_mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0)));
- }
-
- template<> __forceinline const sseb shuffle<0, 1, 0, 1>( const sseb& a ) {
---- blender-2.79b-orig/intern/itasc/kdl/tree.hpp 2018-03-24 02:22:25.000000000 +1100
-+++ blender-2.79b/intern/itasc/kdl/tree.hpp 2018-05-30 20:33:52.045179988 +1000
-@@ -34,7 +34,7 @@
- //Forward declaration
- class TreeElement;
- // Eigen allocator is needed for alignment of Eigen data types
-- typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<std::string, TreeElement> > > SegmentMap;
-+ typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<const std::string, TreeElement> > > SegmentMap;
-
- class TreeElement
- {
diff --git a/media-gfx/blender/files/blender-fix-install-rules.patch b/media-gfx/blender/files/blender-fix-install-rules.patch
deleted file mode 100644
index e62aba814b9f..000000000000
--- a/media-gfx/blender/files/blender-fix-install-rules.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -purN a/source/creator/CMakeLists.txt b/source/creator/CMakeLists.txt
---- a/source/creator/CMakeLists.txt 2016-09-28 10:26:55.000000000 +0100
-+++ b/source/creator/CMakeLists.txt 2016-10-03 12:17:08.938928486 +0100
-@@ -328,12 +328,6 @@ endif()
- # Install Targets (Generic, All Platforms)
-
-
--# important to make a clean install each time, else old scripts get loaded.
--install(
-- CODE
-- "file(REMOVE_RECURSE ${TARGETDIR_VER})"
--)
--
- if(WITH_PYTHON)
- # install(CODE "message(\"copying blender scripts...\")")
-