summaryrefslogtreecommitdiff
path: root/media-gfx/brscan4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /media-gfx/brscan4
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'media-gfx/brscan4')
-rw-r--r--media-gfx/brscan4/Manifest4
-rw-r--r--media-gfx/brscan4/brscan4-0.4.10.1.ebuild70
-rw-r--r--media-gfx/brscan4/metadata.xml10
3 files changed, 84 insertions, 0 deletions
diff --git a/media-gfx/brscan4/Manifest b/media-gfx/brscan4/Manifest
new file mode 100644
index 000000000000..06dc3c8a520a
--- /dev/null
+++ b/media-gfx/brscan4/Manifest
@@ -0,0 +1,4 @@
+DIST brscan4-0.4.10-1.i386.rpm 100151 BLAKE2B 94fd7daa5682b294740a6e1345c4ab8d488589896c3fa34eafc131b1cdc2ef2e022e11795ebc261538c6107583602a9622946ea049a3cfbbeb547e7e9c8825ad SHA512 5daeb9a1304f3aeb0a2e17823887a546ff872dfb42bf08ab403539815553da597504ac7afcbb2a34fbcfd8d973c03c8ca2c62617f8c499b9fc44b1719e4f2611
+DIST brscan4-0.4.10-1.x86_64.rpm 118863 BLAKE2B 1e518122b049a6cd594e4603311d37f289aef4ad3973cbe846700c2a5c0c8f0ec994f6608817a1c12d6494c3ae78178b43f4ba8450ab00153e27f533ec1957c8 SHA512 c648db8d8543dec9e1cd556f2e0415c170c06935febd1373d783191b159ed9ed67043644ef81fb18027de89270e10a5cedcee11ea66ee262df1a2d4f006e4875
+EBUILD brscan4-0.4.10.1.ebuild 2000 BLAKE2B f5c827106cb0d556308239d846fcbeeaa276589b77370a63945df99c091c8c531ea7fd3ed85cb8c9ffcf2dabb616f716334dd98fc77bebafe3b4d4c3b0b2ba4a SHA512 799d059557810a9ecd686d242629a552380c5f14896b43985d4e089533fd78880da0b7d60bb8cfdb4067748c971716b8d3c18374eccc7ffc1b4251bc4b3490a3
+MISC metadata.xml 290 BLAKE2B 7b33307843dfe1ad587233554236500ada8d39e8d22f41d491a09201c502583456267c40332cfc3b0be3d5f703c6dc9be3dd41d325a60aa0c231b0fd2794f623 SHA512 c5fc92f0260d536d70d042d043c3925e7b207efa8c53b5a76f642ed42228df8e957837bb2bd7b735b4067ea779fa679212ff782a0391cdeb518b6b45247658f8
diff --git a/media-gfx/brscan4/brscan4-0.4.10.1.ebuild b/media-gfx/brscan4/brscan4-0.4.10.1.ebuild
new file mode 100644
index 000000000000..7a1df035f4c1
--- /dev/null
+++ b/media-gfx/brscan4/brscan4-0.4.10.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eapi8-dosym readme.gentoo-r1 rpm
+
+MY_P="${PN}-${PV%.*}-${PV##*.}"
+DESCRIPTION="Brother scanner driver"
+HOMEPAGE="https://www.brother.com/"
+SRC_URI="
+ amd64? ( https://download.brother.com/welcome/dlf105203/${MY_P}.x86_64.rpm )
+ x86? ( https://download.brother.com/welcome/dlf105202/${MY_P}.i386.rpm )"
+S="${WORKDIR}/opt/brother/scanner/${PN}"
+
+LICENSE="Brother"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="zeroconf"
+RESTRICT="strip"
+
+RDEPEND="media-gfx/sane-backends
+ virtual/libusb:0
+ zeroconf? ( net-dns/avahi )"
+
+QA_PREBUILT="/opt/brother/*"
+
+src_install() {
+ local dest=/opt/brother/scanner/${PN}
+ local lib=$(get_libdir)
+
+ insinto /etc${dest}
+ doins Brsane4.ini brsanenetdevice4.cfg
+ doins -r models4
+ dosym8 -r {/etc,}${dest}/Brsane4.ini
+ dosym8 -r {/etc,}${dest}/brsanenetdevice4.cfg
+ dosym8 -r {/etc,}${dest}/models4
+
+ exeinto ${dest}
+ doexe brsaneconfig4
+ dosym8 -r {${dest},/usr/bin}/brsaneconfig4
+
+ if use zeroconf; then
+ doexe brscan_cnetconfig
+ # Don't install brscan_gnetconfig because it depends on gtk+:2
+ fi
+
+ into ${dest}
+ dolib.so "${WORKDIR}"/usr/${lib}/sane/libsane-brother4.so.1.0.7
+ dosym libsane-brother4.so.1.0.7 ${dest}/${lib}/libsane-brother4.so.1
+ dosym libsane-brother4.so.1.0.7 ${dest}/${lib}/libsane-brother4.so
+ dosym8 -r {${dest}/${lib},/usr/${lib}/sane}/libsane-brother4.so.1.0.7
+ dosym libsane-brother4.so.1.0.7 /usr/${lib}/sane/libsane-brother4.so.1
+ dosym libsane-brother4.so.1.0.7 /usr/${lib}/sane/libsane-brother4.so
+
+ insinto /etc/sane.d/dll.d
+ newins - ${PN} <<< "brother4"
+
+ local DOC_CONTENTS="If want to use a remote scanner over the network,
+ you will have to add it with \"brsaneconfig4\"."
+ use zeroconf || DOC_CONTENTS+="\\n\\nNote that querying the network
+ (\"brsaneconfig4 -q\") will not work unless you emerge ${PN} with
+ the zeroconf flag enabled."
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/media-gfx/brscan4/metadata.xml b/media-gfx/brscan4/metadata.xml
new file mode 100644
index 000000000000..5bd0c1a7db5c
--- /dev/null
+++ b/media-gfx/brscan4/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<maintainer type="person">
+ <email>mattst88@gentoo.org</email>
+</maintainer>
+</pkgmetadata>