summaryrefslogtreecommitdiff
path: root/media-gfx/curaengine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-gfx/curaengine
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-gfx/curaengine')
-rw-r--r--media-gfx/curaengine/Manifest4
-rw-r--r--media-gfx/curaengine/curaengine-4.12.1.ebuild85
-rw-r--r--media-gfx/curaengine/curaengine-4.13.1.ebuild85
3 files changed, 174 insertions, 0 deletions
diff --git a/media-gfx/curaengine/Manifest b/media-gfx/curaengine/Manifest
index 08e706a19776..b0d38803191f 100644
--- a/media-gfx/curaengine/Manifest
+++ b/media-gfx/curaengine/Manifest
@@ -1,3 +1,7 @@
+DIST curaengine-4.12.1.tar.gz 1726565 BLAKE2B be231ec43792e1f27a6c720444c6755f71bbc3dbaea45b714c73f9b5b51753d58dafeef7ad2ed1bc21de1c39fe9f2a325ab8b85d3eb5b7f075a472dac98654b7 SHA512 c0c703ec9c7fb05389806f45174d45dd65bece169e3ad88aa1744091ce3c3c1e1e4f5af32cb55cfa9f1a4a8bffe0a008d5924a6e5d02baed00996c9112fbafef
+DIST curaengine-4.13.1.tar.gz 1727935 BLAKE2B d306f990b86e6120705b36eba6f3363adc67cf8c93c66c2da506c1ee461a5a6bdd27a4e04880daeb6cebab3ecc736d9a52eec27bf17aa9f032237a4c8ee1d2a3 SHA512 224379a40e26ae0026a3849d582353e49edf99520401e1fef56c9504638c68c62cfe394dab0eb40e4a447bfe0bfa506a880512e84fd6057a839b6384087c46d0
DIST curaengine-4.9.1.tar.gz 1694141 BLAKE2B 84119a2dd66340bdc3a4bd58384f300fb839aa7c5920de87d070945d3c436ace0f8686cd907a204e5825bdc17809d9f9052e37fb96b37e34a20650ca625d7b1e SHA512 cfa918c6301c9948713306256d74a2a84a1fefbc0f85c7ac0eb182d8363f1eae97aecdcb91c207a2e7e1ab252f63cf4b513734b50d4229da7aa35e095ef88bee
+EBUILD curaengine-4.12.1.ebuild 2220 BLAKE2B 8827c7d543d55beb31f90606024fecc342c047c32936ceefade82379149b03013f7606dd9a0319b987babf765904682363d6125e795ba082e8478d87b13f2e2b SHA512 7998abd636444b16c46f162a7758381aa80785c8d8ff3d0759206205fb180393b733578cb0160ab562125a066298c50e5d1ff1ba8fda7b953205012caf487f24
+EBUILD curaengine-4.13.1.ebuild 2221 BLAKE2B 54990c7547fc08f3822b552db6a5acccae1e917eab49464a511fa7ad72cb08b5ec9c9f667284521da3a4c1ea4c2362919563defc75485f84461f1748178a70c1 SHA512 50b2d3cfb0c21eb6b515b6ce0c5672022b2345bab233ddb1e418fb69238a201bc5df9b48fa822ce01413f0a7b240138cfdf837a5b2a1cced43d079ce85f233a6
EBUILD curaengine-4.9.1.ebuild 2237 BLAKE2B 274b913f4d176da6a60d9fc2512b0d8af969b725c12620ff80944e612a6d22914fad70c8797e97f4565c2fd899f6b968a0e187d7d600d83f6af1aac6a7714230 SHA512 7dfefefdb83de79c468015c8b5567177aec516fdc2f3279cdc221534e7ccfb30588744224201d6c19eee6bd4c27247137dfd3bcdf7c1ddbc002495fe305fd7a5
MISC metadata.xml 1581 BLAKE2B c9ae9c37944858a1d85bbc2f8d2eef0be6a4a53be186f7bf189eb9d89880a4e4954c03e542fd3d7b641faf5352114453fc4a6b7bfbe4e59becb90be5bcda5c6e SHA512 a90487d6d8b44aa0e944e843e4e1d0b17dc49c82f61dbd053290a2e7caa5b175cb5d7d65eb623d28cddc5e5019b25444823d5dfee8bea30a7cb1669a9f865347
diff --git a/media-gfx/curaengine/curaengine-4.12.1.ebuild b/media-gfx/curaengine/curaengine-4.12.1.ebuild
new file mode 100644
index 000000000000..98b1c9901eb8
--- /dev/null
+++ b/media-gfx/curaengine/curaengine-4.12.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="CuraEngine"
+
+DESCRIPTION="A 3D model slicing engine for 3D printing"
+HOMEPAGE="https://github.com/Ultimaker/CuraEngine"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+IUSE="+arcus doc openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ arcus? (
+ ~dev-libs/libarcus-${PV}:*
+ dev-libs/protobuf:=
+ )
+ dev-libs/clipper
+ dev-libs/rapidjson
+ dev-libs/stb"
+
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( README.md )
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ rm -r "${S}"/libs || die
+
+ # remove static linking
+ # respect cflags
+ sed -i \
+ -e "s/-static-libstdc++//g" \
+ -e 's/set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")//g' \
+ -e 's/set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE_INIT}")//g' \
+ CMakeLists.txt || die
+
+ if use test; then
+ find "${S}"/tests/arcus "${S}"/tests/integration "${S}"/tests/settings "${S}"/tests/utils \
+ -type f -name '*.cpp' | xargs sed -i \
+ -e 's <../src/utils/AABB.h> "../../src/utils/AABB.h" g'\
+ -e 's <../src/utils/IntPoint.h> "../../src/utils/IntPoint.h" g' \
+ -e 's <../src/utils/polygon.h> "../../src/utils/polygon.h" g'\
+ -e 's <../src/utils/PolygonConnector.h> "../../src/utils/PolygonConnector.h" g'\
+ -e 's <../src/utils/polygonUtils.h> "../../src/utils/polygonUtils.h" g'\
+ -e 's <../src/utils/string.h> "../../src/utils/string.h" g' \
+ -e 's <../src/utils/SVG.h> "../../src/utils/SVG.h" g' \
+ -e 's#include "../src#include "../../src#g'|| die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test ON OFF)
+ -DENABLE_ARCUS=$(usex arcus ON OFF)
+ -DENABLE_MORE_COMPILER_OPTIMIZATION_FLAGS=OFF
+ -DENABLE_OPENMP=$(usex openmp ON OFF)
+ -DUSE_SYSTEM_LIBS=ON
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc; then
+ doxygen || die "generating docs failed"
+ mv docs/html . || die
+ find html -type f '(' -name '*.md5' -o -name '*.map' ')' -delete || die
+ HTML_DOCS=( html/. )
+ fi
+}
diff --git a/media-gfx/curaengine/curaengine-4.13.1.ebuild b/media-gfx/curaengine/curaengine-4.13.1.ebuild
new file mode 100644
index 000000000000..5d9281bd5518
--- /dev/null
+++ b/media-gfx/curaengine/curaengine-4.13.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="CuraEngine"
+
+DESCRIPTION="A 3D model slicing engine for 3D printing"
+HOMEPAGE="https://github.com/Ultimaker/CuraEngine"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+arcus doc openmp test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ arcus? (
+ ~dev-libs/libarcus-${PV}:*
+ dev-libs/protobuf:=
+ )
+ dev-libs/clipper
+ dev-libs/rapidjson
+ dev-libs/stb"
+
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( README.md )
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ rm -r "${S}"/libs || die
+
+ # remove static linking
+ # respect cflags
+ sed -i \
+ -e "s/-static-libstdc++//g" \
+ -e 's/set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")//g' \
+ -e 's/set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE_INIT}")//g' \
+ CMakeLists.txt || die
+
+ if use test; then
+ find "${S}"/tests/arcus "${S}"/tests/integration "${S}"/tests/settings "${S}"/tests/utils \
+ -type f -name '*.cpp' | xargs sed -i \
+ -e 's <../src/utils/AABB.h> "../../src/utils/AABB.h" g'\
+ -e 's <../src/utils/IntPoint.h> "../../src/utils/IntPoint.h" g' \
+ -e 's <../src/utils/polygon.h> "../../src/utils/polygon.h" g'\
+ -e 's <../src/utils/PolygonConnector.h> "../../src/utils/PolygonConnector.h" g'\
+ -e 's <../src/utils/polygonUtils.h> "../../src/utils/polygonUtils.h" g'\
+ -e 's <../src/utils/string.h> "../../src/utils/string.h" g' \
+ -e 's <../src/utils/SVG.h> "../../src/utils/SVG.h" g' \
+ -e 's#include "../src#include "../../src#g'|| die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test ON OFF)
+ -DENABLE_ARCUS=$(usex arcus ON OFF)
+ -DENABLE_MORE_COMPILER_OPTIMIZATION_FLAGS=OFF
+ -DENABLE_OPENMP=$(usex openmp ON OFF)
+ -DUSE_SYSTEM_LIBS=ON
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ if use doc; then
+ doxygen || die "generating docs failed"
+ mv docs/html . || die
+ find html -type f '(' -name '*.md5' -o -name '*.map' ')' -delete || die
+ HTML_DOCS=( html/. )
+ fi
+}