summaryrefslogtreecommitdiff
path: root/media-gfx/dpic/dpic-20160824.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/dpic/dpic-20160824.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/dpic/dpic-20160824.ebuild')
-rw-r--r--media-gfx/dpic/dpic-20160824.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/dpic/dpic-20160824.ebuild b/media-gfx/dpic/dpic-20160824.ebuild
new file mode 100644
index 000000000000..c102eef74e4c
--- /dev/null
+++ b/media-gfx/dpic/dpic-20160824.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Converts PIC plots into pstricks, PGF/TikZ, PostScript, MetaPost and TeX"
+HOMEPAGE="https://ece.uwaterloo.ca/~aplevich/dpic"
+SRC_URI="https://ece.uwaterloo.ca/~aplevich/dpic/${PN}-2016.08.24.tar.gz"
+
+# dpic: BSD-2, dpicdoc.pdf: CC-BY-3.0, p2c: GPL
+LICENSE="BSD-2 CC-BY-3.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-2016.08.24"
+
+DOCS=( "README" "doc/dpicdoc.pdf" )
+
+src_install () {
+ dobin ${PN}
+ doman doc/${PN}.1
+
+ einstalldocs
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}