summaryrefslogtreecommitdiff
path: root/media-gfx/eog-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /media-gfx/eog-plugins
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest2
-rw-r--r--media-gfx/eog-plugins/eog-plugins-42.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 330ed7da241d..a95b0cffd5cd 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,3 +1,5 @@
DIST eog-plugins-3.26.8.tar.xz 479356 BLAKE2B ab781311473e045ffbb88e741427ac59f129fa53e6c551231d7b6edae81d21483dd1f1e7874561dfa29c9e9b2ba01fbdb174302bf8363478b785ec2ce38c53ec SHA512 a58aa849b09761dd0c7f7d31098560969872b03788f3f3ee81445dfb9be653b29e0e6646abc4e0164e4146abf7a9d2e6aadf56071f71c119493dcf1fd706a069
+DIST eog-plugins-42.0.tar.xz 132008 BLAKE2B 0dbe9ddcdf8f9a7f4da46caffe091a5d6e09327e1277b41474ecf8a3ec63ee7217fdc0cbafd1c47007f83b8ae30f30d91031c76f31473df79cda01aee23314ea SHA512 297b31fefa28f4eda73734ddcdb7702b9c9fa3493b4c13d3bf013e24ddb9015299bcd8f2af6a1976c4bf8c694fea0cc9699e82755d5e0689e71738a6d2fb2fe4
EBUILD eog-plugins-3.26.8.ebuild 1725 BLAKE2B f685d824292edc02b08cb0b2adc7d68fff1ef2868c742be61be0ff579795ebd3514f46a2594cc0d7d42eb8b95ee903a733ce88e9b2eca889944e08670c3480c2 SHA512 57604bd1094981357339c5a1382a21a517cd4538c09189a65e1927c61b63363ab36519c52cb99cf9a003e62ff887080b272a39bf4214050b7532749747da03c3
+EBUILD eog-plugins-42.0.ebuild 1681 BLAKE2B 95fdd675235a22c6800fff0d27f95ba3ec2e1c6802a7ded06e07c249a1c1e6c2d58c529c75c60bf1a8add7ec9d147de74226c6ec1df818c191dd0f949c3ef12c SHA512 a71006c09e8e82f7e6f2a8789f0ea0d893f6246f451b295f7093786eb84af307a9ec4098f2d35dbda371364ecc79801c2def9ea41bb9f239b820fc4f49c7dbdd
MISC metadata.xml 429 BLAKE2B 61e0c5a268c0dbcb1a2b0a0e1d0ceb1b7795db34e022ba9229015ecf05210dcdd247c2c9867549f5c75028dcb20011f7757fd9b4ef507af65b80aa8aa1ca6f18 SHA512 d4b81d9f78bf49afe842990d9c1c9dde1c3f1bc68090f77dde1bd51b2be98ab647be10f8886da7dcc1831cabc4f7c81b18b7e6e5cadb2c5aeeec69db883509bf
diff --git a/media-gfx/eog-plugins/eog-plugins-42.0.ebuild b/media-gfx/eog-plugins/eog-plugins-42.0.ebuild
new file mode 100644
index 000000000000..ae3bb0bb211a
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-42.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map picasa +python"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1:=
+ >=media-gfx/eog-41.0
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ picasa? ( >=dev-libs/libgdata-0.9.1:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:=[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ $(meson_use picasa plugin_postasa)
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}