summaryrefslogtreecommitdiff
path: root/media-gfx/eog-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /media-gfx/eog-plugins
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'media-gfx/eog-plugins')
-rw-r--r--media-gfx/eog-plugins/Manifest2
-rw-r--r--media-gfx/eog-plugins/eog-plugins-44.1.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/media-gfx/eog-plugins/Manifest b/media-gfx/eog-plugins/Manifest
index 3dd8dba8660d..61d2f6cdb77b 100644
--- a/media-gfx/eog-plugins/Manifest
+++ b/media-gfx/eog-plugins/Manifest
@@ -1,3 +1,5 @@
DIST eog-plugins-44.0.tar.xz 134544 BLAKE2B db384d949f2a63cb0fcdf1bdfb8ed4c5c97af88d21079af5de7560b3c3bab231a6361ae459727a9b9f31b49e63f7cd227f465a1a7b8e2bc55e8d7a08f0335ed9 SHA512 2955830aa60a3518869ec1af7a9f0c455277b0a571cb14a5e5926b52b80ed0443e91f28e270feffcf26066e1e9b6080c9a457b55175051c20838c8b80e2da195
+DIST eog-plugins-44.1.tar.xz 136392 BLAKE2B b46a8f283798f83b43a82c53c29b98182e7069cf4f5771ba1b5e888c285ddc10dd98fd81eeb8e4350ddf4b8fb0a0c4158673bcf920810e72dc8895ee61835014 SHA512 63fee6b9f1809a7c435ff27649805746d98b3e25c5a8fe2dd0146f7748d33b140c7f5b64598ff0bea427a55bb39d990c5ca19e975cf6bb8ec234f46937b50f29
EBUILD eog-plugins-44.0-r2.ebuild 1732 BLAKE2B f4f53e38b582786e1b34f0d7c7d8aa4c2e75faa7ac119787533ca083b318b6930e66a28134b6ddc97c3bc0ac1ad7a287768133e5e459e0f80720c4126315dcc3 SHA512 8b42bab9a43fb050b9e086800caa29676478fe39c00e9b2f9c81806937d7c886ea82ab94ff8b9ed341359579f34bc6bd437817c75307f8771ad31ac33bf710b0
+EBUILD eog-plugins-44.1.ebuild 1687 BLAKE2B e6145c71bb1ebef03303204487b672c5352cdd71a1c8af412b2ebb624a271524b2197b96084b9f748f210bcfc5cc242e90d90e20c8b42788a1bb5cf99f4427b8 SHA512 1e68dbb7fe49c72241bf6408d32030ca588f908abc841853f74774879d8b73a0e29ab9521609e913cb3cadf48af22a1b59606fee3d3282f42440d9fe438322b5
MISC metadata.xml 463 BLAKE2B 5ac26843df7d902ad1f64f5e9815b9d31437ed02c1a97ef9c33b6abaaa653b833977bd191d7e12d0fd6aaa1a0a95a01d39402417c241a5e7ccc8a8fbe159430b SHA512 bd40d362b9017a8546cff63bb144707a8b275337f72ea45977381aa9db81361e2eb114a66ca02b8b0dbbb82f1bd1ee2e7eafd25cd309e1c79b575e0bee500694
diff --git a/media-gfx/eog-plugins/eog-plugins-44.1.ebuild b/media-gfx/eog-plugins/eog-plugins-44.1.ebuild
new file mode 100644
index 000000000000..ac59330849d4
--- /dev/null
+++ b/media-gfx/eog-plugins/eog-plugins-44.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org meson python-single-r1
+
+DESCRIPTION="Eye of GNOME plugins"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/eog-plugins"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+exif map +python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ map? ( exif )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ >=dev-libs/glib-2.53.4:2
+ >=dev-libs/libpeas-1.14.1:0
+ >=media-gfx/eog-41.0:1
+ exif? ( >=media-libs/libexif-0.6.16 )
+ map? (
+ media-libs/libchamplain:0.12[gtk]
+ >=media-libs/clutter-1.9.4:1.0
+ >=media-libs/clutter-gtk-1.1.2:1.0
+ )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/glib[dbus]
+ dev-libs/libpeas:0[gtk,python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gsettings-desktop-schemas
+ media-gfx/eog[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/appstream-glib )"
+BDEPEND="
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use exif plugin_exif-display)
+ $(meson_use python plugin_export-to-folder)
+ -Dplugin_fit-to-width=true
+ $(meson_use python plugin_fullscreenbg)
+ -Dplugin_light-theme=true
+ $(meson_use map plugin_map)
+ $(meson_use python plugin_maximize-windows)
+ -Dplugin_postasa=false
+ -Dplugin_postr=false
+ $(meson_use python plugin_pythonconsole)
+ -Dplugin_send-by-mail=true
+ $(meson_use python plugin_slideshowshuffle)
+ )
+ meson_src_configure
+}