summaryrefslogtreecommitdiff
path: root/media-gfx/exiv2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /media-gfx/exiv2/files
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'media-gfx/exiv2/files')
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26_p20180319-clang-fix.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/exiv2/files/exiv2-0.26_p20180319-clang-fix.patch b/media-gfx/exiv2/files/exiv2-0.26_p20180319-clang-fix.patch
new file mode 100644
index 000000000000..a80543a5ecd7
--- /dev/null
+++ b/media-gfx/exiv2/files/exiv2-0.26_p20180319-clang-fix.patch
@@ -0,0 +1,47 @@
+From 176ba44cc31064183fdfbce55a7dd7e6b5e2a962 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Dan=20=C4=8Cerm=C3=A1k?= <dan.cermak@cgc-instruments.com>
+Date: Fri, 8 Jun 2018 23:46:04 +0200
+Subject: [PATCH] Fix C & C++ flag adding in CMakeLists.txt
+
+---
+ CMakeLists.txt | 22 ++++++++++++----------
+ 1 file changed, 12 insertions(+), 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2e179bf5..98a172ed 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -74,21 +74,23 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/config/")
+
+ if( MINGW OR UNIX )
+ if (${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
+- ADD_DEFINITIONS(-Wall
+- -Wcast-align
+- -Wpointer-arith
+- -Wformat-security
+- -Wmissing-format-attribute
+- -Woverloaded-virtual
+- -W
+- )
++ string(CONCAT WARNING_FLAGS " -Wall"
++ " -Wcast-align"
++ " -Wpointer-arith"
++ " -Wformat-security"
++ " -Wmissing-format-attribute"
++ " -Woverloaded-virtual"
++ " -W"
++ )
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${WARNING_FLAGS}")
++ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${WARNING_FLAGS}")
+ ENDIF()
+
+ message(STATUS "Compiler info: ${CMAKE_CXX_COMPILER_ID} (${CMAKE_CXX_COMPILER}) ; version: ${CMAKE_CXX_COMPILER_VERSION}")
+ IF ( CYGWIN OR (CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 5.0))
+- ADD_DEFINITIONS( -std=gnu++98 ) # to support snprintf
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++98" ) # to support snprintf
+ ELSE()
+- ADD_DEFINITIONS( -std=c++98 )
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++98" )
+ ENDIF()
+
+ ENDIF( MINGW OR UNIX ) \ No newline at end of file