summaryrefslogtreecommitdiff
path: root/media-gfx/flameshot/flameshot-12.0.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-26 06:14:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-26 06:14:16 +0100
commitd5d36fc823b7189d033e69314ae2764f1eed9168 (patch)
tree7ad153046482fd6c121d0654933c134a72aab4d6 /media-gfx/flameshot/flameshot-12.0.0-r2.ebuild
parent81a92c310907a51d2a03b6d470f4276a7d7ac00c (diff)
gentoo auto-resync : 26:04:2023 - 06:14:16
Diffstat (limited to 'media-gfx/flameshot/flameshot-12.0.0-r2.ebuild')
-rw-r--r--media-gfx/flameshot/flameshot-12.0.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/flameshot/flameshot-12.0.0-r2.ebuild b/media-gfx/flameshot/flameshot-12.0.0-r2.ebuild
new file mode 100644
index 000000000000..708edafe52aa
--- /dev/null
+++ b/media-gfx/flameshot/flameshot-12.0.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Powerful yet simple to use screenshot software"
+HOMEPAGE="https://flameshot.org https://github.com/flameshot-org/flameshot"
+SRC_URI="https://github.com/flameshot-org/flameshot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 Free-Art-1.3 GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="wayland"
+
+DEPEND="
+ =dev-qt/qtsingleapplication-2.6*[qt5(+),X]
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ sys-apps/dbus
+ wayland? ( kde-frameworks/kguiaddons:5 )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ rm -r external/singleapplication || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_EXTERNAL_SINGLEAPPLICATION=1
+ -DENABLE_CACHE=0
+ -DUSE_WAYLAND_CLIPBOARD=$(usex wayland)
+ )
+
+ cmake_src_configure
+}