summaryrefslogtreecommitdiff
path: root/media-gfx/frogr/frogr-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-20 20:08:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-20 20:08:51 +0000
commitd3419aa304ff2564036398be5e8ed4bdeaeaa007 (patch)
tree40ed2d4f8dd5f80c5647645dc91bb22deb7c4d8a /media-gfx/frogr/frogr-1.8.1.ebuild
parent6aa0d33a65c735f3148967b62316c2e71f43589a (diff)
gentoo auto-resync : 20:01:2024 - 20:08:51
Diffstat (limited to 'media-gfx/frogr/frogr-1.8.1.ebuild')
-rw-r--r--media-gfx/frogr/frogr-1.8.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/frogr/frogr-1.8.1.ebuild b/media-gfx/frogr/frogr-1.8.1.ebuild
new file mode 100644
index 000000000000..472697bd7a66
--- /dev/null
+++ b/media-gfx/frogr/frogr-1.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="flickr applications for GNOME"
+HOMEPAGE="https://live.gnome.org/Frogr"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/json-glib-1.1.2
+ >=dev-libs/libgcrypt-1.5:=
+ >=dev-libs/libxml2-2.6.8:2
+ media-libs/gstreamer:1.0
+ >=media-libs/libexif-0.6.14
+ >=net-libs/libsoup-3.0:3.0
+ >=x11-libs/gtk+-3.16:3[introspection]
+ x11-libs/gdk-pixbuf:2
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+# TODO add a useflag for enable-video or header-bar???
+# libsoup2 option not needed
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}