summaryrefslogtreecommitdiff
path: root/media-gfx/gif2png/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:22:19 +0000
commitaa3411e241a201d53a2689766fe419f2756819f3 (patch)
treecc19adfde0a10aab1ab566c8dfe3c1616e5cc390 /media-gfx/gif2png/files
parentb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (diff)
gentoo resync : 24.03.2019
Diffstat (limited to 'media-gfx/gif2png/files')
-rw-r--r--media-gfx/gif2png/files/gif2png-2.5.12-makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/gif2png/files/gif2png-2.5.12-makefile.patch b/media-gfx/gif2png/files/gif2png-2.5.12-makefile.patch
new file mode 100644
index 000000000000..e99180f8686e
--- /dev/null
+++ b/media-gfx/gif2png/files/gif2png-2.5.12-makefile.patch
@@ -0,0 +1,42 @@
+Respect CFLAGS/LDFLAGS/DESTDIR and don't try to run missing tests.
+
+--- gif2png-2.5.12/Makefile
++++ gif2png-2.5.12/Makefile
+@@ -2,8 +2,7 @@
+
+ VERSION = $(shell sed -n <NEWS '/::/s/^\([^:]*\).*/\1/p' | head -1)
+
+-CFLAGS = -DVERSION=\"$(VERSION)\" -O2
+-LDFLAGS = -s
++CFLAGS = -DVERSION=\"$(VERSION)\"
+
+ SOURCES = 437_l1.c gif2png.c gifread.c memory.c version.c
+ OBJECTS = $(SOURCES:.c=.o)
+@@ -28,22 +27,19 @@
+ web2png.1: web2png.xml
+ xmlto man web2png.xml
+
+-check:
+- cd test; make --quiet test
+-
+ clean:
+ rm -f gif2png *.o gif2png.1 web2png.1
+
+ version:
+ @echo $(VERSION)
+
+-prefix?=/usr
++prefix ?= /usr
+
+ install: gif2png gif2png.1 web2png.1
+- mkdir -p $(prefix)/bin
+- mkdir -p $(prefix)/share/man/man1
+- cp gif2png web2png $(prefix)/bin/
+- cp gif2png.1 web2png.1 $(prefix)/share/man/man1/
++ mkdir -p $(DESTDIR)$(prefix)/bin
++ mkdir -p $(DESTDIR)$(prefix)/share/man/man1
++ cp gif2png web2png $(DESTDIR)$(prefix)/bin/
++ cp gif2png.1 web2png.1 $(DESTDIR)$(prefix)/share/man/man1/
+
+ uninstall:
+ rm $(prefix)/bin/gif2png $(prefix)/bin/web2png