summaryrefslogtreecommitdiff
path: root/media-gfx/gif2png
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /media-gfx/gif2png
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'media-gfx/gif2png')
-rw-r--r--media-gfx/gif2png/gif2png-2.5.14.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/gif2png/gif2png-2.5.14.ebuild b/media-gfx/gif2png/gif2png-2.5.14.ebuild
new file mode 100644
index 000000000000..41f89555dbb3
--- /dev/null
+++ b/media-gfx/gif2png/gif2png-2.5.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Converts images from gif format to png format"
+HOMEPAGE="http://catb.org/~esr/gif2png/"
+SRC_URI="http://catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND=">=media-libs/libpng-1.2:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}