summaryrefslogtreecommitdiff
path: root/media-gfx/gphoto2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
commit38b7258d086dd5e263c3bbe3880c8c956676bc71 (patch)
tree6fce284d5bfddaf597a490ac66069d16c6a485db /media-gfx/gphoto2
parent0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (diff)
gentoo resync : 25.01.2018
Diffstat (limited to 'media-gfx/gphoto2')
-rw-r--r--media-gfx/gphoto2/Manifest2
-rw-r--r--media-gfx/gphoto2/gphoto2-2.5.15.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/media-gfx/gphoto2/Manifest b/media-gfx/gphoto2/Manifest
index 311af5d1d891..4d1a7f0e9ee3 100644
--- a/media-gfx/gphoto2/Manifest
+++ b/media-gfx/gphoto2/Manifest
@@ -1,3 +1,5 @@
DIST gphoto2-2.5.14.tar.bz2 784442 BLAKE2B 185bd0d18e0b8d280c0ec366738850bd1fe2d1405179700fe25678c04a88b2092820aa5f049bcc6f97c964b5875bd32e3f8c7c5240ef3a71f2af04d6bfdaadb9 SHA512 47cb0d212673c9c0dbc996e0a67191a307599c844293a67184bd1529d9e3b417e154c6de64f4563f6f7e599a1bd6b127266f85f5baa97bd7d86922405bf45331
+DIST gphoto2-2.5.15.tar.bz2 790513 BLAKE2B e8a22d014ebd33f5e0976d72c5df8373e29106def5da575b69d21f2a58e9408c6ce399476135909e57111196d6e61ead953f66a00c9f440b7cf92e0da0f4a0f6 SHA512 46058a12a81379f3311911e103cf934b6eb616d7f81180615b385d01e855bf6ce998eb12811b9d032328ebed6acfc4456f3a383cfedb93c6967c9699654d4f40
EBUILD gphoto2-2.5.14.ebuild 1392 BLAKE2B d9dad5be797d3f5e2f789c42060c62499d59f8f8aa5129608eea7f023b0257a38d1d3e2d54b4889128f0a867368a3abcac4e3f47bddf98c675049f0b9f24f314 SHA512 6ef5220aaf64e480a95e71d5596093179a41d93912c1d17614034e4814832ba8788a1e282a8711096482eb94c284a65365fb85c67a748fb060a38ef921349a8c
+EBUILD gphoto2-2.5.15.ebuild 1399 BLAKE2B b49450a5c5695f093ef6cc2f8396e861320a12c7dac9edc1f0a2399c9b3347b5fc02e197e220d1f7ebc97cde4b81d382c0b5c601ba88ca47d4137f1c3f46562a SHA512 a1352287960faed91dcba03af16b7127b574442bdf9182646327081668c35e7c6dfe26cad16dc09af18c35660207b6963dddaa7660edae6e89bf183d0ae5d98c
MISC metadata.xml 449 BLAKE2B 324e2ea46a0f8199033bf628d6719a51968a02af01fa3e8abcd1caaf7a4dcd892bfb6b8347a030edf4b2e8529aba47d7103789103a3b03adaa538338ab2ec91f SHA512 f938819a203e0119b1d81aa1dc812717d6ef02c3012f8ed667db452c7712bb7b142cee36d519ec33f4cf65ebcba7a660e2f67f6b66087ec6be832a4987e10c53
diff --git a/media-gfx/gphoto2/gphoto2-2.5.15.ebuild b/media-gfx/gphoto2/gphoto2-2.5.15.ebuild
new file mode 100644
index 000000000000..8353fefc1836
--- /dev/null
+++ b/media-gfx/gphoto2/gphoto2-2.5.15.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Free, redistributable digital camera software application"
+HOMEPAGE="http://www.gphoto.org/"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="aalib exif ncurses nls readline"
+
+# aalib -> needs libjpeg
+RDEPEND="
+ dev-libs/popt
+ >=media-libs/libgphoto2-2.5.10:=[exif?]
+ aalib? (
+ media-libs/aalib
+ virtual/jpeg:0 )
+ exif? ( media-libs/libexif )
+ ncurses? ( dev-libs/cdk:0= )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.14.1 )
+"
+
+src_prepare() {
+ default
+ if ! use exif ; then
+ # Remove tests that require EXIF to pass, bug 610024
+ rm "${S}"/tests/data/test0{35,36,37,40}* || die
+ fi
+ # Leave GCC debug builds under user control
+ sed -r '/(C|LD)FLAGS/ s/ -g( |")/\1/' \
+ -i configure{.ac,} || die
+ eautoreconf
+}
+
+src_configure() {
+ CPPFLAGS="-I/usr/include/cdk" \
+ econf \
+ $(use_with aalib) \
+ $(use_with aalib jpeg) \
+ $(use_with exif libexif auto) \
+ $(use_with ncurses cdk) \
+ $(use_enable nls) \
+ $(use_with readline)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ HTML_DIR="${D}"/usr/share/doc/${PF}/sgml \
+ install
+
+ einstalldocs
+ rm -rf "${D}"/usr/share/doc/${PF}/sgml/gphoto2
+}