summaryrefslogtreecommitdiff
path: root/media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild')
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild133
1 files changed, 0 insertions, 133 deletions
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild
deleted file mode 100644
index 45f73976f1ad..000000000000
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.36.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools toolchain-funcs
-
-MY_P=${P/graphicsm/GraphicsM}
-DESCRIPTION="Collection of tools and libraries for many image formats"
-HOMEPAGE="http://www.graphicsmagick.org/ http://hg.code.sf.net/p/graphicsmagick/code/"
-LICENSE="MIT"
-SLOT="0/${PV%.*}"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit mercurial
- EHG_REPO_URI="http://hg.code.sf.net/p/${PN}/code"
-else
- SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
- S="${WORKDIR}/${MY_P}"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-fi
-
-IUSE="bzip2 +cxx debug dynamic-loading fpx imagemagick jbig jpeg lcms lzma
- openmp perl png postscript q16 q32 static-libs svg threads tiff truetype
- webp wmf X zlib"
-
-RDEPEND="
- dev-libs/libltdl:0
- bzip2? ( app-arch/bzip2 )
- fpx? ( media-libs/libfpx )
- imagemagick? ( !media-gfx/imagemagick )
- jbig? ( media-libs/jbigkit )
- jpeg? ( virtual/jpeg:0 )
- lcms? ( media-libs/lcms:2 )
- lzma? ( app-arch/xz-utils )
- perl? ( dev-lang/perl:= )
- png? ( media-libs/libpng:0= )
- postscript? ( app-text/ghostscript-gpl )
- svg? ( dev-libs/libxml2 )
- tiff? ( media-libs/tiff:0 )
- truetype? (
- media-fonts/urw-fonts
- >=media-libs/freetype-2
- )
- webp? ( media-libs/libwebp:= )
- wmf? ( media-libs/libwmf )
- X? (
- x11-libs/libSM
- x11-libs/libXext
- )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.3.36-flags.patch
- "${FILESDIR}"/${PN}-1.3.19-perl.patch
- "${FILESDIR}"/${PN}-1.3.36-bzip-no-zlib.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local depth=8
- use q16 && depth=16
- use q32 && depth=32
-
- local openmp=disable
- if use openmp && tc-has-openmp ; then
- openmp=enable
- fi
-
- local myeconfargs=(
- --${openmp}-openmp
- --enable-largefile
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable debug prof)
- $(use_enable debug gcov)
- $(use_enable imagemagick magick-compat)
- $(use_with threads)
- $(use_with dynamic-loading modules)
- --with-quantum-depth=${depth}
- --without-frozenpaths
- $(use_with cxx magick-plus-plus)
- $(use_with perl)
- --with-perl-options=INSTALLDIRS=vendor
- $(use_with bzip2 bzlib)
- $(use_with postscript dps)
- $(use_with fpx)
- $(use_with jbig)
- $(use_with webp)
- $(use_with jpeg)
- --without-jp2
- $(use_with lcms lcms2)
- $(use_with lzma)
- $(use_with png)
- $(use_with tiff)
- $(use_with truetype ttf)
- $(use_with wmf)
- --with-fontpath="${EPREFIX}"/usr/share/fonts
- --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts
- --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts
- $(use_with svg xml)
- $(use_with zlib)
- $(use_with X x)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- default
- use perl && emake perl-build
-}
-
-src_test() {
- unset DISPLAY # some perl tests fail when DISPLAY is set
- default
-}
-
-src_install() {
- default
-
- if use perl ; then
- emake -C PerlMagick DESTDIR="${D}" install
- find "${ED}" -type f -name perllocal.pod -exec rm -f {} + || die
- find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} + || die
- fi
-
- find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} + || die
-}