summaryrefslogtreecommitdiff
path: root/media-gfx/graphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
commit796e724b5ace96ff70d918765662edf62f1d8c85 (patch)
treeb09742996db0de2a2414587542b1b91d4ae5c522 /media-gfx/graphviz
parentcd7ab3ad114e9777d85ced67abdd5b25d0bd4efe (diff)
gentoo auto-resync : 09:07:2023 - 22:25:43
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/Manifest2
-rw-r--r--media-gfx/graphviz/graphviz-8.1.0.ebuild213
2 files changed, 215 insertions, 0 deletions
diff --git a/media-gfx/graphviz/Manifest b/media-gfx/graphviz/Manifest
index 2915e1e2174c..719a421d4524 100644
--- a/media-gfx/graphviz/Manifest
+++ b/media-gfx/graphviz/Manifest
@@ -1,3 +1,5 @@
DIST graphviz-8.0.5.tar.xz 21426200 BLAKE2B 0b84dd788c2e8ee54941c9093ad8b9208d30bb42f1b6c62afd136ddc4616c2a851ce78b62631ec8023b39bdb861c3aa3ecc89b1804dbd77f56530a1ab8217a5d SHA512 1bcde81cd8bb370e6b843b02eecc96459d7567ff982a2fc4a97b50b43dad45ac2d4d5fb5f5f629562585600256878dd81c7b4c51ab1691cb3b6f4dcc054c7443
+DIST graphviz-8.1.0.tar.xz 21429292 BLAKE2B ed70eb6edf9394409edea252eae3c882d69cac3dba6464f9dfcc33fffbffd7dfdea931efb5e25aab65f027022065757c5cf1bf805f794fd7368da1005dfcfde1 SHA512 56ce357999b7e7c623ec410eb772a98a23be2d7e871c5e6f500ea000d217714b8f6114d35844dac576e2dcb059f74037833e7728b85fc2c8fa67589e716a39e1
EBUILD graphviz-8.0.5.ebuild 6057 BLAKE2B ecc94d020ea95ab7d92d0807801a9a38ff186c208db70399ca1b261971777e032df819446756357ab42dec60848776797b2316cefd446a7844e289b6ba35cc11 SHA512 8c051bf8a9947ffaf62560c084347fa06d437b64d8d60911e7c5509df4d14a21c28254def43f2fbe73f86c80236c5239ce55aa36dcfa28dd4f5f7f156c8adb98
+EBUILD graphviz-8.1.0.ebuild 6066 BLAKE2B d8318a30b004ea67a12fc7ac0e1cec613e92d04b7dbfa462aa05bab2473ab30639915246bcc7beba308055fcf8d9a3963530021595ae91565b6d0185a513060a SHA512 f05ba385ee995833858407959bad314d86bab8c6f8ad637fc009d4b403756dbfcf1c066b2823d7cf22e774994b75c9d428079dbaab5d6847bda6c604681dfd3c
MISC metadata.xml 2324 BLAKE2B 206e5312317fb7bf8f4bba64196a6fa89a8a9e30be3b5e0bf598485cdc2a862e1cc302024b9d170aa6c8ebbbd429ab839d296076bc6f1ac3b154678773cd4d5f SHA512 8eb9a1508823a06fbb180755a7dd173cb2365d7d90e25ad211d56645ee213ee825a991ba56b3f1c8d952c0a7baaa1ea3f8d8d35bdedbffbdce608d66645dd2b0
diff --git a/media-gfx/graphviz/graphviz-8.1.0.ebuild b/media-gfx/graphviz/graphviz-8.1.0.ebuild
new file mode 100644
index 000000000000..9d1aaab6a8f5
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-8.1.0.ebuild
@@ -0,0 +1,213 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-single-r1
+
+DESCRIPTION="Open Source Graph Visualization Software"
+HOMEPAGE="https://www.graphviz.org/ https://gitlab.com/graphviz/graphviz/"
+# Unfortunately upstream uses an "artifact" store for the pre-generated
+# tarball now, which makes predictable URLs impossible.
+SRC_URI="https://gitlab.com/api/v4/projects/4207231/packages/generic/graphviz-releases/${PV}/${P}.tar.xz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+cairo devil doc examples gtk2 gts guile lasi nls pdf perl postscript python qt5 ruby svg tcl webp X"
+
+REQUIRED_USE="
+ !cairo? ( !X !gtk2 !postscript !lasi )
+ pdf? ( cairo )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Requires ksh, tests against installed package, missing files and directory
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/expat-2
+ >=dev-libs/glib-2.11.1:2
+ dev-libs/libltdl
+ >=media-libs/freetype-2.1.10
+ >=media-libs/gd-2.0.34:=[fontconfig,jpeg,png,truetype,zlib]
+ media-libs/libjpeg-turbo:=
+ >=media-libs/libpng-1.2:=
+ sys-libs/zlib
+ virtual/libiconv
+ cairo? (
+ >=x11-libs/cairo-1.1.10[svg(+)]
+ >=x11-libs/pango-1.12
+ )
+ devil? ( media-libs/devil[png,jpeg] )
+ gtk2? (
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+ gts? ( sci-libs/gts )
+ guile? ( dev-scheme/guile )
+ lasi? ( media-libs/lasi )
+ pdf? ( app-text/poppler )
+ perl? ( dev-lang/perl:= )
+ postscript? ( app-text/ghostscript-gpl )
+ python? ( ${PYTHON_DEPS} )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ )
+ ruby? ( dev-lang/ruby:* )
+ svg? ( gnome-base/librsvg )
+ tcl? ( >=dev-lang/tcl-8.3:= )
+ webp? ( media-libs/libwebp:= )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+ guile? (
+ dev-lang/swig
+ dev-scheme/guile
+ )
+ nls? ( >=sys-devel/gettext-0.14.5 )
+ perl? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )
+ tcl? ( dev-lang/swig )"
+
+# Dependency description / Maintainer info:
+
+# Rendering is done via the following plugins (/plugins):
+# - core, dot_layout, neato_layout, gd , dot
+# the ones which are always compiled in, depend on zlib, gd
+# - gtk
+# Directly depends on gtk-2.
+# needs 'pangocairo' enabled in graphviz configuration
+# gtk-2 depends on pango, cairo and libX11 directly.
+# - gdk-pixbuf
+# Directly depends on gtk-2 and gdk-pixbuf.
+# needs 'pangocairo' enabled in graphviz configuration
+# - ming
+# flash plugin via -Tswf requires media-libs/ming-0.4. Disabled as it's
+# incomplete.
+# - cairo/pango:
+# Needs pango for text layout, uses cairo methods to draw stuff
+# - xlib:
+# needs cairo+pango,
+# can make use of gnomeui and inotify support (??? unsure),
+# needs libXaw for UI
+# UI also links directly against libX11, libXmu, and libXt
+# and uses libXpm if available so we make sure it always is
+
+# There can be swig-generated bindings for the following languages (/tclpkg/gv):
+# - c-sharp (disabled)
+# - scheme (enabled via guile) ... no longer broken on ~x86
+# - go (disabled)
+# - io (disabled)
+# - lua (enabled via lua)
+# - ocaml (enabled via ocaml)
+# - perl (enabled via perl) *1
+# - php (enabled via php) *2
+# - python (enabled via python) *1
+# - ruby (enabled via ruby) *1
+# - tcl (enabled via tcl)
+# *1 = The ${P}-bindings.patch takes care that those bindings are installed to the right location
+# *2 = Those bindings don't build because the paths for the headers/libs aren't
+# detected correctly and/or the options passed to swig are wrong (-php instead of -php4/5)
+
+# There are several other tools in /tclpkg:
+# gdtclft, tcldot, tclhandle, tclpathplan, tclstubs ; enabled with: --with-tcl
+# tkspline, tkstubs ; enabled with: --with-tk
+
+# And the commands (/cmd):
+# - dot, gvedit, gvpr, smyrna, tools/* :)
+# sci-libs/gts can be used for some of these
+# - gvedit (via 'qt5'):
+# based on ./configure it needs qt-core and qt-gui only
+# - smyrna : experimental opengl front-end (via 'smyrna')
+# currently disabled -- it segfaults a lot
+# needs x11-libs/gtkglext, gnome-base/libglade, media-libs/freeglut
+# sci-libs/gts, x11-libs/gtk. Also needs 'gtk','glade','glut','gts' and 'png'
+# with flags enabled at configure time
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myconf=(
+ # Speeds up the libltdl configure
+ --cache-file="${S}"/config.cache
+ --enable-ltdl
+ $(use_enable doc man-pdfs)
+ $(use_with cairo pangocairo)
+ $(use_with examples demos '$(docdir)/examples')
+ $(use_with devil)
+ $(use_with gtk2 gdk)
+ $(use_with gtk2 gdk-pixbuf)
+ $(use_with gtk2)
+ $(use_with gts)
+ $(use_with qt5 qt)
+ $(use_with lasi)
+ $(use_with pdf poppler)
+ $(use_with postscript ghostscript)
+ $(use_with svg rsvg)
+ $(use_with webp)
+ $(use_with X x)
+ --with-digcola
+ --with-freetype2
+ --with-ipsepcola
+ --with-libgd
+ --with-sfdp
+ --without-ming
+ # New/experimental features, to be tested, disable for now
+ --without-ipsepcola
+ --without-smyrna
+ # Bindings
+ $(use_enable guile)
+ $(use_enable perl)
+ $(use_enable python python3)
+ $(use_enable ruby)
+ $(use_enable tcl)
+ --disable-go
+ --disable-lua
+ --disable-java
+ --disable-ocaml
+ --disable-php
+ --disable-python
+ --disable-r
+ --disable-sharp
+ # libtool file collision, bug #276609
+ --without-included-ltdl
+ --disable-ltdl-install
+ QMAKE=$(usev qt5 qmake5)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ use python && python_optimize \
+ "${D}"$(python_get_sitedir) \
+ "${ED}"/usr/$(get_libdir)/graphviz/python3
+}
+
+pkg_postinst() {
+ # We need to register all plugins before they become usable
+ dot -c || die
+}
+
+pkg_postrm() {
+ # Remove cruft, bug #547344
+ rm -rf "${EROOT}"/usr/$(get_libdir)/graphviz/config{,6} || die
+}