summaryrefslogtreecommitdiff
path: root/media-gfx/hydrus/hydrus-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
commit1494784ae35c6fa7b6a92a80dea93265fc54ccd0 (patch)
treedbbb1b83e130750c3a55a4287c3a2ec2bbff7af8 /media-gfx/hydrus/hydrus-9999.ebuild
parentee74b33422f15493c315bdacf20da95d5b936d3c (diff)
gentoo auto-resync : 18:06:2023 - 19:48:47
Diffstat (limited to 'media-gfx/hydrus/hydrus-9999.ebuild')
-rw-r--r--media-gfx/hydrus/hydrus-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-gfx/hydrus/hydrus-9999.ebuild b/media-gfx/hydrus/hydrus-9999.ebuild
index c78c948645a3..851d373d97a8 100644
--- a/media-gfx/hydrus/hydrus-9999.ebuild
+++ b/media-gfx/hydrus/hydrus-9999.ebuild
@@ -69,6 +69,8 @@ BDEPEND="
test? (
dev-python/httmock[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
+
+ dev-python/pyside2[widgets,gui,multimedia,${PYTHON_USEDEP}]
)
')
"
@@ -82,8 +84,6 @@ src_prepare() {
# Contains pre-built binaries for other systems and a broken swf renderer for linux
rm -r bin/ || die
- # Build files used for CI and development, not actually needed
- rm -r static/build_files static/requirements || die
# Python requirements file, not needed
rm requirements.txt || die
# Remove unneeded additional scripts
@@ -99,7 +99,7 @@ src_test() {
# The tests use unittest, but are run with a custom runner script.
# QT_QPA_PLATFORM is required to make them run without X
local -x QT_QPA_PLATFORM=offscreen
- "${EPYTHON}" "${S}/test.py" || die "Tests failed"
+ "${EPYTHON}" "${S}/hydrus_test.py" || die "Tests failed"
}
src_install() {
@@ -114,8 +114,11 @@ src_install() {
einstalldocs
# Files only needed for testing
- rm test.py hydrus/hydrus_test.py || die
+ rm hydrus_test.py hydrus/hydrus_test_boot.py || die
rm -r hydrus/test/ static/testing/ || die
+ # Build files used for CI and development, not actually needed. Has to be deleted after src_compile.
+ # because it contains documentation
+ rm -r static/build_files static/requirements || die
# ${DOCS[@]} files are copied into doc
# ${S}/docs/ is the markdown source code for documentation