summaryrefslogtreecommitdiff
path: root/media-gfx/hydrus/hydrus-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-07 18:14:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-07 18:14:11 +0000
commit7a027cd18c60d9abad83a60c98ccf27db26be067 (patch)
tree905c5e3c3ec66d8d756a71db384bdd7abf7a50f9 /media-gfx/hydrus/hydrus-9999.ebuild
parentd4d70691ab58dfcbd58e0863f3e64d59765533e3 (diff)
gentoo auto-resync : 07:01:2023 - 18:14:11
Diffstat (limited to 'media-gfx/hydrus/hydrus-9999.ebuild')
-rw-r--r--media-gfx/hydrus/hydrus-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/media-gfx/hydrus/hydrus-9999.ebuild b/media-gfx/hydrus/hydrus-9999.ebuild
index 1ecb76ea0b7b..063824a750b8 100644
--- a/media-gfx/hydrus/hydrus-9999.ebuild
+++ b/media-gfx/hydrus/hydrus-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"
DOCS_BUILDER=mkdocs
-DOCS_DEPEND="dev-python/mkdocs-material"
+DOCS_DEPEND="dev-python/mkdocs-material dev-python/regex"
inherit python-single-r1 desktop docs optfeature
@@ -58,6 +58,7 @@ RDEPEND="
dev-python/twisted[${PYTHON_USEDEP}]
media-libs/opencv[python,png,jpeg,${PYTHON_USEDEP}]
media-video/ffmpeg
+ media-video/mpv[libmpv,${PYTHON_USEDEP}]
>=dev-python/QtPy-1.9.0-r4[pyside2,${PYTHON_USEDEP}]
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
@@ -69,7 +70,6 @@ BDEPEND="
test? (
dev-python/httmock[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
)
')
"
@@ -83,10 +83,12 @@ src_prepare() {
# Contains pre-built binaries for other systems and a broken swf renderer for linux
rm -r bin/ || die
- # Build files used for CI, not actually needed
- rm -r static/build_files || die
- # Python requirements files, not needed
- rm requirements_*.txt || die
+ # Build files used for CI and development, not actually needed
+ rm -r static/build_files static/requirements || die
+ # Python requirements file, not needed
+ rm requirements.txt || die
+ # Remove unneeded additional scripts
+ rm *.command *.sh *.bat || die
}
src_compile() {