summaryrefslogtreecommitdiff
path: root/media-gfx/inkscape/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/inkscape/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/inkscape/files')
-rw-r--r--media-gfx/inkscape/files/inkscape-0.48.4-epython.patch11
-rw-r--r--media-gfx/inkscape/files/inkscape-0.91-fix-gtkmm-2.48.patch63
-rw-r--r--media-gfx/inkscape/files/inkscape-0.91_pre3-automagic.patch154
-rw-r--r--media-gfx/inkscape/files/inkscape-0.91_pre3-cppflags.patch14
-rw-r--r--media-gfx/inkscape/files/inkscape-0.91_pre3-desktop.patch20
-rw-r--r--media-gfx/inkscape/files/inkscape-0.91_pre3-exif.patch12
-rw-r--r--media-gfx/inkscape/files/inkscape-0.91_pre3-sk-man.patch15
-rw-r--r--media-gfx/inkscape/files/inkscape-0.92.1-automagic.patch154
-rw-r--r--media-gfx/inkscape/files/inkscape-0.92.1-desktop.patch12
9 files changed, 455 insertions, 0 deletions
diff --git a/media-gfx/inkscape/files/inkscape-0.48.4-epython.patch b/media-gfx/inkscape/files/inkscape-0.48.4-epython.patch
new file mode 100644
index 000000000000..2e2483c1b1e3
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.48.4-epython.patch
@@ -0,0 +1,11 @@
+--- inkscape-0.48.4/src/extension/implementation/script.cpp
++++ inkscape-0.48.4/src/extension/implementation/script.cpp
+@@ -89,7 +89,7 @@
+ #ifdef WIN32
+ {"python", "python-interpreter", "pythonw" },
+ #else
+- {"python", "python-interpreter", "python" },
++ {"python", "python-interpreter", "@EPYTHON@" },
+ #endif
+ {"ruby", "ruby-interpreter", "ruby" },
+ {"shell", "shell-interpreter", "sh" },
diff --git a/media-gfx/inkscape/files/inkscape-0.91-fix-gtkmm-2.48.patch b/media-gfx/inkscape/files/inkscape-0.91-fix-gtkmm-2.48.patch
new file mode 100644
index 000000000000..f9c06601e837
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.91-fix-gtkmm-2.48.patch
@@ -0,0 +1,63 @@
+--- a/src/ui/clipboard.cpp 2016-04-02 15:15:43 +0000
++++ b/src/ui/clipboard.cpp 2016-04-07 16:30:32 +0000
+@@ -146,8 +146,6 @@
+ void _setClipboardColor(guint32);
+ void _userWarn(SPDesktop *, char const *);
+
+- void _inkscape_wait_for_targets(std::list<Glib::ustring> &);
+-
+ // private properites
+ SPDocument *_clipboardSPDoc; ///< Document that stores the clipboard until someone requests it
+ Inkscape::XML::Node *_defs; ///< Reference to the clipboard document's defs node
+@@ -1302,9 +1300,7 @@
+ */
+ Glib::ustring ClipboardManagerImpl::_getBestTarget()
+ {
+- // GTKmm's wait_for_targets() is broken, see the comment in _inkscape_wait_for_targets()
+- std::list<Glib::ustring> targets; // = _clipboard->wait_for_targets();
+- _inkscape_wait_for_targets(targets);
++ std::list<Glib::ustring> targets = _clipboard->wait_for_targets();
+
+ // clipboard target debugging snippet
+ /*
+@@ -1456,39 +1452,6 @@
+ desktop->messageStack()->flash(Inkscape::WARNING_MESSAGE, msg);
+ }
+
+-
+-// GTKMM's clipboard::wait_for_targets is buggy and might return bogus, see
+-//
+-// https://bugs.launchpad.net/inkscape/+bug/296778
+-// http://mail.gnome.org/archives/gtk-devel-list/2009-June/msg00062.html
+-//
+-// for details. Until this has been fixed upstream we will use our own implementation
+-// of this method, as copied from /gtkmm-2.16.0/gtk/gtkmm/clipboard.cc.
+-void ClipboardManagerImpl::_inkscape_wait_for_targets(std::list<Glib::ustring> &listTargets)
+-{
+- //Get a newly-allocated array of atoms:
+- GdkAtom* targets = NULL;
+- gint n_targets = 0;
+- gboolean test = gtk_clipboard_wait_for_targets( gtk_clipboard_get(GDK_SELECTION_CLIPBOARD), &targets, &n_targets );
+- if (!test || (targets == NULL)) {
+- return;
+- }
+-
+- //Add the targets to the C++ container:
+- for (int i = 0; i < n_targets; i++)
+- {
+- //Convert the atom to a string:
+- gchar* const atom_name = gdk_atom_name(targets[i]);
+-
+- Glib::ustring target;
+- if (atom_name) {
+- target = Glib::ScopedPtr<char>(atom_name).get(); //This frees the gchar*.
+- }
+-
+- listTargets.push_back(target);
+- }
+-}
+-
+ /* #######################################
+ ClipboardManager class
+ ####################################### */
+
diff --git a/media-gfx/inkscape/files/inkscape-0.91_pre3-automagic.patch b/media-gfx/inkscape/files/inkscape-0.91_pre3-automagic.patch
new file mode 100644
index 000000000000..e29b7e9f787e
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.91_pre3-automagic.patch
@@ -0,0 +1,154 @@
+Respect configure option for openmp and add configure options for aspell,
+gtkspell, imagemagick, jpeg, and exif.
+
+--- inkscape-0.91pre3/configure.ac
++++ inkscape-0.91pre3/configure.ac
+@@ -233,19 +233,28 @@
+ dnl Check for OpenMP
+ dnl ******************************
+ AC_OPENMP
+-if test "x$ac_cv_prog_cxx_openmp" != "xunsupported"; then
+- openmp_ok=yes
+- dnl We have it, now set up the flags
+- CXXFLAGS="$CXXFLAGS $OPENMP_CXXFLAGS"
+- AC_DEFINE(HAVE_OPENMP, 1, [Use OpenMP])
++openmp_ok="no"
++if test "x$enable_openmp" = "xyes"; then
++ if test "x$ac_cv_prog_cxx_openmp" != "xunsupported"; then
++ openmp_ok=yes
++ dnl We have it, now set up the flags
++ CXXFLAGS="$CXXFLAGS $OPENMP_CXXFLAGS"
++ AC_DEFINE(HAVE_OPENMP, 1, [Use OpenMP])
++ fi
+ fi
+
+ dnl ******************************
+ dnl Check for libexif
+ dnl ******************************
+-PKG_CHECK_MODULES(EXIF, libexif, exif_ok=yes, exif_ok=no)
+-if test "x$exif_ok" = "xyes"; then
+- AC_DEFINE(HAVE_EXIF, 1, [Use libexif])
++AC_ARG_ENABLE(exif,
++ AS_HELP_STRING([--enable-exif], [compile with EXIF support]),
++ enable_exif=$enableval,enable_exif=no)
++
++if test "x$enable_exif" = "xyes"; then
++ PKG_CHECK_MODULES(EXIF, libexif, exif_ok=yes, exif_ok=no)
++ if test "x$exif_ok" = "xyes"; then
++ AC_DEFINE(HAVE_EXIF, 1, [Use libexif])
++ fi
+ fi
+ AC_SUBST(EXIF_LIBS)
+ AC_SUBST(EXIF_CFLAGS)
+@@ -253,10 +262,16 @@
+ dnl ******************************
+ dnl Check for libjpeg
+ dnl ******************************
+-AC_CHECK_LIB(jpeg, jpeg_CreateDecompress, [AC_CHECK_HEADER(jpeglib.h, jpeg_ok=yes, jpeg_ok=no)], jpeg_ok=no)
+-if test "x$jpeg_ok" = "xyes"; then
+- LIBS="-ljpeg $LIBS"
+- AC_DEFINE(HAVE_JPEG, 1, [Use libjpeg])
++AC_ARG_ENABLE(jpeg,
++ AS_HELP_STRING([--enable-jpeg], [compile with JPEG support]),
++ enable_jpeg=$enableval,enable_jpeg=no)
++
++if test "x$enable_jpeg" = "xyes"; then
++ AC_CHECK_LIB(jpeg, jpeg_CreateDecompress, [AC_CHECK_HEADER(jpeglib.h, jpeg_ok=yes, jpeg_ok=no)], jpeg_ok=no)
++ if test "x$jpeg_ok" = "xyes"; then
++ LIBS="-ljpeg $LIBS"
++ AC_DEFINE(HAVE_JPEG, 1, [Use libjpeg])
++ fi
+ fi
+
+ dnl This check is to get a FIONREAD definition on Solaris 8
+@@ -675,9 +690,16 @@
+ dnl Check for ImageMagick Magick++
+ dnl ******************************
+
+-PKG_CHECK_MODULES(IMAGEMAGICK, ImageMagick++, magick_ok=yes, magick_ok=no)
+-if test "x$magick_ok" = "xyes"; then
+- AC_DEFINE(WITH_IMAGE_MAGICK,1,[Image Magick++ support for bitmap effects])
++AC_ARG_ENABLE(magick,
++ AS_HELP_STRING([--enable-magick], [compile with Image Magick++ support for bitmap effects]),
++ enable_magick=$enableval,enable_magick=no)
++
++magick_ok="no"
++if test "x$enable_magick" = "xyes"; then
++ PKG_CHECK_MODULES(IMAGEMAGICK, ImageMagick++, magick_ok=yes, magick_ok=no)
++ if test "x$magick_ok" = "xyes"; then
++ AC_DEFINE(WITH_IMAGE_MAGICK,1,[Image Magick++ support for bitmap effects])
++ fi
+ fi
+ AM_CONDITIONAL(USE_IMAGE_MAGICK, test "x$magick_ok" = "xyes")
+
+@@ -712,6 +734,10 @@
+ AC_DEFINE(WITH_GLIBMM_2_32,1,[Build with Glibmm 2.32 or higher])
+ fi
+
++
++AC_ARG_WITH([gtkspell],
++ AS_HELP_STRING([--without-gtkspell], [disable gtk spelling widget]),[with_gtkspell=$withval], [with_gtkspell=yes])
++
+ dnl *********************************
+ dnl Allow experimental GTK+3 build
+ dnl *********************************
+@@ -723,11 +749,13 @@
+ if test "x$enable_gtk3" = "xyes"; then
+
+ ink_spell_pkg=
+- if pkg-config --exists gtkspell-3.0; then
+- ink_spell_pkg=gtkspell-3.0
+- AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ if test "x$with_gtkspell" = "xyes"; then
++ if pkg-config --exists gtkspell-3.0; then
++ ink_spell_pkg=gtkspell-3.0
++ AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ fi
+ fi
+-
++
+ PKG_CHECK_MODULES(GTK,
+ gtkmm-3.0 >= 3.2
+ gdkmm-3.0 >= 3.2
+@@ -800,11 +828,13 @@
+ else
+
+ ink_spell_pkg=
+- if pkg-config --exists gtkspell-2.0; then
+- ink_spell_pkg=gtkspell-2.0
+- AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ if test "x$with_gtkspell" = "xyes"; then
++ if pkg-config --exists gtkspell-2.0; then
++ ink_spell_pkg=gtkspell-2.0
++ AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ fi
+ fi
+-
++
+ PKG_CHECK_MODULES(GTK,
+ gtk+-2.0 >= 2.24
+ $ink_spell_pkg
+@@ -928,12 +958,17 @@
+ dnl **************************
+ dnl Check for aspell
+ dnl ******************************
+-AC_CHECK_LIB(aspell, new_aspell_config, [AC_CHECK_HEADER(aspell.h, aspell_ok=yes, aspell_ok=no)], aspell_ok=no, -lz -lm)
+-if test "x$aspell_ok" = "xyes"; then
+- AC_DEFINE(HAVE_ASPELL, 1, [Use aspell for built-in spellchecker])
+- INKSCAPE_LIBS="$INKSCAPE_LIBS -laspell"
+-else
+- AC_MSG_CHECKING([Aspell not found, spell checker will be disabled])
++AC_ARG_WITH([aspell],
++ AS_HELP_STRING([--without-aspell], [disable aspell spell checker]),[with_aspell=$withval], [with_aspell=yes])
++
++if test "x$with_aspell" = "xyes"; then
++ AC_CHECK_LIB(aspell, new_aspell_config, [AC_CHECK_HEADER(aspell.h, aspell_ok=yes, aspell_ok=no)], aspell_ok=no, -lz -lm)
++ if test "x$aspell_ok" = "xyes"; then
++ AC_DEFINE(HAVE_ASPELL, 1, [Use aspell for built-in spellchecker])
++ INKSCAPE_LIBS="$INKSCAPE_LIBS -laspell"
++ else
++ AC_MSG_CHECKING([Aspell not found, spell checker will be disabled])
++ fi
+ fi
+
+ dnl Check for bind_textdomain_codeset, including -lintl if GLib brings it in.
diff --git a/media-gfx/inkscape/files/inkscape-0.91_pre3-cppflags.patch b/media-gfx/inkscape/files/inkscape-0.91_pre3-cppflags.patch
new file mode 100644
index 000000000000..94dbf881de0c
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.91_pre3-cppflags.patch
@@ -0,0 +1,14 @@
+Gentoo enables _FORTIFY_SOURCE by default so this avoids redefined warnings.
+
+--- inkscape-0.91pre3/configure.ac
++++ inkscape-0.91pre3/configure.ac
+@@ -72,9 +72,6 @@
+ ####
+ # Generic cpp flags...
+
+- # What is just plain "-W" ?
+- # Fortify source requires -O2 or higher, which is handled with newer autoconf
+- CPPFLAGS="-W -D_FORTIFY_SOURCE=2 $CPPFLAGS"
+ # Enable format and format security warnings
+ CPPFLAGS="-Wformat -Wformat-security $CPPFLAGS"
+ # Enable all default warnings
diff --git a/media-gfx/inkscape/files/inkscape-0.91_pre3-desktop.patch b/media-gfx/inkscape/files/inkscape-0.91_pre3-desktop.patch
new file mode 100644
index 000000000000..f02fa1a8aca5
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.91_pre3-desktop.patch
@@ -0,0 +1,20 @@
+--- inkscape-0.91pre3/inkscape.desktop.in
++++ inkscape-0.91pre3/inkscape.desktop.in
+@@ -5,7 +5,7 @@
+ _X-GNOME-FullName=Inkscape Vector Graphics Editor
+ _Comment=Create and edit Scalable Vector Graphics images
+ Type=Application
+-Categories=Graphics;VectorGraphics;GTK;
++Categories=Graphics;2DGraphics;VectorGraphics;GTK;
+ MimeType=image/svg+xml;image/svg+xml-compressed;application/vnd.corel-draw;application/pdf;application/postscript;image/x-eps;application/illustrator;
+ Exec=inkscape %F
+ TryExec=inkscape
+@@ -14,7 +14,7 @@
+ Icon=inkscape
+ X-Ayatana-Desktop-Shortcuts=Drawing
+
+-[Drawing Shortcut Group]
++[X-Drawing Shortcut Group]
+ _Name=New Drawing
+ Exec=inkscape
+ TargetEnvironment=Unity
diff --git a/media-gfx/inkscape/files/inkscape-0.91_pre3-exif.patch b/media-gfx/inkscape/files/inkscape-0.91_pre3-exif.patch
new file mode 100644
index 000000000000..4180fd4d2ef0
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.91_pre3-exif.patch
@@ -0,0 +1,12 @@
+Actually try to use EXIF support if it's enabled.
+
+--- inkscape-0.91pre3/src/extension/internal/image-resolution.cpp
++++ inkscape-0.91pre3/src/extension/internal/image-resolution.cpp
+@@ -18,6 +18,7 @@
+ #include <png.h>
+
+ #ifdef HAVE_EXIF
++#define IR_TRY_EXIF 1
+ #include <math.h>
+ #include <libexif/exif-data.h>
+ #endif
diff --git a/media-gfx/inkscape/files/inkscape-0.91_pre3-sk-man.patch b/media-gfx/inkscape/files/inkscape-0.91_pre3-sk-man.patch
new file mode 100644
index 000000000000..f14e7d152e19
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.91_pre3-sk-man.patch
@@ -0,0 +1,15 @@
+Install sk man page to the right directory.
+
+https://bugs.gentoo.org/show_bug.cgi?id=481276
+
+--- inkscape-0.91pre3/Makefile.am
++++ inkscape-0.91pre3/Makefile.am
+@@ -561,7 +561,7 @@
+ manja_DATA = inkscape.ja.1
+ manjadir = $(mandir)/ja/man1
+
+-mansk_DATA = inkscape.ja.1
++mansk_DATA = inkscape.sk.1
+ manskdir = $(mandir)/sk/man1
+
+ manzhtw_DATA = inkscape.zh_TW.1
diff --git a/media-gfx/inkscape/files/inkscape-0.92.1-automagic.patch b/media-gfx/inkscape/files/inkscape-0.92.1-automagic.patch
new file mode 100644
index 000000000000..141878b2bcd5
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.92.1-automagic.patch
@@ -0,0 +1,154 @@
+diff -ruN inkscape-0.92.1.orig/configure.ac inkscape-0.92.1/configure.ac
+--- inkscape-0.92.1.orig/configure.ac 2017-02-14 00:46:57.000000000 +0100
++++ inkscape-0.92.1/configure.ac 2017-05-12 21:20:45.880842301 +0200
+@@ -201,11 +201,14 @@
+ dnl Check for OpenMP
+ dnl ******************************
+ AC_OPENMP
+-if test "x$ac_cv_prog_cxx_openmp" != "xunsupported"; then
+- openmp_ok=yes
+- dnl We have it, now set up the flags
+- CXXFLAGS="$CXXFLAGS $OPENMP_CXXFLAGS"
+- AC_DEFINE(HAVE_OPENMP, 1, [Use OpenMP])
++openmp_ok="no"
++if test "x$enable_openmp" = "xyes"; then
++ if test "x$ac_cv_prog_cxx_openmp" != "xunsupported"; then
++ openmp_ok=yes
++ dnl We have it, now set up the flags
++ CXXFLAGS="$CXXFLAGS $OPENMP_CXXFLAGS"
++ AC_DEFINE(HAVE_OPENMP, 1, [Use OpenMP])
++ fi
+ fi
+
+ dnl ********************
+@@ -222,9 +225,15 @@
+ dnl ******************************
+ dnl Check for libexif
+ dnl ******************************
+-PKG_CHECK_MODULES(EXIF, libexif, exif_ok=yes, exif_ok=no)
+-if test "x$exif_ok" = "xyes"; then
+- AC_DEFINE(HAVE_EXIF, 1, [Use libexif])
++AC_ARG_ENABLE(exif,
++ AS_HELP_STRING([--enable-exif], [compile with EXIF support]),
++ enable_exif=$enableval,enable_exif=no)
++
++if test "x$enable_exif" = "xyes"; then
++ PKG_CHECK_MODULES(EXIF, libexif, exif_ok=yes, exif_ok=no)
++ if test "x$exif_ok" = "xyes"; then
++ AC_DEFINE(HAVE_EXIF, 1, [Use libexif])
++ fi
+ fi
+ AC_SUBST(EXIF_LIBS)
+ AC_SUBST(EXIF_CFLAGS)
+@@ -232,10 +241,16 @@
+ dnl ******************************
+ dnl Check for libjpeg
+ dnl ******************************
+-AC_CHECK_LIB(jpeg, jpeg_CreateDecompress, [AC_CHECK_HEADER(jpeglib.h, jpeg_ok=yes, jpeg_ok=no)], jpeg_ok=no)
+-if test "x$jpeg_ok" = "xyes"; then
+- LIBS="-ljpeg $LIBS"
+- AC_DEFINE(HAVE_JPEG, 1, [Use libjpeg])
++AC_ARG_ENABLE(jpeg,
++ AS_HELP_STRING([--enable-jpeg], [compile with JPEG support]),
++ enable_jpeg=$enableval,enable_jpeg=no)
++
++if test "x$enable_jpeg" = "xyes"; then
++ AC_CHECK_LIB(jpeg, jpeg_CreateDecompress, [AC_CHECK_HEADER(jpeglib.h, jpeg_ok=yes, jpeg_ok=no)], jpeg_ok=no)
++ if test "x$jpeg_ok" = "xyes"; then
++ LIBS="-ljpeg $LIBS"
++ AC_DEFINE(HAVE_JPEG, 1, [Use libjpeg])
++ fi
+ fi
+
+ dnl This check is to get a FIONREAD definition on Solaris 8
+@@ -614,9 +629,16 @@
+ dnl Check for ImageMagick Magick++
+ dnl ******************************
+
+-PKG_CHECK_MODULES(IMAGEMAGICK, ImageMagick++, magick_ok=yes, magick_ok=no)
+-if test "x$magick_ok" = "xyes"; then
+- AC_DEFINE(WITH_IMAGE_MAGICK,1,[Image Magick++ support for bitmap effects])
++AC_ARG_ENABLE(magick,
++ AS_HELP_STRING([--enable-magick], [compile with Image Magick++ support for bitmap effects]),
++ enable_magick=$enableval,enable_magick=no)
++
++magick_ok="no"
++if test "x$enable_magick" = "xyes"; then
++ PKG_CHECK_MODULES(IMAGEMAGICK, ImageMagick++, magick_ok=yes, magick_ok=no)
++ if test "x$magick_ok" = "xyes"; then
++ AC_DEFINE(WITH_IMAGE_MAGICK,1,[Image Magick++ support for bitmap effects])
++ fi
+ fi
+ AM_CONDITIONAL(USE_IMAGE_MAGICK, test "x$magick_ok" = "xyes")
+
+@@ -712,6 +734,10 @@
+
+ AC_CHECK_HEADER([boost/unordered_set.hpp], [AC_DEFINE(HAVE_BOOST_UNORDERED_SET, 1, [Boost unordered_set (Boost >= 1.36)])], [])
+
++
++AC_ARG_WITH([gtkspell],
++ AS_HELP_STRING([--without-gtkspell], [disable gtk spelling widget]),[with_gtkspell=$withval], [with_gtkspell=yes])
++
+ dnl *********************************
+ dnl Allow experimental GTK+3 build
+ dnl *********************************
+@@ -723,11 +749,13 @@
+ if test "x$enable_gtk3" = "xyes"; then
+
+ ink_spell_pkg=
+- if pkg-config --exists gtkspell-3.0; then
+- ink_spell_pkg=gtkspell-3.0
+- AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ if test "x$with_gtkspell" = "xyes"; then
++ if pkg-config --exists gtkspell-3.0; then
++ ink_spell_pkg=gtkspell-3.0
++ AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ fi
+ fi
+-
++
+ PKG_CHECK_MODULES(GTK,
+ gtk+-3.0 >= 3.8
+ gdk-3.0 >= 3.8
+@@ -804,11 +832,13 @@
+ else
+
+ ink_spell_pkg=
+- if pkg-config --exists gtkspell-2.0; then
+- ink_spell_pkg=gtkspell-2.0
+- AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ if test "x$with_gtkspell" = "xyes"; then
++ if pkg-config --exists gtkspell-2.0; then
++ ink_spell_pkg=gtkspell-2.0
++ AC_DEFINE(WITH_GTKSPELL, 1, [enable gtk spelling widget])
++ fi
+ fi
+-
++
+ PKG_CHECK_MODULES(GTK,
+ gtk+-2.0 >= 2.24
+ $ink_spell_pkg)
+@@ -931,12 +961,17 @@
+ dnl **************************
+ dnl Check for aspell
+ dnl ******************************
+-AC_CHECK_LIB(aspell, new_aspell_config, [AC_CHECK_HEADER(aspell.h, aspell_ok=yes, aspell_ok=no)], aspell_ok=no, -lz -lm)
+-if test "x$aspell_ok" = "xyes"; then
+- AC_DEFINE(HAVE_ASPELL, 1, [Use aspell for built-in spellchecker])
+- INKSCAPE_LIBS="$INKSCAPE_LIBS -laspell"
+-else
+- AC_MSG_CHECKING([Aspell not found, spell checker will be disabled])
++AC_ARG_WITH([aspell],
++ AS_HELP_STRING([--without-aspell], [disable aspell spell checker]),[with_aspell=$withval], [with_aspell=yes])
++
++if test "x$with_aspell" = "xyes"; then
++ AC_CHECK_LIB(aspell, new_aspell_config, [AC_CHECK_HEADER(aspell.h, aspell_ok=yes, aspell_ok=no)], aspell_ok=no, -lz -lm)
++ if test "x$aspell_ok" = "xyes"; then
++ AC_DEFINE(HAVE_ASPELL, 1, [Use aspell for built-in spellchecker])
++ INKSCAPE_LIBS="$INKSCAPE_LIBS -laspell"
++ else
++ AC_MSG_CHECKING([Aspell not found, spell checker will be disabled])
++ fi
+ fi
+
+ dnl Check for bind_textdomain_codeset, including -lintl if GLib brings it in.
diff --git a/media-gfx/inkscape/files/inkscape-0.92.1-desktop.patch b/media-gfx/inkscape/files/inkscape-0.92.1-desktop.patch
new file mode 100644
index 000000000000..be49ea505d36
--- /dev/null
+++ b/media-gfx/inkscape/files/inkscape-0.92.1-desktop.patch
@@ -0,0 +1,12 @@
+diff -ruN inkscape-0.92.1.orig/inkscape.desktop.in inkscape-0.92.1/inkscape.desktop.in
+--- inkscape-0.92.1.orig/inkscape.desktop.in 2017-02-14 00:46:57.000000000 +0100
++++ inkscape-0.92.1/inkscape.desktop.in 2017-05-12 21:25:01.628853033 +0200
+@@ -6,7 +6,7 @@
+ _Comment=Create and edit Scalable Vector Graphics images
+ _Keywords=image;editor;vector;drawing;
+ Type=Application
+-Categories=Graphics;VectorGraphics;GTK;
++Categories=Graphics;2DGraphics;VectorGraphics;GTK;
+ MimeType=image/svg+xml;image/svg+xml-compressed;application/vnd.corel-draw;application/pdf;application/postscript;image/x-eps;application/illustrator;image/cgm;image/x-wmf;application/x-xccx;application/x-xcgm;application/x-xcdt;application/x-xsk1;application/x-xcmx;image/x-xcdr;application/visio;application/x-visio;application/vnd.visio;application/visio.drawing;application/vsd;application/x-vsd;image/x-vsd;
+ Exec=inkscape %F
+ TryExec=inkscape