summaryrefslogtreecommitdiff
path: root/media-gfx/jhead/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-gfx/jhead/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-gfx/jhead/files')
-rw-r--r--media-gfx/jhead/files/Makefile44
-rw-r--r--media-gfx/jhead/files/jhead-2.90-mkstemp_respect_flags.patch26
-rw-r--r--media-gfx/jhead/files/jhead-3.04-mkstemp-fix-makefile.patch53
3 files changed, 53 insertions, 70 deletions
diff --git a/media-gfx/jhead/files/Makefile b/media-gfx/jhead/files/Makefile
deleted file mode 100644
index 5f1d9799a42b..000000000000
--- a/media-gfx/jhead/files/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-#--------------------------------
-# jhead makefile for Unix
-# this make file also creates libjhead for meshlab
-#--------------------------------
-OBJ=.
-SRC=.
-AR = ar cqs
-LFLAGS = -shared -Wl,-soname,libjhead.so.1
-
-objs = $(OBJ)/jhead.o $(OBJ)/jpgfile.o $(OBJ)/jpgqguess.o $(OBJ)/paths.o \
- $(OBJ)/exif.o $(OBJ)/iptc.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
-
-TARGET = libjhead.so.1.0.0
-TARGET0 = libjhead.so
-TARGET1 = libjhead.so.1
-TARGET2 = libjhead.so.1.0
-
-all: jhead $(TARGET)
-
-$(OBJ)/%.o:$(SRC)/%.c
- ${CC} -fPIC $(CFLAGS) -c $< -o $@
-
-jhead: $(objs) jhead.h
- ${CC} ${LDFLAGS} -o jhead $(objs) -lm
-
-clean:
- rm -f $(objs) jhead ${TARGET} ${TARGETA} ${TARGET0} ${TARGETD} \
- ${TARGET1} ${TARGET2}
-
-install:
- cp jhead ${DESTDIR}/usr/bin/
- cp ${TARGET} ${DESTDIR}/usr/lib/
- cp jhead ${DESTDIR}/usr/bin/
- cp ${TARGET0} ${DESTDIR}/usr/lib/
- cp ${TARGET1} ${DESTDIR}/usr/lib/
- cp ${TARGET2} ${DESTDIR}/usr/lib/
-
-$(TARGET): $(objs) jhead
- ${CC} $(LDFLAGS) $(LFLAGS) -o $(TARGET) $(objs)
- ln -s ${TARGET} ${TARGET0}
- ln -s ${TARGET} ${TARGET1}
- ln -s ${TARGET} ${TARGET2}
-
-
diff --git a/media-gfx/jhead/files/jhead-2.90-mkstemp_respect_flags.patch b/media-gfx/jhead/files/jhead-2.90-mkstemp_respect_flags.patch
deleted file mode 100644
index f09214b9f3d6..000000000000
--- a/media-gfx/jhead/files/jhead-2.90-mkstemp_respect_flags.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --exclude='*~' -Naur -Naur jhead-2.90.orig/jhead.c jhead-2.90/jhead.c
---- jhead-2.90.orig/jhead.c 2011-02-12 14:36:47.000000000 -0200
-+++ jhead-2.90/jhead.c 2011-02-12 14:39:28.000000000 -0200
-@@ -358,7 +358,7 @@
- // as mktemp - that is, that between getting the random name, and making the file
- // some other program could snatch that exact same name!
- // also, not all pltforms support mkstemp.
-- mktemp(TempName);
-+ mkstemp(TempName);
-
-
- if(!TempName[0]) {
-diff --exclude='*~' -Naur -Naur jhead-2.90.orig/makefile jhead-2.90/makefile
---- jhead-2.90.orig/makefile 2011-02-12 14:36:47.000000000 -0200
-+++ jhead-2.90/makefile 2011-02-12 14:40:50.000000000 -0200
-@@ -13,8 +13,9 @@
- $(OBJ)/%.o:$(SRC)/%.c
- ${CC} $(CFLAGS) -c $< -o $@
-
-+
- jhead: $(objs) jhead.h
-- ${CC} -o jhead $(objs) -lm
-+ ${CC} ${LDFLAGS} -o jhead $(objs) -lm
-
- clean:
- rm -f $(objs) jhead
diff --git a/media-gfx/jhead/files/jhead-3.04-mkstemp-fix-makefile.patch b/media-gfx/jhead/files/jhead-3.04-mkstemp-fix-makefile.patch
new file mode 100644
index 000000000000..0bb634b6f5b9
--- /dev/null
+++ b/media-gfx/jhead/files/jhead-3.04-mkstemp-fix-makefile.patch
@@ -0,0 +1,53 @@
+diff --git a/jhead.c b/jhead.c
+index f78127a..d8d1472 100644
+--- a/jhead.c
++++ b/jhead.c
+@@ -376,7 +376,7 @@ static void DoCommand(const char * FileName, int ShowIt)
+ // as mktemp - that is, that between getting the random name, and making the file
+ // some other program could snatch that exact same name!
+ // also, not all platforms support mkstemp.
+- mktemp(TempName);
++ mkstemp(TempName);
+
+
+ if(!TempName[0]) {
+diff --git a/makefile b/makefile
+index f8f195e..c36d34f 100644
+--- a/makefile
++++ b/makefile
+@@ -3,17 +3,20 @@
+ #--------------------------------
+ OBJ=.
+ SRC=.
+-CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+-CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+-LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
++LFLAGS = -fPIC -shared -Wl,-soname,libjhead.so.1
+
+-all: jhead
++TARGET = libjhead.so.1.0.0
++TARGET0 = libjhead.so
++TARGET1 = libjhead.so.1
++TARGET2 = libjhead.so.1.0
++
++all: jhead $(TARGET)
+
+ objs = $(OBJ)/jhead.o $(OBJ)/jpgfile.o $(OBJ)/jpgqguess.o $(OBJ)/paths.o \
+ $(OBJ)/exif.o $(OBJ)/iptc.o $(OBJ)/gpsinfo.o $(OBJ)/makernote.o
+
+ $(OBJ)/%.o:$(SRC)/%.c
+- ${CC} $(CFLAGS) $(CPPFLAGS) -c $< -o $@
++ ${CC} -fPIC $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ jhead: $(objs) jhead.h
+ ${CC} $(LDFLAGS) -o jhead $(objs) -lm
+@@ -23,3 +26,9 @@ clean:
+
+ install:
+ cp jhead ${DESTDIR}/usr/bin/
++
++$(TARGET): $(objs) jhead
++ ${CC} $(LDFLAGS) $(LFLAGS) -o $(TARGET) $(objs)
++ ln -s ${TARGET} ${TARGET0}
++ ln -s ${TARGET} ${TARGET1}
++ ln -s ${TARGET} ${TARGET2}