summaryrefslogtreecommitdiff
path: root/media-gfx/kphotoalbum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-08 21:46:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-08 21:46:31 +0100
commitc875ddc2b3a59401c7da3cb2c085afff4ba24e28 (patch)
tree6ff80676ab99535f05ea8e06cc9e68f6a8f29760 /media-gfx/kphotoalbum
parentd5599da3055bf9b900513a61c3c6e4bdbb524503 (diff)
gentoo auto-resync : 08:06:2023 - 21:46:30
Diffstat (limited to 'media-gfx/kphotoalbum')
-rw-r--r--media-gfx/kphotoalbum/Manifest3
-rw-r--r--media-gfx/kphotoalbum/files/kphotoalbum-5.10.0-exiv2-0.28.patch147
-rw-r--r--media-gfx/kphotoalbum/kphotoalbum-5.10.0.ebuild2
3 files changed, 151 insertions, 1 deletions
diff --git a/media-gfx/kphotoalbum/Manifest b/media-gfx/kphotoalbum/Manifest
index fea3f3ca43b2..209019e55c20 100644
--- a/media-gfx/kphotoalbum/Manifest
+++ b/media-gfx/kphotoalbum/Manifest
@@ -1,3 +1,4 @@
+AUX kphotoalbum-5.10.0-exiv2-0.28.patch 5737 BLAKE2B bfdc846f99f4ce2f51467834636bbe14e01bd555bcae9eed7a670c0e611736fbf070c6a6a9765820b9df521cc98511744b9bfbb4559c2d689ec9ef68f7af6fc8 SHA512 8f4cf6aebbd49b67b596e4de06154299eed46783c42272aea07d995656c1c19356d75c9442d0747e0e635d4f4046ad65675e632f0ca750b0e8ea99ac484ef3e8
DIST kphotoalbum-5.10.0.tar.xz 12002788 BLAKE2B e20a06f6829c1ac3df51102b09be4e59fe97557b7b51ab4c2ef072f2ea18b9c086acad9cd03dde14549e35ee652f325a558bb634e5760d3b216f9a1c6d681a63 SHA512 6e6e3d3173f2783c05319c6a372553e92b97174a43307d2bd1fdfa0eb6751bab435e61e07e1c33496254e6f53dd95032adf002899c68475dac7af7ad575c28cc
-EBUILD kphotoalbum-5.10.0.ebuild 1900 BLAKE2B 7c42400f498d1503a2266ae5bb12423fcaaf1d0c3cf736e67a3632d88f2b6ff19ac3bebe865f1f2d5611c513dde71c56bebaad23b4136b69a3c43d3c819efaa6 SHA512 4b434e436a9a596e1928f54f1cbb5af18775b8bd653e2e53b393f6be79e24b6d65720a223ed8d79491410970ff25e5a748e05c39c11860f00468edb04bec007f
+EBUILD kphotoalbum-5.10.0.ebuild 1974 BLAKE2B e3a5135a8566f064afb727e3c57d2d95e46eefbd27283283df58f83493dcc97d49774605860dacd22a97c512b898a1820303346cb885bb0d4cba0a393320c56e SHA512 e2d0b7e7bfad05be239026f3c88af935b9b2cbe980b0a809bf527db38f72ba1f0779ef61d6a4252a74f20a15d6c2f26ca29bff28d38fb5a6e5dc76e0feab6720
MISC metadata.xml 733 BLAKE2B 8925ee0f3c5e6e4d8592c3403781228f00cf39f39b0363920c86091fdb566e43889b522121112cf3f0f857cdb94f2da86cf6dd0029276e990ac197870a0ab718 SHA512 824eed39872862a0502dadf33cfee45ecc269bd0750286157abc08119b49c0fa3abf6ec66eb170a37251e141dd2842563219084a41245dc9b8cfe61fa8ad8a08
diff --git a/media-gfx/kphotoalbum/files/kphotoalbum-5.10.0-exiv2-0.28.patch b/media-gfx/kphotoalbum/files/kphotoalbum-5.10.0-exiv2-0.28.patch
new file mode 100644
index 000000000000..2eea9495b735
--- /dev/null
+++ b/media-gfx/kphotoalbum/files/kphotoalbum-5.10.0-exiv2-0.28.patch
@@ -0,0 +1,147 @@
+diff --git a/DB/FileInfo.cpp b/DB/FileInfo.cpp
+index dc4c9819b62706c9c7bbfa21f3da7ef7d3f8b6d3..8b4e275c1765e718ed917cb41e7b221ed8d484ef 100644
+--- a/DB/FileInfo.cpp
++++ b/DB/FileInfo.cpp
+@@ -1,5 +1,6 @@
+ // SPDX-FileCopyrightText: 2003-2010 Jesper K. Pedersen <blackie@kde.org>
+ // SPDX-FileCopyrightText: 2021 Johannes Zarl-Zierl <johannes@zarl-zierl.at>
++// SPDX-FileCopyrightText: 2023 Tobias Leupold <tl at stonemx dot de>
+ //
+ // SPDX-License-Identifier: GPL-2.0-or-later
+
+@@ -13,6 +14,8 @@
+ #include <QFileInfo>
+ #include <QRegularExpression>
+
++#include <exiv2/version.hpp>
++
+ using namespace DB;
+
+ FileInfo FileInfo::read(const DB::FileName &fileName, DB::ExifMode mode)
+@@ -79,8 +82,14 @@ void DB::FileInfo::parseEXIV2(const DB::FileName &fileName)
+ const Exiv2::Exifdatum &datum = m_exifMap["Exif.Image.Orientation"];
+
+ int orientation = 0;
+- if (datum.count() > 0)
++ if (datum.count() > 0) {
++#if EXIV2_TEST_VERSION(0, 28, 0)
++ orientation = datum.toInt64();
++#else
+ orientation = datum.toLong();
++#endif
++ }
++
+ m_angle = orientationToAngle(orientation);
+ }
+
+diff --git a/lib/kpaexif/Database.cpp b/lib/kpaexif/Database.cpp
+index 4d0e228c72f5747f9d5b2a4e15871e2a11de4ed9..985713ceb53e60c3c17de80632f902a07ba94b14 100644
+--- a/lib/kpaexif/Database.cpp
++++ b/lib/kpaexif/Database.cpp
+@@ -1,6 +1,6 @@
+ // SPDX-FileCopyrightText: 2003-2020 The KPhotoAlbum Development Team
+-// SPDX-FileCopyrightText: 2021 Johannes Zarl-Zierl <johannes@zarl-zierl.at>
+-// SPDX-FileCopyrightText: 2022 Johannes Zarl-Zierl <johannes@zarl-zierl.at>
++// SPDX-FileCopyrightText: 2021-2022 Johannes Zarl-Zierl <johannes@zarl-zierl.at>
++// SPDX-FileCopyrightText: 2023 Tobias Leupold <tl at stonemx dot de>
+ //
+ // SPDX-License-Identifier: GPL-2.0-or-later
+
+@@ -320,7 +320,7 @@ bool Exif::Database::add(const DB::FileName &fileName)
+ return false;
+
+ try {
+- Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open(fileName.absolute().toLocal8Bit().data());
++ const auto image = Exiv2::ImageFactory::open(fileName.absolute().toLocal8Bit().data());
+ Q_ASSERT(image.get() != nullptr);
+ image->readMetadata();
+ Exiv2::ExifData &exifData = image->exifData();
+@@ -341,7 +341,7 @@ bool Exif::Database::add(const DB::FileNameList &list)
+
+ for (const DB::FileName &fileName : list) {
+ try {
+- Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open(fileName.absolute().toLocal8Bit().data());
++ const auto image = Exiv2::ImageFactory::open(fileName.absolute().toLocal8Bit().data());
+ Q_ASSERT(image.get() != nullptr);
+ image->readMetadata();
+ map << DBExifInfo(fileName, image->exifData());
+diff --git a/lib/kpaexif/DatabaseElement.cpp b/lib/kpaexif/DatabaseElement.cpp
+index 4e7ba198e425e81c582c585bb184ec19c31d4985..3d5d56cfbe5028a8e148753979bdae3f0922008d 100644
+--- a/lib/kpaexif/DatabaseElement.cpp
++++ b/lib/kpaexif/DatabaseElement.cpp
+@@ -1,13 +1,15 @@
+-/* SPDX-FileCopyrightText: 2003-2010 Jesper K. Pedersen <blackie@kde.org>
++// SPDX-FileCopyrightText: 2003-2010 Jesper K. Pedersen <blackie@kde.org>
++// SPDX-FileCopyrightText: 2023 Tobias Leupold <tl at stonemx dot de>
++//
++// SPDX-License-Identifier: GPL-2.0-or-later
+
+- SPDX-License-Identifier: GPL-2.0-or-later
+-*/
+ #include "DatabaseElement.h"
+
+ #include <kpabase/Logging.h>
+
+ #include <QVariant>
+ #include <exiv2/exif.hpp>
++#include <exiv2/version.hpp>
+
+ static QString replaceDotWithUnderscore(const char *cstr)
+ {
+@@ -76,10 +78,15 @@ QString Exif::IntExifElement::queryString() const
+
+ QVariant Exif::IntExifElement::valueFromExif(Exiv2::ExifData &data) const
+ {
+- if (data[m_tag].count() > 0)
+- return QVariant { (int)data[m_tag].toLong() };
+- else
+- return QVariant { (int)0 };
++ if (data[m_tag].count() > 0) {
++#if EXIV2_TEST_VERSION(0, 28, 0)
++ return QVariant((int) data[m_tag].toInt64());
++#else
++ return QVariant((int) data[m_tag].toLong());
++#endif
++ } else {
++ return QVariant(0);
++ }
+ }
+
+ Exif::RationalExifElement::RationalExifElement(const char *tag)
+diff --git a/lib/kpaexif/Info.cpp b/lib/kpaexif/Info.cpp
+index 5f77fc8144516434465bd9f21ea2e885054aed37..162a05d14f3fbadd1d776d0eb10589a892bcf86c 100644
+--- a/lib/kpaexif/Info.cpp
++++ b/lib/kpaexif/Info.cpp
+@@ -1,5 +1,6 @@
+ // SPDX-FileCopyrightText: 2003-2020 The KPhotoAlbum Development Team
+ // SPDX-FileCopyrightText: 2021 Johannes Zarl-Zierl <johannes@zarl-zierl.at>
++// SPDX-FileCopyrightText: 2023 Tobias Leupold <tl at stonemx dot de>
+ //
+ // SPDX-License-Identifier: GPL-2.0-or-later
+
+@@ -16,7 +17,6 @@
+ #include <QTextCodec>
+ #include <exiv2/exv_conf.h>
+ #include <exiv2/image.hpp>
+-#include <exiv2/version.hpp>
+
+ using namespace Exif;
+
+@@ -166,7 +166,7 @@ Info::Info()
+ void Exif::writeExifInfoToFile(const DB::FileName &srcName, const QString &destName, const QString &imageDescription)
+ {
+ // Load Exif from source image
+- Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open(QFile::encodeName(srcName.absolute()).data());
++ auto image = Exiv2::ImageFactory::open(QFile::encodeName(srcName.absolute()).data());
+ image->readMetadata();
+ Exiv2::ExifData data = image->exifData();
+
+@@ -201,7 +201,7 @@ Exif::Metadata Exif::Info::metadata(const DB::FileName &fileName)
+ {
+ try {
+ Exif::Metadata result;
+- Exiv2::Image::AutoPtr image = Exiv2::ImageFactory::open(QFile::encodeName(fileName.absolute()).data());
++ auto image = Exiv2::ImageFactory::open(QFile::encodeName(fileName.absolute()).data());
+ Q_ASSERT(image.get() != nullptr);
+ image->readMetadata();
+ result.exif = image->exifData();
diff --git a/media-gfx/kphotoalbum/kphotoalbum-5.10.0.ebuild b/media-gfx/kphotoalbum/kphotoalbum-5.10.0.ebuild
index 84e92e1afc9c..6f0b4d7fe491 100644
--- a/media-gfx/kphotoalbum/kphotoalbum-5.10.0.ebuild
+++ b/media-gfx/kphotoalbum/kphotoalbum-5.10.0.ebuild
@@ -57,6 +57,8 @@ RDEPEND="${DEPEND}
DOCS=( CHANGELOG.{md,old} README.md )
+PATCHES=( "${FILESDIR}/${P}-exiv2-0.28.patch" ) # git master, bug 906469
+
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_QtAV=ON # bug 758641, last-rited