summaryrefslogtreecommitdiff
path: root/media-gfx/meshlab/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /media-gfx/meshlab/files
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'media-gfx/meshlab/files')
-rw-r--r--media-gfx/meshlab/files/meshlab-2020.12-disable-updates.patch38
-rw-r--r--media-gfx/meshlab/files/meshlab-2020.12-find-plugins.patch39
2 files changed, 77 insertions, 0 deletions
diff --git a/media-gfx/meshlab/files/meshlab-2020.12-disable-updates.patch b/media-gfx/meshlab/files/meshlab-2020.12-disable-updates.patch
new file mode 100644
index 000000000000..d8cadf06d9b7
--- /dev/null
+++ b/media-gfx/meshlab/files/meshlab-2020.12-disable-updates.patch
@@ -0,0 +1,38 @@
+--- a/meshlab/mainwindow_Init.cpp
++++ b/meshlab/mainwindow_Init.cpp
+@@ -607,7 +607,6 @@
+ helpMenu->addAction(onlineHelpAct);
+ helpMenu->addAction(onscreenHelpAct);
+ helpMenu->addAction(submitBugAct);
+- helpMenu->addAction(checkUpdatesAct);
+
+ fillEditMenu();
+ fillRenderMenu();
+--- a/meshlab/mainwindow_RunTime.cpp
++++ b/meshlab/mainwindow_RunTime.cpp
+@@ -2623,7 +2623,9 @@
+
+ void MainWindow::helpOnline()
+ {
++#if defined(__ENABLE_AUTO_STATS__)
+ checkForUpdates(false);
++#endif
+ QDesktopServices::openUrl(QUrl("http://www.meshlab.net/#support"));
+ }
+
+@@ -2882,6 +2884,7 @@
+ void MainWindow::showEvent(QShowEvent * event)
+ {
+ QWidget::showEvent(event);
++#if defined(__ENABLE_AUTO_STATS__)
+ QSettings settings;
+ QSettings::setDefaultFormat(QSettings::NativeFormat);
+ const QString versioncheckeddatestring("lastTimeMeshLabVersionCheckedOnStart");
+@@ -2902,6 +2905,7 @@
+ settings.setValue(versioncheckeddatestring, todayStr);
+ }
+ sendUsAMail();
++#endif
+ }
+
+ void MainWindow::meshAdded(int mid)
diff --git a/media-gfx/meshlab/files/meshlab-2020.12-find-plugins.patch b/media-gfx/meshlab/files/meshlab-2020.12-find-plugins.patch
new file mode 100644
index 000000000000..0d3c4c118ceb
--- /dev/null
+++ b/media-gfx/meshlab/files/meshlab-2020.12-find-plugins.patch
@@ -0,0 +1,39 @@
+--- a/common/CMakeLists.txt
++++ b/common/CMakeLists.txt
+@@ -75,6 +75,11 @@
+ endif()
+ add_library(meshlab-common ${TARGET_TYPE} ${SOURCES} ${HEADERS} ${RESOURCES})
+
++if(NOT WIN32 AND NOT APPLE)
++ target_compile_definitions(
++ meshlab-common PRIVATE MESHLAB_LIB_INSTALL_DIR="${MESHLAB_LIB_INSTALL_DIR}")
++endif()
++
+ target_include_directories(meshlab-common PRIVATE ${EXTERNAL_DIR}/easyexif/)
+ target_link_libraries(
+ meshlab-common
+--- a/common/pluginmanager.cpp
++++ b/common/pluginmanager.cpp
+@@ -225,7 +225,21 @@ QMap<QString, RichParameterList> PluginManager::generateFilterParameterMap()
+ QString PluginManager::getBaseDirPath()
+ {
+ QDir baseDir(qApp->applicationDirPath());
+-
++
++#if defined(Q_OS_LINUX)
++ if (baseDir.dirName() == "bin") {
++ baseDir.cdUp();
++#ifdef MESHLAB_LIB_INSTALL_DIR
++ baseDir.cd(MESHLAB_LIB_INSTALL_DIR);
++#else
++ baseDir.cd("lib");
++ if(baseDir.exists("meshlab")) {
++ baseDir.cd("meshlab");
++ }
++#endif // MESHLAB_LIB_INSTALL_DIR
++ }
++#endif
++
+ #if defined(Q_OS_WIN)
+ // Windows:
+ // during development with visual studio binary could be in the debug/release subdir.