summaryrefslogtreecommitdiff
path: root/media-gfx/mypaint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-gfx/mypaint
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-gfx/mypaint')
-rw-r--r--media-gfx/mypaint/Manifest2
-rw-r--r--media-gfx/mypaint/mypaint-2.0.1.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/media-gfx/mypaint/Manifest b/media-gfx/mypaint/Manifest
index 238b2ded9641..032578bf8825 100644
--- a/media-gfx/mypaint/Manifest
+++ b/media-gfx/mypaint/Manifest
@@ -1,4 +1,6 @@
AUX mypaint-1.2.1-json-c-boolean-defs.patch 1189 BLAKE2B 7cc9728fbe01195b0c95bd844592d4fbae29a7a26758d242933ed712b940d8a893cd41bd2987952e2a817208efbffd779e9c39d4dde42d809a1e11de06a234fa SHA512 8e5815c281a6c63c7818f378d0e75a94860dd24ea69e9fff8e5951b05c407f12e2e19fefeaa559476a4dab46c88eab8821eff061e8c8eadd1f3ce150e42563c2
DIST mypaint-1.2.1.tar.xz 37897196 BLAKE2B 2d8f6b03f710febae1c2d617a6e542543786be384585ae8a973604da2eba8a0fb770d185aa3d2dfc6f794adf29ffb9c217356a96ab27d677ebb57816f62fae9c SHA512 1783765e495b9535669a83a29d27ba684e6201fdfe0875bdd2c167b1dab8af05993b19025767fe0b2770ed9e578e4709f75d8a4820ac945812cba85609f9eb9b
+DIST mypaint-2.0.1.tar.xz 7295048 BLAKE2B 813a939f95ea6887c57d8c0868e33e9bc8b1b95746d5ecd793d4fd13a32198ee5a445cfdd2691a15e944bfb0099d6ac624dff320ae29465db5b1e0d197bedb30 SHA512 449beddcc6da5d720c9efbeac94a466ed0057bd1962d42ebb419190e8b7fd8ffd341327408467fc5da47920f9d0da1fd6d78233a0dda88de5f5d52d53d9ab562
EBUILD mypaint-1.2.1-r5.ebuild 2016 BLAKE2B 0a00318c334adc4c97021ca1e52cb089075b1db667f0ad431fcf758345756d7d3558e50a353c8578d5749172ea4bbe396a99041c026cecce6174cb7cc6e4caf3 SHA512 5b1a703cf2efb5e0d729315ea092c58954975dedc177472467f03726956211b34744018cb3ef730f4b5a8ff2053f30218f838609ef225dd05eab21f5d8a683d8
+EBUILD mypaint-2.0.1.ebuild 1561 BLAKE2B b007519875279d38483c18cc383cbef204c138ac1b9a9b876262a9d89fefd5916f79696baee97e457de35d12ecfe1a6eae8815ea1fe4b0600a2e35cab184fcd3 SHA512 7e64726112465bd52a907700ba5db4f1acbbc04e8f9599a772694850ba29e1523bc170943380cb6a1fb5abd943f87e1e8a4b2c2e2650c5b1b81af70bff68e08f
MISC metadata.xml 247 BLAKE2B 3a8d267e6befd2f46c41982b7196470f32b4fcf5dc6a42ead10b13e81bdcb7975ea998a51d0deb2c3c1a49f00b5f9216d8e43ad7e6dd0aea0f3352b19532d0a0 SHA512 21b957bb801d29dfed1d0aeceac553c9ba039a7fe94ebf899e7ab5c3316bbad116c7bd63a07ccbbb8277d2ce19f27b964499d2ccd942028290519e465e989dbb
diff --git a/media-gfx/mypaint/mypaint-2.0.1.ebuild b/media-gfx/mypaint/mypaint-2.0.1.ebuild
new file mode 100644
index 000000000000..cb35547d5db7
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-2.0.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit desktop distutils-r1 gnome2-utils xdg xdg-utils
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.org/"
+SRC_URI="https://github.com/mypaint/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LANGS="cs de en_CA en_GB es fr hu id it ja ko nb nn_NO pl pt_BR ro ru sl sv uk zh_CN zh_TW"
+
+BDEPEND="
+ dev-lang/swig
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.4[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ ')
+ >=dev-libs/json-c-0.11:=
+ gnome-base/librsvg
+ media-gfx/mypaint-brushes:2.0
+ media-libs/lcms:2
+ >=media-libs/libmypaint-1.5.0
+ media-libs/libpng:0=
+ sys-devel/gettext
+ sys-libs/libomp
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+
+# Need to poke at failing tests
+# Dying on a numpy assert
+RESTRICT="test"
+
+distutils_enable_tests setup.py
+
+src_install() {
+ distutils-r1_src_install
+
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+
+ local lang=
+ for lang in ${LANGS}; do
+ if ! has ${lang} ${LINGUAS}; then
+ rm -rf "${ED}"/usr/share/locale/${lang} || die
+ fi
+ done
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ xdg_mimeinfo_database_update
+}