summaryrefslogtreecommitdiff
path: root/media-gfx/plantuml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
commit71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (patch)
tree4eccd905f575579fe47abb8a83bbdb44ceb8c929 /media-gfx/plantuml
parentc7a7ec40cf928d8fc6a8241aa208272c008c7b4d (diff)
gentoo auto-resync : 23:11:2024 - 03:02:56
Diffstat (limited to 'media-gfx/plantuml')
-rw-r--r--media-gfx/plantuml/Manifest2
-rw-r--r--media-gfx/plantuml/plantuml-1.2024.8.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/media-gfx/plantuml/Manifest b/media-gfx/plantuml/Manifest
index 3c86f43a176c..8071210d8d20 100644
--- a/media-gfx/plantuml/Manifest
+++ b/media-gfx/plantuml/Manifest
@@ -1,3 +1,5 @@
DIST plantuml-1.2024.7.tar.gz 12645142 BLAKE2B 5716e3085c8e326cb504637779fa4a50ab73fb557345858b6985e8f67412ee24d5447bb41b9037c54a565e6dd45db3dbd76245378add7d168e5bc0e05dfca83c SHA512 4f201b0341efa02deb260b44837fff2e1225715ded1fd196f7cd79d0d75baa0a5a146880d9c46470d9652df593b4c4419554d9bbc4a94d380b689359130d70dd
+DIST plantuml-1.2024.8.tar.gz 12543887 BLAKE2B 719602cb8f21e5908fea32778257f0fca830746796e0130bd76f48dc7c829a528d2d0bf8b6f1a0a4ab4fc73c60e8c0b37559108f4afbaf5994597207e6497df2 SHA512 32ee9cb80171ee467b68fe98ca74a3a084bd64410de34d50c79cb40ca972d6092b9c65e0e6ee96647393fa44f152e2ecd3bdafc3f22010afbe73630573996b64
EBUILD plantuml-1.2024.7.ebuild 1374 BLAKE2B 0f09d29f7740d522aa6ca68781b3acf862c62365dfca7b3223f45de2bd9c57c98d1da3756b9e1d58f1ca7c8dd49e5fd4072ce346f69015cdb9658cbc9294cb33 SHA512 51d1069d2617cf7393d1db274f8891c0c25b8d71107e31bd50ca09c32bed895b0c5df71f61a01de8f6333d7b3c3919f7212a3b5f55e476a6f52ba74717e5d5a0
+EBUILD plantuml-1.2024.8.ebuild 1375 BLAKE2B 4083d69b586fa0bc2a7def31c9d637d6ae97307d9731b4eac196f644838177f968a3b46615ee7eb659dea00cb348cab5010ae2dd2134c01a8858c4ab01e891e0 SHA512 2bfc14db0f3bad9d36c440720875c860815630400d05be75e15ab3025cb7d262ed4f2f9153b7aa7e6c5dc8e4b87c1790fe9327968aa9f35d7973685bd62a86b7
MISC metadata.xml 975 BLAKE2B 3a847073b2f3b5f14adb59f8dec5183533eef81f8b10e5633b356743cb45c3927dfc2f8427f26f1e2b3eef01976b0a8e5884b5f9492310e87884c26759dbfed8 SHA512 2cd56c421b1566a679afb739ca82377d5c8b47519fd2cc44307424f5cd88fa0f8b2144842943a7da6abef7ad79254101818292819fdef97631746815a892e7a5
diff --git a/media-gfx/plantuml/plantuml-1.2024.8.ebuild b/media-gfx/plantuml/plantuml-1.2024.8.ebuild
new file mode 100644
index 000000000000..b1af7cd7e527
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-1.2024.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-pkg-simple desktop xdg
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="https://plantuml.com"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ant-task"
+
+DEPEND=">=virtual/jdk-1.8:*
+ ant-task? ( >=dev-java/ant-1.10.14-r3:0 )"
+RDEPEND=">=virtual/jre-1.8:*
+ media-gfx/graphviz
+ ant-task? ( >=dev-java/ant-1.10.14-r3:0 )"
+
+JAVA_AUTOMATIC_MODULE_NAME="net.sourceforge.plantuml"
+JAVA_MAIN_CLASS="net.sourceforge.plantuml.Run"
+JAVA_RESOURCE_DIRS="res"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ java-pkg-2_src_prepare
+ if use ant-task; then
+ # src/net/sourceforge/plantuml/ant/readme.md
+ JAVA_GENTOO_CLASSPATH+="ant"
+ else
+ rm src/net/sourceforge/plantuml/ant/{CheckZip,PlantUml}Task.java || die
+ fi
+
+ # java-pkg-simple wants resources in a separate directory
+ cp -r src res || die
+ cp -r skin stdlib svg themes res || die
+ find res -type f \( -name '*.java' -o -iname 'readme.md' \
+ -o -name '*.ttf' -o -name '*.html' -o -name 'data.txt' \
+ -o -name '.editorconfig' \) -exec rm -rf {} + || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ make_desktop_entry plantuml
+}