summaryrefslogtreecommitdiff
path: root/media-gfx/pngcheck/pngcheck-3.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 09:35:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 09:35:57 +0000
commitb982051e7c8e12c3810a0d21d30d687b406b3ae5 (patch)
tree1f40c63a302b92f633c075f289851ab62633babe /media-gfx/pngcheck/pngcheck-3.0.3.ebuild
parentb62381b18b4bf2e919cbfbae11ebcad391e38e77 (diff)
gentoo auto-resync : 16:12:2022 - 09:35:57
Diffstat (limited to 'media-gfx/pngcheck/pngcheck-3.0.3.ebuild')
-rw-r--r--media-gfx/pngcheck/pngcheck-3.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/pngcheck/pngcheck-3.0.3.ebuild b/media-gfx/pngcheck/pngcheck-3.0.3.ebuild
new file mode 100644
index 000000000000..536c33d0495d
--- /dev/null
+++ b/media-gfx/pngcheck/pngcheck-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Verifies the integrity of PNG, JNG, and MNG files with internal checksums"
+HOMEPAGE="http://www.libpng.org/pub/png/apps/pngcheck.html"
+SRC_URI="http://www.libpng.org/pub/png/src/${P}.tar.gz"
+
+LICENSE="HPND GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -f Makefile.unx \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -DUSE_ZLIB" \
+ ZLIB="-lz"
+}
+
+src_install() {
+ dobin png{check,split,-fix-IDAT-windowsize}
+ doman pngcheck.1 gpl/pngsplit.1
+
+ einstalldocs
+}