summaryrefslogtreecommitdiff
path: root/media-gfx/rawtherapee
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-17 04:04:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-17 04:04:27 +0100
commit8796aaedb3257bbe4d80b0033408b2210b2259d6 (patch)
tree1ffee2ca4a87bd5dba43077259c000f9086fbfc8 /media-gfx/rawtherapee
parent61a1cada8ceb208845fa604b982216b0a7b099cb (diff)
gentoo auto-resync : 17:10:2024 - 04:04:26
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/Manifest1
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.11-r1.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index 628a0015c9ef..7684392412e8 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1,3 +1,4 @@
DIST rawtherapee-5.11.tar.xz 18005652 BLAKE2B d4b4cb45042faf7eadb1c5bfbd7d1db2a452397d10eb12349d1d0a2ae4b9254beb3ee943cf3ddf40380f31abc653ec2c85fb0d4c8e2b1121402bbd41e74afaf0 SHA512 a37af6d99569a6b427379b76b980be8dca5007bf4ec8fc65663e9e8d13850dd2f547e1633f69ee495df105ca6f0f9ab4daf12beec29c9fff63e2e7e5083813b2
+EBUILD rawtherapee-5.11-r1.ebuild 2017 BLAKE2B 1b533809ed1d45d4b0fb8b5c504cef5de6b89b265b02af80d56591df483f0f4921cb44c6cbffbb45afa7af0cf057ccd8ab7684552078751d2697c93eec9bb1a9 SHA512 d344193debc8ca85cbf2638d7b5933f285edb7692928e6e2621ef3f6239c0c6ebcf7fb963a15d28a495a75efacb7bcc4cbfd50caad1f79f01630c63faa46aa0a
EBUILD rawtherapee-5.11.ebuild 1898 BLAKE2B 15c4f40e7016b6d249c4129b41e8cfa472dfbb1063ae7fe30c393edf7d67c201fca1a71bbed303c1cba833d1cb7ef167c841b69bdc8d839adbd31c76f75b3647 SHA512 40f872d001a8f5179c5de769a53145bc555a4ad6b5b5884bf056e190fc12741aab1a7b0ad465780bd28046d71100e5ace4b973cdd041ffb5afe3bf55932cd374
MISC metadata.xml 398 BLAKE2B 4a0ef68f8e8c4e04158552d21df211610a6ccd9195da6365c77f78297ee4957f61d91b5b6eb6af2912d28a70462bdeb012176dc1448cfdf7221eca7225c707ec SHA512 d562b2782f388590aac143ff10c74eb24b4df447d61051875d3a6d9200f013c290ca5c7fe7c2d130484b5ba01b9c725f453b690dbbe04cd0a0f398a9a99352ed
diff --git a/media-gfx/rawtherapee/rawtherapee-5.11-r1.ebuild b/media-gfx/rawtherapee/rawtherapee-5.11-r1.ebuild
new file mode 100644
index 000000000000..596ee7aa14a8
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.11-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P=${P/_rc/-rc}
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://github.com/Beep6581/RawTherapee/releases/download/${PV}/${P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="jpegxl openmp tcmalloc"
+
+RDEPEND="
+ dev-cpp/atkmm:0
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/pangomm:1.4
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ gnome-base/librsvg:2
+ media-gfx/exiv2:=
+ media-libs/lcms:2
+ media-libs/lensfun
+ media-libs/libcanberra[gtk3]
+ media-libs/libiptcdata
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0=
+ media-libs/libraw:=
+ media-libs/tiff:=
+ sci-libs/fftw:3.0=
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ jpegxl? ( media-libs/libjxl:= )
+ tcmalloc? ( dev-util/google-perftools )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ -DWITH_SYSTEM_LIBRAW="on"
+ -DENABLE_TCMALLOC=$(usex tcmalloc)
+ -DWITH_JXL=$(usex jpegxl)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}