summaryrefslogtreecommitdiff
path: root/media-gfx/tif22pnm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/tif22pnm/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/tif22pnm/files')
-rw-r--r--media-gfx/tif22pnm/files/tif22pnm-0.14-gentoo.patch44
-rw-r--r--media-gfx/tif22pnm/files/tif22pnm-0.14-math.patch31
2 files changed, 75 insertions, 0 deletions
diff --git a/media-gfx/tif22pnm/files/tif22pnm-0.14-gentoo.patch b/media-gfx/tif22pnm/files/tif22pnm-0.14-gentoo.patch
new file mode 100644
index 000000000000..f71c751bd1a5
--- /dev/null
+++ b/media-gfx/tif22pnm/files/tif22pnm-0.14-gentoo.patch
@@ -0,0 +1,44 @@
+--- configure.in
++++ configure.in
+@@ -21,7 +21,6 @@
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_LANG_C
+-CFLAGS=" "
+ dnl ^^^ set it to non-empty, so AC_PROG_CXX won't include `-g'
+ dnl AC_PROG_CXX
+ dnl AC_PTS_PROG_CFLAGS(fs, -fsigned-char)
+--- do.sh
++++ do.sh
+@@ -35,8 +35,8 @@
+ if [ x"$CMD" != x ]; then echo "Executing: $CMD"; fi
+
+ if [ "$CMD" = fast ]; then
+- L_CC="$CC -s -O3 -DNDEBUG"
+- L_LD="$LD -s"
++ L_CC="$CC -DNDEBUG"
++ L_LD="$LD"
+ elif [ "$CMD" = debug ]; then
+ L_CC="$CC $GFLAG"
+ L_LD="$LD"
+@@ -47,14 +47,14 @@
+ L_CC="checkergcc $GFLAG"
+ L_LD="checkergcc"
+ elif [ "$CMD" = small ]; then
+- L_CC="$CC -Os -DNDEBUG"
+- L_LD="$LD -s"
++ L_CC="$CC -DNDEBUG"
++ L_LD="$LD"
+ elif [ "$CMD" = final ]; then
+- L_CC="$CC -O2 -DNDEBUG"
+- L_LD="$LD -s"
++ L_CC="$CC -DNDEBUG"
++ L_LD="$LD"
+ elif [ "$CMD" = asserted ]; then
+- L_CC="$CC -O2"
+- L_LD="$LD -s"
++ L_CC="$CC"
++ L_LD="$LD"
+ elif [ "$CMD" = clean ]; then
+ rm -f *.o core DEADJOE tif22pnm png22pnm
+ exit
diff --git a/media-gfx/tif22pnm/files/tif22pnm-0.14-math.patch b/media-gfx/tif22pnm/files/tif22pnm-0.14-math.patch
new file mode 100644
index 000000000000..99c6dba3aac6
--- /dev/null
+++ b/media-gfx/tif22pnm/files/tif22pnm-0.14-math.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/516274
+diff --git a/cc_help.sh.in b/cc_help.sh.in
+index b20feb6..1820304 100644
+--- a/cc_help.sh.in
++++ b/cc_help.sh.in
+@@ -7,2 +7,3 @@ LIBS_PNG='@LIBS_PNG@'
+ LIBS_TIFF='@LIBS_TIFF@'
++LIBS_MATH='@LIBS_MATH@'
+ ENABLE_DEBUG='@ENABLE_DEBUG@'
+diff --git a/configure.in b/configure.in
+index d11f42c..459ad8f 100644
+--- a/configure.in
++++ b/configure.in
+@@ -125,2 +125,8 @@ fi
+
++LIBS=""
++AC_SEARCH_LIBS([pow], [m], [LIBS_MATH="$LIBS"], [
++ AC_MSG_ERROR([unable to find the pow() function])
++])
++AC_SUBST(LIBS_MATH)
++
+ dnl Checks for header files.
+diff --git a/do.sh b/do.sh
+index fa15db8..0e9f449 100755
+--- a/do.sh
++++ b/do.sh
+@@ -117,3 +117,3 @@ SOURCES='png22pnm.c'
+ TARGET=png22pnm
+-LIBS="$LIBS_PNG"
++LIBS="$LIBS_PNG $LIBS_MATH"
+ build