summaryrefslogtreecommitdiff
path: root/media-gfx/tintii
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
commitfaddeff65d652bda3291eba255955adb17f1aa19 (patch)
tree4352e6d85ce48c7c8d96159fad4d3dd90602a70a /media-gfx/tintii
parent0e7b1da874d923b9f006e0000023f5fa528140a8 (diff)
gentoo auto-resync : 24:11:2023 - 16:33:11
Diffstat (limited to 'media-gfx/tintii')
-rw-r--r--media-gfx/tintii/Manifest2
-rw-r--r--media-gfx/tintii/tintii-2.10.0-r2.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/tintii/Manifest b/media-gfx/tintii/Manifest
index 1c59df078496..ed45ed6907d0 100644
--- a/media-gfx/tintii/Manifest
+++ b/media-gfx/tintii/Manifest
@@ -1,3 +1,5 @@
DIST tintii-2.10.0.tar.gz 620863 BLAKE2B 61127bfe1ce1eca87cea7fcd5cc6ef95c445ad0cdf32fd2d752a27818df8132ee0d7e6eab355c37ff3535be416a79b34652e8a28d8f93e0bd523a15396f6a4cd SHA512 884a9a3393080ee064069288afc13b2f72272571efaabf013ea2029627fc2ed922dcb791b8316c1d2117faf553d6bf333cf35f0486ba82aa2dc0987f9ce5f9a3
+DIST tintii_128.png 22351 BLAKE2B 54f32b1a0037e4acb05fa524ddbea10a942b0441570e4bb73f4659f1b536ac72261ad2ffd03db5a0df6f5819cb58081ce2371cce981ee037023b27054a31db56 SHA512 fb5458a10b6a461dc3b9a7e15d65616c8df318fc2a439118e0d0433e5badebe18da499ff7627ac30fd0374f754ebb90ac9c7ce5b2fb521820ea134a625862052
EBUILD tintii-2.10.0-r1.ebuild 555 BLAKE2B de7a9038871008016e49efb5d65c9f212232a5a31c25c96a2480530827d4f9c9b7a7be61f0b7919d0cee4224ab7011c700c349108ba5e9e82c5362c8b6e0cf83 SHA512 95d88eaf7d18690444ba482f509fa949f769e8b81d20c12117cc5ddc3746efb424ca409801ff60f68680a041136f093ff0197f658341573b3dcf95d6d10487f7
+EBUILD tintii-2.10.0-r2.ebuild 766 BLAKE2B bc99b3a23016c1aa72d61a350fffad52a9d358357bc4b555b5cbb6ac49d4270f7baa1cb3dd8e261370962026db8bb9e149e9a30f7f5ab8ca27a33511048a3f8d SHA512 a2b36c862029c4a175e86cd1321c0919c74dd05d62bbb2c19ba6aa51a872607dada39c67fe55172cf781222543c6851b68e41be142481370c0ed4514405c968b
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/media-gfx/tintii/tintii-2.10.0-r2.ebuild b/media-gfx/tintii/tintii-2.10.0-r2.ebuild
new file mode 100644
index 000000000000..5f7cbdb6b451
--- /dev/null
+++ b/media-gfx/tintii/tintii-2.10.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.2-gtk3"
+
+inherit desktop wxwidgets
+
+DESCRIPTION="Photo editor for selective color, saturation, and hue shift adjustments"
+HOMEPAGE="https://www.indii.org/software/tintii/"
+SRC_URI="https://www.indii.org/files/tint/releases/${P}.tar.gz
+ https://dev.gentoo.org/~pacho/${PN}/${PN}_128.png"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="sys-devel/bc"
+
+src_prepare() {
+ default
+ setup-wxwidgets
+}
+
+src_configure() {
+ econf --disable-assert
+}
+
+src_install() {
+ default
+ newicon "${DISTDIR}"/${PN}_128.png ${PN}.png
+ make_desktop_entry ${PN} Tintii
+}