summaryrefslogtreecommitdiff
path: root/media-gfx/word_cloud
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /media-gfx/word_cloud
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'media-gfx/word_cloud')
-rw-r--r--media-gfx/word_cloud/Manifest4
-rw-r--r--media-gfx/word_cloud/files/word_cloud-1.6.0-bundled-font.patch9
-rw-r--r--media-gfx/word_cloud/metadata.xml7
-rw-r--r--media-gfx/word_cloud/word_cloud-1.6.0.ebuild24
4 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/Manifest b/media-gfx/word_cloud/Manifest
new file mode 100644
index 000000000000..78de99cafc30
--- /dev/null
+++ b/media-gfx/word_cloud/Manifest
@@ -0,0 +1,4 @@
+AUX word_cloud-1.6.0-bundled-font.patch 238 BLAKE2B 0c62c4e8d76b3f5beb5e7e031bf25727809e2cf3c4c5954dfd748a0c60d1c118531321664c146889c88f8652c9a0ef05e1fc63c06bcac97719f6db937af6cea1 SHA512 f28a37c1c48ea878c6ba702a5bac100c6204b4f2ce9452cb93f37da62b0bf961e78f3ac082a6d1fd238da362f9019e29f337c6bc6f01e65749e2a836c7d6963e
+DIST word_cloud-1.6.0.tar.gz 27524706 BLAKE2B 751b78fca97ec6e93c6a766c5b960dbb5fd91c012637e9c905ef96eea0dc60882ef1604a9868cfb3ca91a2c9ac6f50132ad5d820e6dd52114e68112bbe6decb0 SHA512 cb67570e2f6206c92316ef398382703b4ff0f1740688cd4a9ec66a093a663e903da66daaef666d634a7fddc5ec19da859d706693940a963a3bf58c52e9054056
+EBUILD word_cloud-1.6.0.ebuild 623 BLAKE2B 8d307dde7291f9660d49dc08e5bddab75ed81d2f83367d1d30bf367ef9ab28bcf464fd20c93ce74f788222de01f88090fc66480cf80bb60f6ae5d65e9827e544 SHA512 9703bb931a38315a1968ded0a757d14074d220adfc14424d7b5e169ec8ffec5e4e784a4c1e248c832d63f11f7eaa704f3e40cbb98fad72cab30c3b7cd1a37e26
+MISC metadata.xml 212 BLAKE2B ecb53eb3efac6ceef048d345601c5ca0430e2f62d6409dc2a18494ee188f792d4763892816f197418d2e9a6d04452091a0c69d83afc207b366fca816632209ee SHA512 3919b8b096abf61c7edaa6a76898603b6ca2e206e2eccd27c671957a9d085bc2591a2fb4839a85ef2a51dcbf887bb2c752d4b38e82ea19c48dfd6d99b67954fa
diff --git a/media-gfx/word_cloud/files/word_cloud-1.6.0-bundled-font.patch b/media-gfx/word_cloud/files/word_cloud-1.6.0-bundled-font.patch
new file mode 100644
index 000000000000..3c43b30ce42b
--- /dev/null
+++ b/media-gfx/word_cloud/files/word_cloud-1.6.0-bundled-font.patch
@@ -0,0 +1,9 @@
+Don't install bundled DroidSansMono font.
+
+--- a/setup.py
++++ b/setup.py
+@@ -24,3 +24,3 @@
+ packages=['wordcloud'],
+- package_data={'wordcloud': ['stopwords', 'DroidSansMono.ttf']}
++ package_data={'wordcloud': ['stopwords']}
+ )
diff --git a/media-gfx/word_cloud/metadata.xml b/media-gfx/word_cloud/metadata.xml
new file mode 100644
index 000000000000..c665e48637be
--- /dev/null
+++ b/media-gfx/word_cloud/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>ulm@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-gfx/word_cloud/word_cloud-1.6.0.ebuild b/media-gfx/word_cloud/word_cloud-1.6.0.ebuild
new file mode 100644
index 000000000000..a8a60e0fb337
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+PATCHES=( "${FILESDIR}"/${P}-bundled-font.patch )