summaryrefslogtreecommitdiff
path: root/media-libs/aalib/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/aalib/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/aalib/files')
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch35
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc4-m4.patch9
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch34
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-fix-protos.patch56
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-key-down-OOB.patch23
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-more-protos.patch55
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-tinfo.patch19
7 files changed, 231 insertions, 0 deletions
diff --git a/media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch b/media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch
new file mode 100644
index 000000000000..4eb4a391a5be
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch
@@ -0,0 +1,35 @@
+Fix --with-gpm-mouse usage to not be so freaky. Don't patch
+configure.in that way we avoid having to run autotools.
+
+ AC_ARG_WITH(gpm-mouse,
+ - [ --with-gpm-mouse=base-dir Specifies the base gpm directory],
+ - if test x$withval = xyes
+ + [ --with-gpm-mouse=base-dir/no Specifies the base gpm directory],
+ + if test x$withval = xno
+ then
+ - AC_MSG_WARN(Usage is: --with-gpm-mouse=base-dir)
+ + gpm_mousedriver_test=no
+ else
+--- aalib-1.4.0/configure
++++ aalib-1.4.0/configure
+@@ -28,7 +28,7 @@
+ ac_help="$ac_help
+ --with-curses-driver=no/yes Used to disable/force curses driver"
+ ac_help="$ac_help
+- --with-gpm-mouse=base-dir Specifies the base gpm directory"
++ --with-gpm-mouse=base-dir/no Specifies the base gpm directory"
+ ac_help="$ac_help
+ --with-x use the X Window System"
+ ac_help="$ac_help
+@@ -1960,9 +1960,9 @@
+ # Check whether --with-gpm-mouse or --without-gpm-mouse was given.
+ if test "${with_gpm_mouse+set}" = set; then
+ withval="$with_gpm_mouse"
+- if test x$withval = xyes
++ if test x$withval = xno
+ then
+- echo "configure: warning: Usage is: --with-gpm-mouse=base-dir" 1>&2
++ gpm_mousedriver_test=no
+ else
+ LIBS="$LIBS -L$withval/lib -lgpm"
+ cat >> confdefs.h <<\EOF
diff --git a/media-libs/aalib/files/aalib-1.4_rc4-m4.patch b/media-libs/aalib/files/aalib-1.4_rc4-m4.patch
new file mode 100644
index 000000000000..3670f19125fc
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc4-m4.patch
@@ -0,0 +1,9 @@
+Get rid of aclocal warning:
+/usr/share/aclocal/aalib.m4:12: warning: underquoted definition of AM_PATH_AALIB
+--- aalib-1.4.0/aalib.m4
++++ aalib-1.4.0/aalib.m4
+@@ -11,3 +11,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_AALIB,
++AC_DEFUN([AM_PATH_AALIB],
+ [dnl
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch b/media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch
new file mode 100644
index 000000000000..97c59836b5c9
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch
@@ -0,0 +1,34 @@
+This bug can be seen very clearly with e.g. mplayer -vo aa -monitoraspect 3
+in which case a big part of the picture is missing or there is even completely
+black output.
+
+The reason for this is, when drawing only a part of the picture via aarender()
+the first X coordinate is used for the loop count, but it is not applied to the
+destination and source image index, thus instead of (re)drawing the middle part
+of the image, it draws always the left part.
+
+Actual Results:
+only the left part of the image is draw (depending on the video, only the left
+black bar might be draw, so you will see nothing at all - if so use a slightly
+smaller value for -monitoraspect).
+
+Expected Results:
+All of the image should be drawn, and -monitoraspect should only squeeze the
+image, not cause part of it to miss.
+
+Gentoo-bug: http://bugs.gentoo.org/id=214142
+Reported-by: Reimar Döffinger
+Fixed-by: Reimar Döffinger
+--- src/aarender.c.orig 2008-03-18 23:55:32.000000000 +0100
++++ src/aarender.c 2008-03-18 23:55:50.000000000 +0100
+@@ -94,8 +94,8 @@
+ gamma = randomval / 2;
+ mval = (c->parameters[c->filltable[255]].p[4]);
+ for (y = y1; y < y2; y++) {
+- pos = 2 * y * wi;
+- pos1 = y * aa_scrwidth(c);
++ pos = 2 * (y * wi + x1);
++ pos1 = y * aa_scrwidth(c) + x1;
+ esum = 0;
+ for (x = x1; x < x2; x++) {
+ i1 = table[((((int) c->imagebuffer[pos])))];
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-fix-protos.patch b/media-libs/aalib/files/aalib-1.4_rc5-fix-protos.patch
new file mode 100644
index 000000000000..b22738a25c6c
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-fix-protos.patch
@@ -0,0 +1,56 @@
+fix missing protos
+
+ * QA Notice: Package triggers severe warnings which indicate that it
+ * may exhibit random runtime failures.
+ * aainfo.c:12:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aainfo.c:17:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aatest.c:8:5: warning: incompatible implicit declaration of built-in function 'strcpy'
+ * aatest.c:11:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aatest.c:16:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aatest.c:21:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aafire.c:55:7: warning: incompatible implicit declaration of built-in function 'exit'
+ * aafire.c:68:3: warning: incompatible implicit declaration of built-in function 'exit'
+ * aafire.c:154:7: warning: incompatible implicit declaration of built-in function 'exit'
+ * aasavefont.c:10:2: warning: incompatible implicit declaration of built-in function 'exit'
+
+Gentoo-bug: http://bugs.gentoo.org/224267
+Reported-by: Peter Hüwe
+diff --git a/src/aafire.c b/src/aafire.c
+index 4f36149..5e41237 100644
+--- a/src/aafire.c
++++ b/src/aafire.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h> /* exit() */
+ #include "aalib.h"
+
+ #define XSIZ aa_imgwidth(context)
+diff --git a/src/aainfo.c b/src/aainfo.c
+index d3f6d50..e24082d 100644
+--- a/src/aainfo.c
++++ b/src/aainfo.c
+@@ -1,4 +1,4 @@
+-
++#include <stdlib.h> /* exit() */
+ #include "aalib.h"
+ #include "aaint.h"
+ int main(int argc, char **argv)
+diff --git a/src/aasavefont.c b/src/aasavefont.c
+index b00e1e6..16591e8 100644
+--- a/src/aasavefont.c
++++ b/src/aasavefont.c
+@@ -1,3 +1,4 @@
++#include <stdlib.h> /* exit() */
+ #include "aalib.h"
+ int main(int argc, char **argv)
+ {
+diff --git a/src/aatest.c b/src/aatest.c
+index 9816f5d..ed0c2da 100644
+--- a/src/aatest.c
++++ b/src/aatest.c
+@@ -1,3 +1,5 @@
++#include <string.h> /* strcpy() */
++#include <stdlib.h> /* exit() */
+ #include "aalib.h"
+ int main(int argc, char **argv)
+ {
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-key-down-OOB.patch b/media-libs/aalib/files/aalib-1.4_rc5-key-down-OOB.patch
new file mode 100644
index 000000000000..8078aa5b2708
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-key-down-OOB.patch
@@ -0,0 +1,23 @@
+diff -Naur a/src/aalinuxkbd.c b/src/aalinuxkbd.c
+--- a/src/aalinuxkbd.c 2016-12-19 12:40:26.660039735 +0100
++++ b/src/aalinuxkbd.c 2016-12-19 12:42:21.692045971 +0100
+@@ -114,6 +114,7 @@
+ static int vtswitch_allowed;
+
+ static char key_down[128];
++static size_t key_down_size = 128;
+ static int closed = 1;
+ static int mypid;
+
+@@ -165,10 +166,7 @@
+
+ static void blank_key_down(void)
+ {
+- int f;
+-
+- for (f = 0; f < NR_KEYS; f++)
+- key_down[f] = 0;
++ memset(key_down, 0, key_down_size);
+ }
+
+
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-more-protos.patch b/media-libs/aalib/files/aalib-1.4_rc5-more-protos.patch
new file mode 100644
index 000000000000..58d37f1cb7c9
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-more-protos.patch
@@ -0,0 +1,55 @@
+diff --git a/src/aakbdreg.c b/src/aakbdreg.c
+index f4f8efb..b344dd8 100644
+--- a/src/aakbdreg.c
++++ b/src/aakbdreg.c
+@@ -1,2 +1,3 @@
+ #include <stdlib.h>
++#include <string.h> /* strcmp */
+ #include "config.h"
+diff --git a/src/aalinuxkbd.c b/src/aalinuxkbd.c
+index a5379bb..e816eb2 100644
+--- a/src/aalinuxkbd.c
++++ b/src/aalinuxkbd.c
+@@ -10,2 +10,3 @@
+ #include "config.h"
++#include <stdlib.h> /* atexit */
+ #ifdef LINUX_DRIVER
+@@ -135,3 +136,3 @@ static int get_keyb_map(void)
+
+- if (ioctl(tty_fd, KDGKBENT, (unsigned int) &keyb_ent))
++ if (ioctl(tty_fd, KDGKBENT, &keyb_ent))
+ return (0);
+@@ -144,3 +145,3 @@ static int get_keyb_map(void)
+
+- if (ioctl(tty_fd, KDGKBENT, (unsigned int) &keyb_ent))
++ if (ioctl(tty_fd, KDGKBENT, &keyb_ent))
+ return (0);
+@@ -200,3 +201,3 @@ static int rawmode_init(void)
+ if (!closed)
+- return;
++ return (1);
+ mypid = getpid();
+diff --git a/src/aamoureg.c b/src/aamoureg.c
+index bb55fe3..4a533b6 100644
+--- a/src/aamoureg.c
++++ b/src/aamoureg.c
+@@ -1,2 +1,3 @@
+ #include <stdlib.h>
++#include <string.h> /* strcmp */
+ #include "config.h"
+diff --git a/src/aaregist.c b/src/aaregist.c
+index 765155e..f9190ab 100644
+--- a/src/aaregist.c
++++ b/src/aaregist.c
+@@ -1,2 +1,3 @@
+ #include <stdlib.h>
++#include <string.h> /* strcmp */
+ #include "config.h"
+diff --git a/src/aaxkbd.c b/src/aaxkbd.c
+index dacc80f..c252cd9 100644
+--- a/src/aaxkbd.c
++++ b/src/aaxkbd.c
+@@ -7,2 +7,3 @@
+ #include <X11/Xlib.h>
++#include <X11/Xutil.h>
+ #include <X11/keysymdef.h>
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-tinfo.patch b/media-libs/aalib/files/aalib-1.4_rc5-tinfo.patch
new file mode 100644
index 000000000000..daf9cde9f575
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-tinfo.patch
@@ -0,0 +1,19 @@
+diff --git a/configure.ac b/configure.ac
+index 66bcbc0..f15f06e 100644
+--- a/configure.in
++++ b/configure.in
+@@ -302,6 +302,14 @@ AC_DEFUN(AC_CURSES, [
+ if test "$curses_driver_test" = yes; then
+ if $search_ncurses
+ then
+ AC_CHECKING("location of curses")
++ PKG_CHECK_MODULES([CURSES], [ncurses], [
++ AC_MSG_RESULT([Found ncurses via pkg-config: CURSES_CFLAGS="$CURSES_CFLAGS" CURSES_LIBS="$CURSES_LIBS"])
++ CFLAGS="$CFLAGS $CURSES_CFLAGS"
++ LIBS="$LIBS $CURSES_LIBS"
++ AALIB_LIBS="$AALIB_LIBS $CURSES_LIBS"
++ search_ncurses=false
++ curses_driver=true
++ ], [])
+
+ AC_NCURSES(/usr/include, ncurses.h, , -I/usr/include/ncurses , "ncurses on /usr/include")