summaryrefslogtreecommitdiff
path: root/media-libs/cogl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /media-libs/cogl
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'media-libs/cogl')
-rw-r--r--media-libs/cogl/Manifest2
-rw-r--r--media-libs/cogl/cogl-1.22.8.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/media-libs/cogl/Manifest b/media-libs/cogl/Manifest
index fcc5d9f9b288..3310b8f1b3d2 100644
--- a/media-libs/cogl/Manifest
+++ b/media-libs/cogl/Manifest
@@ -1,4 +1,6 @@
AUX cogl-eglmesaext-include.patch 2204 BLAKE2B 307a473a606129fe7e08e65915dbe985d3765c2745ec444b41592f8c36ab5b6ad0d43bbc35a93f01666d8cff81111e0c211bddfbf5d89f48591c8bf5377cb471 SHA512 41e475d73e12e4ab517c49ae1a70d1dd71e9f8a618eb28cd7b81430bf3acec84bbdf8a31ec4e02fd87734fe402e523cda5c14c4a4c5d63928b9de930bcf23e10
DIST cogl-1.22.6.tar.xz 1744240 BLAKE2B d3483c972705ec72d2ccbd06106bdd37ea23a7940c7d5f5d8c45da43a8e5ed7bc2fb5f07838b5a0cfe9b54d3681120008c03945ee8bac39042a9c263e84d3549 SHA512 b3475fa4fff3b6725f643b0d17d2de242fce1503cd83bd18031d98495501917bf5173152fb1aba7f2614fcf6553029fbb6f26bda5a497f5f12e2849ed301a483
+DIST cogl-1.22.8.tar.xz 1742632 BLAKE2B c6230a2223928c5d4e5d87fa6b039c96000fac546e3e57e04e528b571500d350013a4b6e0a2ab6b2133672fec992fff6f9486ab8c83a01cf9790bc94266c75d4 SHA512 702d5b1b22dc34bffaa82c9c57021caf036ee3a13fa7ca24a90cca1ebc0f8b7a86070cc1fe5125757132b02774fa874bb55675c96d1ccbc233fac0e6132da65f
EBUILD cogl-1.22.6.ebuild 3384 BLAKE2B c591d4942a45b55cd9bceb0dd8e438c15a2a4a8b6dc2e2ca1f56dde8e3f113c8d4b6543f5d34b065f2690dcda4553b4a32ea5a21a03ebca8e982a809f1f03920 SHA512 3aabd0e305a5391109755f90f022487aebcaf46482094d0f8894d3c94565ceb661b63ac0bc5e4b22d122d6f16d00df9009f86541970ee28e470349e64c4caaec
+EBUILD cogl-1.22.8.ebuild 3274 BLAKE2B f332391ea88386192cbd95c9684bddc4a8320fdc8cc96c89060779c4e1df1170d73c4d9b3097e89e745d806b0036cd297c75b75a64958492937cd0d407330ee1 SHA512 105a2a3921018594c9c6864053cb4c028f7b286f07988454387c821bea1a6ded73d821b4d8f381eafcbd2f56dc53d7e0b498923970bfe0697e29772551d4700c
MISC metadata.xml 457 BLAKE2B 79c55fb3e5a1e5772c7b26cea5b54b15d683772204ec2ff2229481085130f4945b877a4608f01308a297571c01fa0da50220cd44b6a333eb34d2aae71c3a9157 SHA512 e0e4be51119ec98c906ca2f5df69c9024d77855fafa53ec00bc30b481f33dfd98708c2c9021737f84a46121788079fdc1d9ecffc2693a3257819f05879318a44
diff --git a/media-libs/cogl/cogl-1.22.8.ebuild b/media-libs/cogl/cogl-1.22.8.ebuild
new file mode 100644
index 000000000000..0582d681b12b
--- /dev/null
+++ b/media-libs/cogl/cogl-1.22.8.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 multilib
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="https://www.cogl3d.org/"
+
+LICENSE="MIT BSD"
+SLOT="1.0/20" # subslot = .so version
+
+# doc and profile disable for now due to bugs #484750 and #483332
+IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango wayland" # doc profile
+REQUIRED_USE="
+ wayland? ( gles2 )
+ || ( gles2 opengl )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ x11-libs/cairo:=
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXrandr-1.2
+ virtual/opengl
+ gles2? ( media-libs/mesa[gles2] )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.34.2:= )
+ kms? (
+ media-libs/mesa[egl,gbm]
+ x11-libs/libdrm:= )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )
+ wayland? (
+ >=dev-libs/wayland-1.1.90
+ media-libs/mesa[egl,wayland] )
+"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19
+ virtual/pkgconfig
+"
+
+# Need classic mesa swrast for tests, llvmpipe causes a test failure
+# For some reason GL3 conformance test all fails again...
+RESTRICT="test"
+
+src_prepare() {
+ # Do not build examples
+ sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+
+ #if ! use test ; then
+ # For some reason the configure switch will not completely disable
+ # tests being built
+ sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
+ -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
+ -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ #fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # TODO: think about quartz, sdl
+ # Prefer gl over gles2 if both are selected
+ # Profiling needs uprof, which is not available in portage yet, bug #484750
+ # FIXME: Doesn't provide prebuilt docs, but they can neither be rebuilt, bug #483332
+ gnome2_src_configure \
+ --disable-examples-install \
+ --disable-maintainer-flags \
+ --enable-cairo \
+ --enable-deprecated \
+ --enable-gdk-pixbuf \
+ --enable-glib \
+ $(use_enable debug) \
+ $(use_enable opengl glx) \
+ $(use_enable opengl gl) \
+ $(use_enable gles2) \
+ $(use_enable gles2 cogl-gles2) \
+ $(use_enable gles2 xlib-egl-platform) \
+ $(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
+ $(use_enable gstreamer cogl-gst) \
+ $(use_enable introspection) \
+ $(use_enable kms kms-egl-platform) \
+ $(use_enable pango cogl-pango) \
+ --disable-unit-tests \
+ $(use_enable wayland wayland-egl-platform) \
+ $(use_enable wayland wayland-egl-server) \
+ --disable-profile
+# $(use_enable profile)
+}
+
+src_install() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/{*.c,*.jpg}
+ fi
+
+ gnome2_src_install
+
+ # Remove silly examples-data directory
+ rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
+}