summaryrefslogtreecommitdiff
path: root/media-libs/glu/glu-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /media-libs/glu/glu-9999.ebuild
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'media-libs/glu/glu-9999.ebuild')
-rw-r--r--media-libs/glu/glu-9999.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/media-libs/glu/glu-9999.ebuild b/media-libs/glu/glu-9999.ebuild
index 684f3b54380a..b743ef44af75 100644
--- a/media-libs/glu/glu-9999.ebuild
+++ b/media-libs/glu/glu-9999.ebuild
@@ -1,24 +1,23 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/mesa/glu.git"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/glu.git"
if [[ ${PV} = 9999* ]]; then
AUTOTOOLS_AUTORECONF=1
- GIT_ECLASS="git-2"
+ GIT_ECLASS="git-r3"
EXPERIMENTAL="true"
fi
-inherit autotools-multilib multilib ${GIT_ECLASS}
+inherit autotools multilib-minimal ${GIT_ECLASS}
DESCRIPTION="The OpenGL Utility Library"
-HOMEPAGE="https://cgit.freedesktop.org/mesa/glu/"
+HOMEPAGE="https://gitlab.freedesktop.org/mesa/glu"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
- KEYWORDS=""
else
SRC_URI="https://mesa.freedesktop.org/archive/glu/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
@@ -32,9 +31,18 @@ DEPEND=">=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}
!<media-libs/mesa-9"
-src_unpack() {
+src_prepare() {
+ eapply_user
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
default
- [[ $PV = 9999* ]] && git-2_src_unpack
+ find "${D}" -name '*.la' -delete || die
}
src_test() {