summaryrefslogtreecommitdiff
path: root/media-libs/gmmlib/gmmlib-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /media-libs/gmmlib/gmmlib-9999.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'media-libs/gmmlib/gmmlib-9999.ebuild')
-rw-r--r--media-libs/gmmlib/gmmlib-9999.ebuild27
1 files changed, 9 insertions, 18 deletions
diff --git a/media-libs/gmmlib/gmmlib-9999.ebuild b/media-libs/gmmlib/gmmlib-9999.ebuild
index 4e796e2186d3..1f972c3b1914 100644
--- a/media-libs/gmmlib/gmmlib-9999.ebuild
+++ b/media-libs/gmmlib/gmmlib-9999.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-CMAKE_ECLASS=cmake
-
-inherit cmake-multilib
+inherit cmake
if [[ ${PV} == *9999 ]] ; then
: ${EGIT_REPO_URI:="https://github.com/intel/gmmlib"}
@@ -17,32 +15,25 @@ fi
DESCRIPTION="Intel Graphics Memory Management Library"
HOMEPAGE="https://github.com/intel/gmmlib"
-if [[ ${PV} == *9999 ]] ; then
- SRC_URI=""
-else
- SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
- S="${WORKDIR}/${PN}-intel-${P}"
- KEYWORDS="~amd64"
-fi
+SRC_URI=""
LICENSE="MIT"
SLOT="0"
IUSE="test +custom-cflags"
-
RESTRICT="!test? ( test )"
-RDEPEND="${DEPEND}"
-
PATCHES=(
"${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
"${FILESDIR}"/${PN}-20.4.1_custom_cflags.patch
+ "${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
)
-multilib_src_configure() {
+src_configure() {
local mycmakeargs=(
- -DBUILD_TYPE=Release
- -DBUILD_TESTING=$(usex test)
- -DOVERRIDE_COMPILER_FLAGS=$(usex !custom-cflags)
+ -DBUILD_TESTING="$(usex test)"
+ -DBUILD_TYPE="Release"
+ -DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
)
+
cmake_src_configure
}