summaryrefslogtreecommitdiff
path: root/media-libs/hamlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /media-libs/hamlib
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/Manifest1
-rw-r--r--media-libs/hamlib/hamlib-4.5.5-r3.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index 7c0673e37503..131b2a92d117 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -2,4 +2,5 @@ AUX hamlib-4.5.5-gcc14-fix.patch 224 BLAKE2B 882645207d62657b790e76d5e4d3a17be3a
DIST hamlib-4.5.5.tar.gz 2603846 BLAKE2B ad4a286a7aa1e972707cb9ed15a4268909a7d252a64b98b01d35c9d9e42c605cd600e819e195e49d501c1e135191fda585581e27801fa217c9141236a81ad770 SHA512 2cdff2630e89fa95c7ac40e998492e8a04e000fcca18b9491ddcb967927ffaa771ed2e6ac3232a060947883533a6ae7405042a2f8fdb1de157d71f74381f5899
EBUILD hamlib-4.5.5-r1.ebuild 2138 BLAKE2B 7b3ce1c1617861c48ea3b1a0a58ae0690d595e02e2837eb4a057dd990bc3105038fafb4608f3b66184cc4958f19a92d0e7299b5311c1714d6f5770d9a5c4a965 SHA512 378da3183a49bce0fa176d1583d786742e43d4be184143e4fc8daa744665134d6a97d87b6f6be1a6c2fd7d82b332ba22585f48942fc513152773a0f4e2b635ea
EBUILD hamlib-4.5.5-r2.ebuild 2196 BLAKE2B dff5f4ee5a746f15a121283e58be831ba66cfd98cc88e92532ed2add396105c88643262d4ce942137fba4c09ad430dd3870d46ffeb6de73f6b86c697635d46e5 SHA512 381bf4a6712d790ecccd59fef627250ae2e03cb3b3d68bae822adaf8a79de832693310d175a0c6c8cd9cfa8e7dfec72f4ed11c19e2b681d958badb348330ae56
+EBUILD hamlib-4.5.5-r3.ebuild 2196 BLAKE2B 93477a5040b315d8e94a8ff24afaccfe3bb2932e11723e9f6bc3d2bf6a62dfacbe025753174372d160b92f4a79761338dc781d96fb2e078eef9932b793656513 SHA512 66255a94b670be8c906dbb034163902f44f2066c1b124a12dd53dfe517321ac3b9a5d01bcc6638597933c2dcfb0c96e2e6bed2394ae0baf7b8ea3bd7d186b2e8
MISC metadata.xml 379 BLAKE2B 17bfaa1ae7f031e14bef4bad4d552e3d4b644b9578bd996a9e8454b6b55f4029c3395e8a1cfc5a2b27a5372cd1aea140e0aebe637f7eb7889008fb434897b681 SHA512 c8c7a37088c0da4952a557776db8b6b701df23c07c4b17c50b77a199a6e7740369e27254eabae4e504ecb07871d33aec008e54bc7a787030828616ab36dfcb93
diff --git a/media-libs/hamlib/hamlib-4.5.5-r3.ebuild b/media-libs/hamlib/hamlib-4.5.5-r3.ebuild
new file mode 100644
index 000000000000..208e7e9d4980
--- /dev/null
+++ b/media-libs/hamlib/hamlib-4.5.5-r3.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+MY_P=${P/_rc2/~rc2}
+
+inherit autotools flag-o-matic python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="https://www.hamlib.github.io"
+SRC_URI="mirror://sourceforge/hamlib/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/4.2"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0=
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-lang/swig
+ >=dev-build/libtool-2.2
+ doc? ( app-text/doxygen
+ dev-util/source-highlight )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.5.5-gcc14-fix.patch"
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Correct install target to whatever INSTALLDIRS says and use vendor
+ # installdirs everywhere (bug #611550)
+ sed -i -e "s#install_site#install#" \
+ -e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \
+ bindings/Makefile.am || die "sed failed patching for perl"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/926839
+ # https://github.com/Hamlib/Hamlib/issues/1524
+ filter-lto
+
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-xml-support \
+ $(use_with perl perl-binding) \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+}
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use python && python_optimize
+
+ use doc && HTML_DOCS=( doc/html/ )
+ einstalldocs
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+
+ find "${ED}" -name '*.la' -delete || die
+}