summaryrefslogtreecommitdiff
path: root/media-libs/hamlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-23 06:45:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-23 06:45:02 +0000
commitc78477d222e1ceb9516a9bbbadbba0b5c1ce11db (patch)
tree5187cbad4740387edb2c1cca0942036a0fdccd88 /media-libs/hamlib
parent564687d289b862b8b079569a45a2d39d7b8c3585 (diff)
gentoo auto-resync : 23:01:2025 - 06:45:02
Diffstat (limited to 'media-libs/hamlib')
-rw-r--r--media-libs/hamlib/Manifest2
-rw-r--r--media-libs/hamlib/hamlib-4.6.1.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/media-libs/hamlib/Manifest b/media-libs/hamlib/Manifest
index 813bd3aae7d9..3ecb2826dbe9 100644
--- a/media-libs/hamlib/Manifest
+++ b/media-libs/hamlib/Manifest
@@ -1,4 +1,6 @@
AUX hamlib-4.5.5-gcc14-fix.patch 224 BLAKE2B 882645207d62657b790e76d5e4d3a17be3aca9dfd978d5a2939bfc81a018788e6a2b3d1f37bf2d0e122740014e076820dfc9c626d24509741b1342ec700d2a75 SHA512 1529f2002de0e9c216dad0f4bcf0656fb70da543ab0f84d19e8a1621e87d9983f43f7bbc05cae09ab3a2310628b7522c152f15861f32adad05c9088e36b01acd
DIST hamlib-4.5.5.tar.gz 2603846 BLAKE2B ad4a286a7aa1e972707cb9ed15a4268909a7d252a64b98b01d35c9d9e42c605cd600e819e195e49d501c1e135191fda585581e27801fa217c9141236a81ad770 SHA512 2cdff2630e89fa95c7ac40e998492e8a04e000fcca18b9491ddcb967927ffaa771ed2e6ac3232a060947883533a6ae7405042a2f8fdb1de157d71f74381f5899
+DIST hamlib-4.6.1.tar.gz 2909273 BLAKE2B d8ab443bd19068ec76fbe021f9dcdbaf3cead9a6eac1eab47c148c35fe7c98d294d50386cc3c386e8113ac26a9aa594f7a9d121e81601c84660350115566b1b6 SHA512 3363665e2fc5541e2bd68767e9c0d8c856a7d2ea9a7e4a2d7e79d6e7349150642cba4e96d27ab6dc029fd838e05c3f0f9f7acadcc7c8bc51bedaf61ef67e95ce
EBUILD hamlib-4.5.5-r3.ebuild 2207 BLAKE2B 085c5dbad4fdaa2d4c6a7e2831aca85ae77de74d9b3d3167d382bff110804db87b85543c80ffa2407eaa1f562d570c9e2e9bcf272f92acae4ae8021d737694a4 SHA512 33a2f3843d80a1c29ab995e48c4c9c9913e26c2b204e75033bce9d9a1f01bbc650abb935bdfae85446ade5eff034b52263fe6124ca7525334c509aab52a0c811
+EBUILD hamlib-4.6.1.ebuild 2153 BLAKE2B a838be1a79f8ce5eaf5c6b104e0d0cf802141ce59e1e8b5c7acfc7ed45d2bae3591d17a22a97ff74c29a220d37d3e3600d93fc20b735f471a89a55d7f3d22006 SHA512 a3ce15e167e64623053e7ab1021f3af0dae8190cec608ca70eae37318eb886ad3c2b2a8a794563160f1b6d120b92d6aad5d5ae38abe38c99e9c3c920f30d24cd
MISC metadata.xml 379 BLAKE2B 17bfaa1ae7f031e14bef4bad4d552e3d4b644b9578bd996a9e8454b6b55f4029c3395e8a1cfc5a2b27a5372cd1aea140e0aebe637f7eb7889008fb434897b681 SHA512 c8c7a37088c0da4952a557776db8b6b701df23c07c4b17c50b77a199a6e7740369e27254eabae4e504ecb07871d33aec008e54bc7a787030828616ab36dfcb93
diff --git a/media-libs/hamlib/hamlib-4.6.1.ebuild b/media-libs/hamlib/hamlib-4.6.1.ebuild
new file mode 100644
index 000000000000..0aa7bcf6e296
--- /dev/null
+++ b/media-libs/hamlib/hamlib-4.6.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+MY_P=${P/_rc2/~rc2}
+
+inherit autotools flag-o-matic python-single-r1
+
+DESCRIPTION="Ham radio backend rig control libraries"
+HOMEPAGE="https://www.hamlib.github.io"
+SRC_URI="https://downloads.sourceforge.net/hamlib/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/4.2"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="doc perl python tcl"
+
+RESTRICT="test"
+
+RDEPEND="
+ =virtual/libusb-0*
+ dev-libs/libxml2
+ sys-libs/readline:0=
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ tcl? ( dev-lang/tcl:0= )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-lang/swig
+ >=dev-build/libtool-2.2
+ doc? ( app-text/doxygen
+ dev-util/source-highlight )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=(AUTHORS NEWS PLAN README README.betatester README.developer)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Correct install target to whatever INSTALLDIRS says and use vendor
+ # installdirs everywhere (bug #611550)
+ sed -i -e "s#install_site#install#" \
+ -e 's#MAKEFILE="Hamlib-pl.mk"#MAKEFILE="Hamlib-pl.mk" INSTALLDIRS=vendor#' \
+ bindings/Makefile.am || die "sed failed patching for perl"
+
+ # make building of documentation compatible with autotools-utils
+ sed -i -e "s/doc:/html:/g" doc/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/926839
+ # https://github.com/Hamlib/Hamlib/issues/1524
+ filter-lto
+
+ econf \
+ --libdir=/usr/$(get_libdir)/hamlib \
+ --disable-static \
+ --with-xml-support \
+ $(use_with perl perl-binding) \
+ $(use_with python python-binding) \
+ $(use_with tcl tcl-binding)
+}
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ use python && python_optimize
+
+ use doc && HTML_DOCS=( doc/html/ )
+ einstalldocs
+
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins hamlib.pc
+
+ echo "LDPATH=/usr/$(get_libdir)/hamlib" > "${T}"/73hamlib
+ doenvd "${T}"/73hamlib
+
+ find "${ED}" -name '*.la' -delete || die
+}