summaryrefslogtreecommitdiff
path: root/media-libs/ilmbase/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /media-libs/ilmbase/files
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'media-libs/ilmbase/files')
-rw-r--r--media-libs/ilmbase/files/ilmbase-2.5.2-musl.patch50
1 files changed, 0 insertions, 50 deletions
diff --git a/media-libs/ilmbase/files/ilmbase-2.5.2-musl.patch b/media-libs/ilmbase/files/ilmbase-2.5.2-musl.patch
deleted file mode 100644
index 80f11e44c12e..000000000000
--- a/media-libs/ilmbase/files/ilmbase-2.5.2-musl.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From c7af102e6bce6638add2f38576ffe9c6741ba768 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Niklas=20Hamb=C3=BCchen?= <mail@nh2.me>
-Date: Thu, 30 Jul 2020 02:21:07 +0200
-Subject: [PATCH] IexMathFpu.cpp: Fix build on non-glibc (e.g. musl libc).
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Originally from:
-https://github.com/void-linux/void-packages/blob/80bbc168faa25448bd3399f4df331b836e74b85c/srcpkgs/ilmbase/patches/musl-_fpstate.patch
-
-Fixes error:
-
- IlmBase/IexMath/IexMathFpu.cpp: In function ‘void Iex_2_4::FpuControl::restoreControlRegs(const ucontext_t&, bool)’:
- IlmBase/IexMath/IexMathFpu.cpp:284:38: error: ‘struct _fpstate’ has no member named ‘cw’; did you mean ‘cwd’?
- 284 | setCw ((ucon.uc_mcontext.fpregs->cw & cwRestoreMask) | cwRestoreVal);
- | ^~
- | cwd
- IlmBase/IexMath/IexMathFpu.cpp:287:20: error: ‘struct Iex_2_4::FpuControl::_fpstate_64’ has no member named ‘magic’
- 287 | setMxcsr (kfp->magic == 0 ? kfp->mxcsr : 0, clearExceptions);
- | ^~~~~
-
-Signed-off-by: Niklas Hambüchen <mail@nh2.me>
----
- IlmBase/IexMath/IexMathFpu.cpp | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/IlmBase/IexMath/IexMathFpu.cpp b/IlmBase/IexMath/IexMathFpu.cpp
-index ceed658e0..439329e50 100644
---- a/IexMath/IexMathFpu.cpp
-+++ b/IexMath/IexMathFpu.cpp
-@@ -281,10 +281,18 @@ restoreControlRegs (const ucontext_t & ucon, bool clearExceptions)
- inline void
- restoreControlRegs (const ucontext_t & ucon, bool clearExceptions)
- {
-+#if defined(__GLIBC__) || defined(__i386__)
- setCw ((ucon.uc_mcontext.fpregs->cw & cwRestoreMask) | cwRestoreVal);
-+#else
-+ setCw ((ucon.uc_mcontext.fpregs->cwd & cwRestoreMask) | cwRestoreVal);
-+#endif
-
- _fpstate * kfp = reinterpret_cast<_fpstate *> (ucon.uc_mcontext.fpregs);
-+#if defined(__GLIBC__) || defined(__i386__)
- setMxcsr (kfp->magic == 0 ? kfp->mxcsr : 0, clearExceptions);
-+#else
-+ setMxcsr (kfp->mxcsr, clearExceptions);
-+#endif
- }
-
- #endif