summaryrefslogtreecommitdiff
path: root/media-libs/libaom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/libaom
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/libaom')
-rw-r--r--media-libs/libaom/Manifest4
-rw-r--r--media-libs/libaom/libaom-3.3.0.ebuild102
-rw-r--r--media-libs/libaom/libaom-9999.ebuild6
3 files changed, 107 insertions, 5 deletions
diff --git a/media-libs/libaom/Manifest b/media-libs/libaom/Manifest
index 815849f288ca..2556c45c19fb 100644
--- a/media-libs/libaom/Manifest
+++ b/media-libs/libaom/Manifest
@@ -1,4 +1,6 @@
DIST libaom-3.2.0.tar.gz 4717955 BLAKE2B b247c9092bf3b8080b33671f182b10eea060a2eafd94eeb1b92177d2c7b5c32de2342f9cf1c7e500b28fdac2b00ea8d43b1e56c9d1c8c0efe1bbc4e40285a52a SHA512 649bebde85c1a42b0c1c3d2d3b7110b999e3ee1c8e76595259e4e75a8b0f3918e23ff7c7e2c313da4d579882f55bf29765bb882570280adc81f3bc1e82f1ee19
+DIST libaom-3.3.0.tar.gz 4768475 BLAKE2B 22060694019bcd925cb38c365063b8f2be60aed4cc6f9b0aa95cf8b4c4c5b40f5c603359d8c0728c5650fe9f7eea7573b8fd4a93975481c67409b201b4c48428 SHA512 9bd118bf46d777da4e85f348fed95510ce583d16d005d062d33e2899f16f24bdb8b120792a7c77ccb64b4e1ff5b3d934342fb1b356bb426693ef69220f138c5f
EBUILD libaom-3.2.0.ebuild 2422 BLAKE2B 3bc74e6923f44c3daefdbed351e6fabb3ace367981499af4051205d3e8d5e0200a072ba8f9d91302d7a32be751c64f1f89a4d7fe095f8354c56d147a04ec55e6 SHA512 34767df5f510f6ba88eef3475d4e52765ba8967150854635c363cca2c7e42fc3646205d6aea64b9f6e1397dc87a582bfbf3e42f472355e5527cb294bd473742a
-EBUILD libaom-9999.ebuild 2428 BLAKE2B 274b92868f8986aecf1cddd8d47e4c70d1070eb262b772ff440d3e1ff05bfe5ab2ea12f411582bd776a6e87fa8933653b79604ccd070deeb6163af4a828a9b6c SHA512 415e58b83def4ad6b9b5b60ac98e5edd3929d4ba042d05b02949f8b958dd728d725c05a92aea6f51cc72b69c8d52d9acfde0605365ae7ab5efc910b09d8cae07
+EBUILD libaom-3.3.0.ebuild 3090 BLAKE2B 5174985df97a5ce713c16230bb2744a71e3cd5203d5e1301c58cf90353df3af9c7790a2ea817b2fa78064ae8b2a30223d29258f1df8027b91fc22be44969decc SHA512 1ddd6c41017f2236c03c0a3d0f4c14cbc8a926f6eae2a92f52547a02b450964c3b5b284c3d8367ad6a799dcebec9ae828bda8e922cbc5960f8da5d6972622205
+EBUILD libaom-9999.ebuild 2432 BLAKE2B e5dea7087d3d0dc2a5ed9e671c0a3e044c0cd079299f851b63d10c4e5d446002b47f0707a8e31d0427355df0b77cfd71bbdc41bdbdba6cdb36bd23707a8451d4 SHA512 316469183bc7b44a60db5ab0ffd59ebc634426901bf56cde8658e28cfd95815af9d31f4e9215e09c7e2ed1f335eef407da74096e82060cd413356841cf7fe371
MISC metadata.xml 224 BLAKE2B a8fa831654345ddf74b54f53fdc27d128ff6896378c8aa2dcb27139a4382f63efd0cac17f94ee420932e2855042c94e32fe534c99a977698953aaab4c51c31d0 SHA512 0b59f17151d352f25e3b073a3ee388d0189e1caddf0d97142851a19df433d082e3eead9f5aae07f4beb247861d90f02ae217514d02445703b95ee6ff62d967b8
diff --git a/media-libs/libaom/libaom-3.3.0.ebuild b/media-libs/libaom/libaom-3.3.0.ebuild
new file mode 100644
index 000000000000..e23ac9e6a952
--- /dev/null
+++ b/media-libs/libaom/libaom-3.3.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit cmake-multilib python-any-r1
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
+else
+ SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
+fi
+
+DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
+HOMEPAGE="https://aomedia.org https://aomedia.googlesource.com/aom/"
+
+LICENSE="BSD-2"
+SLOT="0/3"
+IUSE="doc +examples"
+IUSE="${IUSE} cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3"
+IUSE="${IUSE} cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2"
+IUSE="${IUSE} cpu_flags_arm_neon"
+
+REQUIRED_USE="
+ cpu_flags_x86_sse2? ( cpu_flags_x86_mmx )
+ cpu_flags_x86_ssse3? ( cpu_flags_x86_sse2 )
+"
+
+BDEPEND="${PYTHON_DEPS}
+ abi_x86_32? ( dev-lang/yasm )
+ abi_x86_64? ( dev-lang/yasm )
+ abi_x86_x32? ( dev-lang/yasm )
+ doc? ( app-doc/doxygen )
+"
+
+# the PATENTS file is required to be distributed with this package, bug #682214
+DOCS=( PATENTS )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CCACHE=OFF
+ -DENABLE_DOCS=$(multilib_native_usex doc ON OFF)
+ -DENABLE_EXAMPLES=$(multilib_native_usex examples ON OFF)
+ -DENABLE_NASM=OFF
+ -DENABLE_TESTS=OFF
+ -DENABLE_TOOLS=ON
+ -DENABLE_WERROR=OFF
+
+ # Needs libjxl, currently unpackaged.
+ -DCONFIG_TUNE_BUTTERAUGLI=0
+
+ # neon support is assumed to be always enabled on arm64
+ -DENABLE_NEON=$(usex cpu_flags_arm_neon ON $(usex arm64 ON OFF))
+ # ENABLE_DSPR2 / ENABLE_MSA for mips
+ -DENABLE_MMX=$(usex cpu_flags_x86_mmx ON OFF)
+ -DENABLE_SSE=$(usex cpu_flags_x86_sse ON OFF)
+ -DENABLE_SSE2=$(usex cpu_flags_x86_sse2 ON OFF)
+ -DENABLE_SSE3=$(usex cpu_flags_x86_sse3 ON OFF)
+ -DENABLE_SSSE3=$(usex cpu_flags_x86_ssse3 ON OFF)
+ -DENABLE_SSE4_1=$(usex cpu_flags_x86_sse4_1 ON OFF)
+ -DENABLE_SSE4_2=$(usex cpu_flags_x86_sse4_2 ON OFF)
+ -DENABLE_AVX=$(usex cpu_flags_x86_avx ON OFF)
+ -DENABLE_AVX2=$(usex cpu_flags_x86_avx2 ON OFF)
+ )
+
+ # For 32-bit multilib builds, force some intrinsics on to work around
+ # bug #816027. libaom seems to do runtime detection for some targets
+ # at least, so this isn't an issue.
+ if ! multilib_is_native_abi && use amd64 ; then
+ mycmakeargs+=(
+ -DENABLE_SSE3=ON
+ -DENABLE_SSSE3=ON
+ )
+ fi
+
+ # On ARM32-on-ARM64, things end up failing if NEON is off, bug #835456
+ # Just force generic, given it's a niche situation.
+ # TODO: could try forcing armv7 or similar?
+ if use arm && ! use cpu_flags_arm_neon && [[ $(uname -p) == "aarch64" ]] ; then
+ ewarn "Forcing generic for arm32-on-arm64 build (bug #835456)"
+ mycmakeargs+=(
+ -DAOM_TARGET_CPU=generic
+ )
+ fi
+
+ cmake_src_configure
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use doc ; then
+ local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ fi
+
+ cmake_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+}
diff --git a/media-libs/libaom/libaom-9999.ebuild b/media-libs/libaom/libaom-9999.ebuild
index 1c7cfa25f6f8..711be136d0c9 100644
--- a/media-libs/libaom/libaom-9999.ebuild
+++ b/media-libs/libaom/libaom-9999.ebuild
@@ -3,7 +3,6 @@
EAPI=8
-CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
inherit cmake-multilib python-any-r1
@@ -12,12 +11,11 @@ if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://aomedia.googlesource.com/aom"
else
SRC_URI="https://storage.googleapis.com/aom-releases/${P}.tar.gz"
- S="${WORKDIR}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
DESCRIPTION="Alliance for Open Media AV1 Codec SDK"
-HOMEPAGE="https://aomedia.org"
+HOMEPAGE="https://aomedia.org https://aomedia.googlesource.com/aom/"
LICENSE="BSD-2"
SLOT="0/3"
@@ -38,7 +36,7 @@ BDEPEND="${PYTHON_DEPS}
doc? ( app-doc/doxygen )
"
-# the PATENTS file is required to be distributed with this package bug #682214
+# the PATENTS file is required to be distributed with this package, bug #682214
DOCS=( PATENTS )
multilib_src_configure() {