summaryrefslogtreecommitdiff
path: root/media-libs/libcdr/libcdr-0.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /media-libs/libcdr/libcdr-0.1.5.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'media-libs/libcdr/libcdr-0.1.5.ebuild')
-rw-r--r--media-libs/libcdr/libcdr-0.1.5.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/media-libs/libcdr/libcdr-0.1.5.ebuild b/media-libs/libcdr/libcdr-0.1.5.ebuild
deleted file mode 100644
index 88fd7662e04b..000000000000
--- a/media-libs/libcdr/libcdr-0.1.5.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libcdr.git"
- inherit autotools git-r3
-else
- SRC_URI="https://dev-www.libreoffice.org/src/libcdr/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~hppa ppc ppc64 ~sparc x86"
-fi
-
-DESCRIPTION="Library parsing the Corel cdr documents"
-HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-IUSE="doc static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/icu:=
- dev-libs/librevenge
- media-libs/lcms:2
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- dev-libs/boost
-"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit )
-"
-
-src_prepare() {
- default
- [[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- # bug 619448
- append-cxxflags -std=c++14
-
- local myeconfargs=(
- $(use_with doc docs)
- $(use_enable static-libs static)
- $(use_enable test tests)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}