summaryrefslogtreecommitdiff
path: root/media-libs/libde265/libde265-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /media-libs/libde265/libde265-9999.ebuild
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'media-libs/libde265/libde265-9999.ebuild')
-rw-r--r--media-libs/libde265/libde265-9999.ebuild60
1 files changed, 44 insertions, 16 deletions
diff --git a/media-libs/libde265/libde265-9999.ebuild b/media-libs/libde265/libde265-9999.ebuild
index 5fd5bc2676da..8b1ede09936e 100644
--- a/media-libs/libde265/libde265-9999.ebuild
+++ b/media-libs/libde265/libde265-9999.ebuild
@@ -1,24 +1,31 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_IN_SOURCE_BUILD=1
-AUTOTOOLS_AUTORECONF=1
-inherit git-r3 autotools-multilib
+inherit autotools multilib-minimal
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.2-qtbindir.patch" )
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strukturag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="Open h.265 video codec implementation"
HOMEPAGE="https://github.com/strukturag/libde265"
-EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="debug qt5 static-libs cpu_flags_x86_sse"
+IUSE="cpu_flags_x86_sse debug libav qt5 static-libs"
DEPEND="
- media-libs/libsdl
- virtual/ffmpeg
+ media-libs/libsdl[${MULTILIB_USEDEP}]
+ !libav? ( media-video/ffmpeg:=[${MULTILIB_USEDEP}] )
+ libav? ( media-video/libav:=[${MULTILIB_USEDEP}] )
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
@@ -27,19 +34,40 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-1.0.2-qtbindir.patch" )
+src_prepare() {
+ default
+
+ eautoreconf
-src_configure() {
+ # without this, headers would be missing and make would fail
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
local myeconfargs=(
$(use_enable cpu_flags_x86_sse sse)
$(use_enable static-libs static)
$(use_enable debug log-info)
$(use_enable debug log-debug)
$(use_enable debug log-trace)
- $(use_enable qt5 dec265)
- $(use_enable qt5 sherlock265)
- --disable-silent-rules
--enable-log-error
)
- autotools-multilib_src_configure "${myeconfargs[@]}"
+
+ if ! multilib_is_native_abi; then
+ myeconfargs+=( --disable-dec265 --disable-sherlock265 )
+ else
+ myeconfargs+=(
+ $(use_enable qt5 dec265)
+ $(use_enable qt5 sherlock265)
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
}