summaryrefslogtreecommitdiff
path: root/media-libs/libfishsound
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
commit2bf68d7062b64d9f815f3b8ce6942a66afe53b0d (patch)
treeac1e773aaa4d3575d18d178ae260cab963bbf64c /media-libs/libfishsound
parentcd356b722fd8d162f02a5059fae1a66e00be52e3 (diff)
gentoo auto-resync : 17:03:2024 - 06:49:08
Diffstat (limited to 'media-libs/libfishsound')
-rw-r--r--media-libs/libfishsound/Manifest2
-rw-r--r--media-libs/libfishsound/files/libfishsound-1.0.0-c99.patch65
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild52
3 files changed, 119 insertions, 0 deletions
diff --git a/media-libs/libfishsound/Manifest b/media-libs/libfishsound/Manifest
index 977afaea8959..005ce25707bf 100644
--- a/media-libs/libfishsound/Manifest
+++ b/media-libs/libfishsound/Manifest
@@ -1,4 +1,6 @@
+AUX libfishsound-1.0.0-c99.patch 2443 BLAKE2B feb353da9bb2ea2afa87c8153eb41e7228eb1fee612d5bdfc4c494e5bb5c45409500b06b2f1ca054307056e03365f3117c2a067b9e549e70fb86149d62e2be4b SHA512 d329084bc313943873fbc7e26893e3a4a68b71713ef7e3d1fc454030e78e06e4e8c8e67e2ede7dbb59ede578006a46dccd7b0bef04f71f2b9c0e17a995c9af5a
AUX libfishsound-1.0.0-pc.patch 410 BLAKE2B a949e5c3e843017f7c901ef936da4dac2f9d3300cc6fe57032d28bfba94919baee9a77054464cd97c567bc90733bbd6cd92fa25f7fb4a41cc38e5f502b075eae SHA512 b4b5f70363633702ed1932454bf8133d24ff7703f432ebd0c8721e33d48c1a21fc996c4759713fb2272f230038b40fe6cc773aea715726dfee13066669e32f1e
DIST libfishsound-1.0.0.tar.gz 444980 BLAKE2B eadb6bed80d51fa7399f9557a38b65183a4f583e431bc68ee961dcca947856c79f011206fdcb04ed6ee5f709e1045b2a9c4fd4a34afa00b09656b1a4623c3ab0 SHA512 97d850fb42b394fca098a96b1784da431a0af1d54d57127179b612e4b88a7a2e406eb1411f55536e5a11ec2e8956f2659182c60ac46d49f6d14250e39a740339
EBUILD libfishsound-1.0.0-r1.ebuild 1032 BLAKE2B ff5e7d72437f40cddb70ae1b594adbbe2cb0f670e8ebe576581e98abc2a3d4e4a81f76f71214ae0925d988eb3e50dd856a288861e6924e7c6e2ffe2fb3912214 SHA512 513e4edaf38566bc12b408817515ffd2eeacf00d4a85f0859e3ebc2a2341de0054567989a0a374597817b01eee8188ff6263a588e3c02b674d6c0e25f4fa7012
+EBUILD libfishsound-1.0.0-r2.ebuild 1073 BLAKE2B 7ea1da699f3cc2203e05a457b27d8b41f2052eb7d524e738d2e58f31ed0f23b599b733a97dd20058a88b176c0e3c7a33eeecf4ce120423cd8d4b0e012e733e09 SHA512 dc59b4cb90aac6de06821ce56c6dd93f93a9378d611d07e920c9de1cd620f886b88fc9781dd6bbab6ac8dc53258a2312c4cf3db3bf2ed02a197ac795613df8cd
MISC metadata.xml 260 BLAKE2B 9945ac40ee60ce67adf51840c3cc2d6d2743dffe4fd2ec965d300c709323f80eb5d35eaeb804414eebb2da1e954ee688067c05093b26499678de524b414ac4ec SHA512 e5b6a2a44cd2a4ea4fb1267eb8f635c079c022853443ad180ca12f2df84492f3ba34db45e4ff5e7e09262a74745f5c0aa04ebccd6f998cf19a6ea2ccd0627701
diff --git a/media-libs/libfishsound/files/libfishsound-1.0.0-c99.patch b/media-libs/libfishsound/files/libfishsound-1.0.0-c99.patch
new file mode 100644
index 000000000000..d010eb75ac0b
--- /dev/null
+++ b/media-libs/libfishsound/files/libfishsound-1.0.0-c99.patch
@@ -0,0 +1,65 @@
+https://bugs.gentoo.org/883393
+https://gitlab.xiph.org/xiph/libfishsound/-/merge_requests/1
+
+From 8eb391d772cb3c3dbfb68b2216e095af705b0229 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Martin=20Stegh=C3=B6fer?= <martin@steghoefer.eu>
+Date: Wed, 22 Oct 2014 22:03:15 +0200
+Subject: [PATCH] Fix incompatible flac callback types.
+
+Bug-Debian: https://bugs.debian.org/766394
+
+Starting from libflac 1.1.3 the flac API uses "size_t" as parameter type for the number of bytes in all callback functions.
+--- a/src/libfishsound/flac.c
++++ b/src/libfishsound/flac.c
+@@ -56,6 +56,13 @@
+
+ #define BITS_PER_SAMPLE 24
+
++#if defined(HAVE_FLAC_1_1_3)
++# define flac_callback_bytes_type size_t
++#else
++# define flac_callback_bytes_type unsigned int
++#endif
++
++
+ typedef struct _FishSoundFlacInfo {
+ FLAC__StreamDecoder *fsd;
+ FLAC__StreamEncoder *fse;
+@@ -106,7 +113,7 @@ fs_flac_command (FishSound * fsound, int command, void * data, int datasize)
+ #if FS_DECODE
+ static FLAC__StreamDecoderReadStatus
+ fs_flac_read_callback(const FLAC__StreamDecoder *decoder,
+- FLAC__byte buffer[], unsigned int *bytes,
++ FLAC__byte buffer[], flac_callback_bytes_type *bytes,
+ void *client_data)
+ {
+ FishSound* fsound = (FishSound*)client_data;
+@@ -121,7 +128,7 @@ fs_flac_read_callback(const FLAC__StreamDecoder *decoder,
+ }
+
+ memcpy(buffer, fi->buffer, fi->bufferlength);
+- *bytes = (unsigned int)fi->bufferlength;
++ *bytes = (flac_callback_bytes_type)fi->bufferlength;
+ fi->bufferlength = 0;
+ return FLAC__STREAM_DECODER_READ_STATUS_CONTINUE;
+ }
+@@ -346,7 +353,7 @@ dec_err:
+ #if FS_ENCODE
+ static FLAC__StreamEncoderWriteStatus
+ fs_flac_enc_write_callback(const FLAC__StreamEncoder *encoder,
+- const FLAC__byte buffer[], unsigned bytes,
++ const FLAC__byte buffer[], flac_callback_bytes_type bytes,
+ unsigned samples, unsigned current_frame,
+ void *client_data)
+ {
+@@ -354,7 +361,7 @@ fs_flac_enc_write_callback(const FLAC__StreamEncoder *encoder,
+ FishSoundFlacInfo *fi = fsound->codec_data;
+
+ debug_printf(1, "IN");
+- debug_printf(1, "bytes: %d, samples: %d", bytes, samples);
++ debug_printf(1, "bytes: %lld, samples: %d", (long long) bytes, samples);
+
+ if (fsound->callback.encoded) {
+ FishSoundEncoded encoded = (FishSoundEncoded) fsound->callback.encoded;
+--
+GitLab
diff --git a/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild b/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..174d912e442b
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple programming interface to decode and encode audio with vorbis or speex"
+HOMEPAGE="https://www.xiph.org/fishsound/"
+SRC_URI="https://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac speex"
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/libvorbis
+ flac? ( media-libs/flac:= )
+ speex? ( media-libs/speex )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# bug #395153
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pc.patch
+ "${FILESDIR}"/${PN}-1.0.0-c99.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:doxygen:doxygen-dummy:' \
+ configure || die
+}
+
+src_configure() {
+ local myconf="--disable-static"
+ use flac || myconf="${myconf} --disable-flac"
+ use speex || myconf="${myconf} --disable-speex"
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="${D}/usr/share/doc/${PF}" install
+ dodoc AUTHORS ChangeLog README
+ find "${ED}" -name '*.la' -delete || die
+}