summaryrefslogtreecommitdiff
path: root/media-libs/libfreehand
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /media-libs/libfreehand
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'media-libs/libfreehand')
-rw-r--r--media-libs/libfreehand/Manifest2
-rw-r--r--media-libs/libfreehand/libfreehand-9999.ebuild37
2 files changed, 22 insertions, 17 deletions
diff --git a/media-libs/libfreehand/Manifest b/media-libs/libfreehand/Manifest
index af2c24c7fd14..e01399307e7f 100644
--- a/media-libs/libfreehand/Manifest
+++ b/media-libs/libfreehand/Manifest
@@ -1,4 +1,4 @@
DIST libfreehand-0.1.2.tar.xz 516132 BLAKE2B 7c2dc629fd2a84f23dcd721ed6f9d4644e3bf7a160be9ca5ec0f15a72ae63b3cf861f80fafa12ef1f99b02e0fbc1c806bc37c466010a420bb425f4f9e2757928 SHA512 4112a76ac99999801d97d1b282596d631d8496a5bf65778ab26aa06da86637b1e2b630648a67ea01bf3316ecec9f2715546baff27af090b900267c87a011b963
EBUILD libfreehand-0.1.2.ebuild 1188 BLAKE2B 3a8bb50e8609ad253f17b3e7eaaaba8d07ece4273de198aafe7cf526fc644cda20e747241c007449bcfea6a23822c583e3abd2bcc8cb05a6ee7d5d7e04bd7e37 SHA512 b03c5417960418c4d0227597ca42b11b68135dcdfaf984a77db8527dbae2b9e6375bd52e2bd380d22dbe7543d992788730e92f63e18ca81c7bebdd310ceb12e1
-EBUILD libfreehand-9999.ebuild 1171 BLAKE2B edf9a99dd928bda98b3d15dcdb2c4943c3499fb14d0d51f0d0287b55236323f1ae0e9377d09bc221fdf42a2c00daace6a9fa26a3a79a797446a91451306c7fdd SHA512 ce17b320bd3c30f4f36d315a45309fd54eba638fe95bc12cef2cb08da575bad983406b1f4725ecd6a0bc7aa6766aea1a542cbdb0080f45e1e5cfd292042b7d80
+EBUILD libfreehand-9999.ebuild 1219 BLAKE2B 1492965e949240027d702e3d1dcae52ba2d2f755969db240321375ab465229b31ecf1bb020305e3c8e5adf96b032fd88a0260f679639c9135dcca39f69ddfa5b SHA512 e4999e91f63a9767373d46bacac7e5617f2544838261c37d6f84332fb37b6bcc78f94eee5e3cdebe20b228685803e9b8377ff7b96bc2b674e76b9ae886607ce9
MISC metadata.xml 255 BLAKE2B 9b8486730bea2158e8be5cbbe0552c5460d1b18e2236a68e3f11d85ce4eeb96eb0e746f44a10cb7cdcf1bf498190a512ef42f47852c6843b9a3c937ceabc338d SHA512 ac646e8ac676faf0aac283e4be31c5f2b29e98ccf07327073ed05e688ce696caf639bdfea63e4aed141a90e84c0a86892bc717a52b95cdf1739aaa15240013c3
diff --git a/media-libs/libfreehand/libfreehand-9999.ebuild b/media-libs/libfreehand/libfreehand-9999.ebuild
index be281349087b..b0b78cb0249e 100644
--- a/media-libs/libfreehand/libfreehand-9999.ebuild
+++ b/media-libs/libfreehand/libfreehand-9999.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libfreehand.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libfreehand.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libfreehand/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
DESCRIPTION="Library for import of FreeHand drawings"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libfreehand/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="doc static-libs test"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
RDEPEND="
dev-libs/librevenge
sys-libs/zlib
@@ -28,29 +33,29 @@ DEPEND="${RDEPEND}
dev-util/gperf
media-libs/lcms
sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
test? ( dev-util/cppunit )
"
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
# bug 619762
append-cxxflags -std=c++14
- econf \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable static-libs static)
$(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}