summaryrefslogtreecommitdiff
path: root/media-libs/libiptcdata
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-20 12:29:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-20 12:29:37 +0100
commitd3ae3ea75073c53ed5f3a4418e76383436bb0f58 (patch)
treee7bdf993ecf567ea3b6d9c8c00797f63ae25ea02 /media-libs/libiptcdata
parentc59df12b8749ab7bbd5a0692072652d4fbb0d2cf (diff)
gentoo auto-resync : 20:07:2024 - 12:29:37
Diffstat (limited to 'media-libs/libiptcdata')
-rw-r--r--media-libs/libiptcdata/Manifest1
-rw-r--r--media-libs/libiptcdata/libiptcdata-1.0.5-r1.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/media-libs/libiptcdata/Manifest b/media-libs/libiptcdata/Manifest
index 1932c0cc72b8..38be89910521 100644
--- a/media-libs/libiptcdata/Manifest
+++ b/media-libs/libiptcdata/Manifest
@@ -1,3 +1,4 @@
DIST libiptcdata-1.0.5.tar.gz 593779 BLAKE2B 7e5226a289fed5c2f4b662efaa693a8b38e95ac34bc1365af05d1af649be876d3e5b58fecea4818255879bd7518aa482cb623540601fb3c8065acd428439a29c SHA512 64ef44b1e639890004f31d5d42844ba25ed558f0a118f1dad9bc3f4dcad2457e51b825a13df849659b0e15afc78f528f330b03be94cdf156bd95b62dc419494a
+EBUILD libiptcdata-1.0.5-r1.ebuild 1634 BLAKE2B 78ca5b5779b7f1088e7dbf7ae043ec0506547741847b199236a030f710c7f8ec1c3cace433319ebc8a415f2e0c2fb9177d537254fca9a4ccda04388d1d425c06 SHA512 4ee5399c12184c4951cd5678e84571e1f8b970a11f02880d32bf385633657ed785c51e81ff7624dd6fa7aa15be83fd9b54808a429210164df744c8f8136b6031
EBUILD libiptcdata-1.0.5.ebuild 1160 BLAKE2B 5472a979846b09c26b910b3c335e500ade2755d66309d834794d7e8db6d60a21c79ee9847f6feab6851f5ec9728ff88b457eaa04e0deae2babb0a5736e40754a SHA512 a1fe02239489469f46a2fe34a4eb21fddd0009d1e79d38f11f1fd1f9c19378a1ec4bd052f0d44b896eaaa0e84d6f9a34d6f958af475448cdf19edb1fd95862e7
MISC metadata.xml 948 BLAKE2B 2eb9fc81cf1795cfc57e9b89e5880a3f34b21937bc41e802ab09d3fd508ad9e9c67a6c621558e2cf56683a4641b8160a3cfac3ff6ea578ee12e7543f73e1d9e1 SHA512 8dbf6854415f937c99f88fd1c1159acbc94a40b992c8eeaf5edb855a7830d4d11ea8ae9929e2af3e3d11c8ce5c7163e723110fad5f15259d5a21b7451fbaa9ac
diff --git a/media-libs/libiptcdata/libiptcdata-1.0.5-r1.ebuild b/media-libs/libiptcdata/libiptcdata-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..53e7ef439208
--- /dev/null
+++ b/media-libs/libiptcdata/libiptcdata-1.0.5-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit autotools distutils-r1
+
+DESCRIPTION="Library for International Press Telecommunications Council (IPTC) metadata"
+HOMEPAGE="https://github.com/ianw/libiptcdata https://libiptcdata.sourceforge.net/"
+SRC_URI="https://github.com/ianw/${PN}/releases/download/release_1_0_5/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples nls python"
+
+RDEPEND="
+ nls? ( virtual/libintl )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-build/gtk-doc-am
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )
+ nls? ( >=sys-devel/gettext-0.13.1 )
+ python? (
+ ${DISTUTILS_DEPS}
+ ${PYTHON_DEPS}
+ )
+"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ default
+ eautoreconf
+ if use python; then
+ cd python || die
+ distutils-r1_src_prepare
+ fi
+}
+
+src_configure () {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_enable python)
+ $(use_enable doc gtk-doc)
+ )
+ econf "${myeconfargs[@]}"
+
+ if use python; then
+ cd python || die
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ default
+ if use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_install () {
+ default
+
+ find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
+
+ if use python; then
+ cd python || die
+ distutils-r1_src_install
+ fi
+
+ if use examples; then
+ dodoc python/README
+ dodoc -r python/examples
+ fi
+}