summaryrefslogtreecommitdiff
path: root/media-libs/libopenaptx/libopenaptx-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /media-libs/libopenaptx/libopenaptx-9999.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'media-libs/libopenaptx/libopenaptx-9999.ebuild')
-rw-r--r--media-libs/libopenaptx/libopenaptx-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libopenaptx/libopenaptx-9999.ebuild b/media-libs/libopenaptx/libopenaptx-9999.ebuild
new file mode 100644
index 000000000000..bac055db1328
--- /dev/null
+++ b/media-libs/libopenaptx/libopenaptx-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Reverse-engineered aptX and aptX HD library"
+HOMEPAGE="https://github.com/pali/libopenaptx"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pali/${PN}"
+else
+ SRC_URI="https://github.com/pali/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE="cpu_flags_x86_avx2"
+
+src_compile() {
+ tc-export CC AR
+
+ use cpu_flags_x86_avx2 && append-cflags "-mavx2"
+
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ LIBDIR=$(get_libdir) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ all
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}"/usr \
+ DESTDIR="${D}" \
+ LIBDIR="$(get_libdir)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ARFLAGS="${ARFLAGS} -rcs" \
+ install
+
+ rm -f "${ED}/usr/$(get_libdir)"/libopenaptx.a || die "Failed to remove static lib"
+}