summaryrefslogtreecommitdiff
path: root/media-libs/libopenmpt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /media-libs/libopenmpt
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'media-libs/libopenmpt')
-rw-r--r--media-libs/libopenmpt/Manifest2
-rw-r--r--media-libs/libopenmpt/libopenmpt-0.6.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/libopenmpt/Manifest b/media-libs/libopenmpt/Manifest
index b8afe442e005..7e073ccb9460 100644
--- a/media-libs/libopenmpt/Manifest
+++ b/media-libs/libopenmpt/Manifest
@@ -1,3 +1,5 @@
DIST libopenmpt-0.5.14+release.autotools.tar.gz 1446898 BLAKE2B ab6ff8db2e19d859fecca882aea3e569b58d96d5055ec0dd42494a7eb38fefa9c8b88f4700d354de71346c71c6d9a96327db1c2b7b48e227928dcba0ce7347d6 SHA512 8897549c18afb57c5bf54f4dd8a1d80983829bca958052d76cda1315ef4a37f4201575817b7cedfe17a44ee79051a52aa35b26a51b554091e92c9d2dcf5924a3
+DIST libopenmpt-0.6.0+release.autotools.tar.gz 1506911 BLAKE2B 44cf8c5f725d2b11409d23e293dca0c151cad17c029da7f70a22366e75baa1b49b763f67d617d84a142efd3933b90344ccca5d881e5c724e2cfe0210170593dc SHA512 8da6cf1f2dbf683c32f45cbf884784360cced5e21f9862c96a1a679bd90b36be9a7cc59accbf82271a804722986cb81e75915f6564aeaaa248ed3e967dfdfb1a
EBUILD libopenmpt-0.5.14.ebuild 1544 BLAKE2B ce1beb9e386a70e598f295b4caedab63a9bfb273e4d31a7b78047d68b176dc6b46bf673ca97a395bb30067629785ef9f9117502c3bb0f6a50c25d7045203f51c SHA512 9b834a31821d7fae8e409241b4acf5c298a539c815191cef68219ed6ce6a4edb1cf85f50254c6ea61d17898fbbb0f58ed5c40f4ca35c7cc5965aadadcaa4a5d9
+EBUILD libopenmpt-0.6.0.ebuild 1546 BLAKE2B 681d53024b675898c28c08ffd1541380fbc375b09c70cbb41e724d27fa76608f496c2ffaf164663ff01ea9243b65616ab191d93328812b24b3c18121d165c082 SHA512 1e0eedabe9d82f5493c590d3262f2fc61ae0ed402d90743101e6a07674134f725223d5573f729e2a411c3aa7eebbf013c98442fe808af443e5c9d11f9ad63d86
MISC metadata.xml 328 BLAKE2B 25f8b37a7e7885a50e5b7305c9090033c78b1154214e05060c3407f0d27ac436aa3f0da1dff3a5ba1685bef390f1fe99416893aaf59e002921cc3464ce0d2167 SHA512 6686c75dbfcd5a5f9d6ef4d667916f54388180045471f8eb585c7b0d6e03f5d56c3fc892c97851f7453318309a456bbfd877eb240cbf008b71984009d08a8181
diff --git a/media-libs/libopenmpt/libopenmpt-0.6.0.ebuild b/media-libs/libopenmpt/libopenmpt-0.6.0.ebuild
new file mode 100644
index 000000000000..ecc623d23085
--- /dev/null
+++ b/media-libs/libopenmpt/libopenmpt-0.6.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+MY_P="libopenmpt-${PV}+release.autotools"
+DESCRIPTION="Library to decode tracked music files (modules)"
+HOMEPAGE="https://lib.openmpt.org/libopenmpt/"
+SRC_URI="https://lib.openmpt.org/files/libopenmpt/src/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="examples mp3 ogg static-libs test vorbis zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ mp3? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
+ ogg? ( media-libs/libogg[${MULTILIB_USEDEP}] )
+ vorbis? ( media-libs/libvorbis[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ # A lot of these optional dependencies relate to openmpt123, which
+ # we package separately, so we disable them here.
+ econf \
+ $(use_enable static-libs static) \
+ --disable-openmpt123 \
+ --disable-examples \
+ $(use_enable test tests) \
+ --disable-doxygen-doc \
+ $(use_with zlib) \
+ $(use_with mp3 mpg123) \
+ $(use_with ogg) \
+ $(use_with vorbis) \
+ $(use_with vorbis vorbisfile) \
+ --without-pulseaudio \
+ --without-portaudio \
+ --without-portaudiocpp \
+ --without-sdl2 \
+ --without-sndfile \
+ --without-flac
+}
+
+multilib_src_install_all() {
+ rm -f \
+ "${ED}"/usr/*/*.la \
+ "${ED}"/usr/share/doc/${P}/LICENSE || die
+
+ if ! use examples; then
+ rm -r "${ED}"/usr/share/doc/${P}/examples || die
+ fi
+}