summaryrefslogtreecommitdiff
path: root/media-libs/libopenmpt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /media-libs/libopenmpt
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'media-libs/libopenmpt')
-rw-r--r--media-libs/libopenmpt/Manifest3
-rw-r--r--media-libs/libopenmpt/libopenmpt-0.4.10.ebuild62
-rw-r--r--media-libs/libopenmpt/metadata.xml11
3 files changed, 76 insertions, 0 deletions
diff --git a/media-libs/libopenmpt/Manifest b/media-libs/libopenmpt/Manifest
new file mode 100644
index 000000000000..58dbe6eacae0
--- /dev/null
+++ b/media-libs/libopenmpt/Manifest
@@ -0,0 +1,3 @@
+DIST libopenmpt-0.4.10+release.autotools.tar.gz 1471662 BLAKE2B c20ef4d26b583f5cbbed5e6d108ce6f55fef74726997267a56d16b8508fb46f26f62f934a98bcc20749da2ed2aef0bdd22931cc785806ec0b6c5daef593d196d SHA512 d7c46016eea59c21e3f948d8538a747d5fa6b29f160841b688878d8ce48859d014c3a036738074b3d260af6e662c36b03391aef511c1817a5ace81f60bf27dfc
+EBUILD libopenmpt-0.4.10.ebuild 1554 BLAKE2B 9c094bebb82c016864cd62e5cdcc90fbc8dd661a9a81469b1d2a4b906dbc77b63906e80bee07c1a9d82262a9eed4e9f2af751a716607d3132de8f91aac564861 SHA512 d63c8bfe835a4d933d56d361488fd4e736b40a5b691f8e783dec263a472a5d5875ffded370b78d1de09ee69694326f27a98fbc588d7e10d0c821fbf65700ac42
+MISC metadata.xml 327 BLAKE2B 586d07f006d87d8e0dc4c0be387cdbe4fadaabad3d9fb985f9d6c8afe77ca9686773c2eed48defbe85da365f0256efa3337f32a9e913d61fb8a48781236ce185 SHA512 52b1f22ca0b08f9d6201ec44718875f6c3b4de31703f55ebc22a516e574eeeba7ac8d0d06425e624b258b4658d0d164d1a1b7b44b2e049e151fcb390cfbeb297
diff --git a/media-libs/libopenmpt/libopenmpt-0.4.10.ebuild b/media-libs/libopenmpt/libopenmpt-0.4.10.ebuild
new file mode 100644
index 000000000000..091bc25c2d2b
--- /dev/null
+++ b/media-libs/libopenmpt/libopenmpt-0.4.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+MY_P="libopenmpt-${PV}+release.autotools"
+DESCRIPTION="Library to decode tracked music files (modules)"
+HOMEPAGE="https://lib.openmpt.org/libopenmpt/"
+SRC_URI="https://lib.openmpt.org/files/libopenmpt/src/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples mp3 ogg static-libs test vorbis zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ mp3? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
+ ogg? ( media-libs/libogg[${MULTILIB_USEDEP}] )
+ vorbis? ( media-libs/libvorbis[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ # A lot of these optional dependencies relate to openmpt123, which
+ # we package separately, so we disable them here.
+ econf \
+ $(use_enable static-libs static) \
+ --disable-openmpt123 \
+ --disable-examples \
+ $(use_enable test tests) \
+ --disable-doxygen-doc \
+ $(use_with zlib) \
+ $(use_with mp3 mpg123) \
+ $(use_with ogg) \
+ $(use_with vorbis) \
+ $(use_with vorbis vorbisfile) \
+ --without-pulseaudio \
+ --without-portaudio \
+ --without-portaudiocpp \
+ --without-sdl2 \
+ --without-sdl \
+ --without-sndfile \
+ --without-flac
+}
+
+multilib_src_install_all() {
+ rm \
+ "${ED}"/usr/*/*.la \
+ "${ED}"/usr/share/doc/${P}/LICENSE || die
+
+ if ! use examples; then
+ rm -r "${ED}"/usr/share/doc/${P}/examples || die
+ fi
+}
diff --git a/media-libs/libopenmpt/metadata.xml b/media-libs/libopenmpt/metadata.xml
new file mode 100644
index 000000000000..334feada06c3
--- /dev/null
+++ b/media-libs/libopenmpt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">OpenMPT/openmpt</remote-id>
+ </upstream>
+</pkgmetadata>