summaryrefslogtreecommitdiff
path: root/media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-07 21:22:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-07 21:22:54 +0000
commit1cfea2a84c51291a77ab820b6871efcff10c148d (patch)
tree924f8b07cb24ba72b3d889cf4b50bdff4d2785c0 /media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch
parent441369caa3d11703d0349d4b9746b7ad10aa6cb2 (diff)
gentoo auto-resync : 07:11:2022 - 21:22:53
Diffstat (limited to 'media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch')
-rw-r--r--media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch b/media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch
new file mode 100644
index 000000000000..14ce1f6972c0
--- /dev/null
+++ b/media-libs/libplacebo/files/libplacebo-5.229.1-shared-glslang.patch
@@ -0,0 +1,12 @@
+OSDependent and OGLCompiler are already included in the shared libglslang,
+and glslang-1.3.231 normally does not install these with shared builds.
+--- a/src/glsl/meson.build
++++ b/src/glsl/meson.build
+@@ -21,5 +21,5 @@
+ cxx.find_library('MachineIndependent', required: false),
+- cxx.find_library('OSDependent', required: glslang_req),
++ cxx.find_library('OSDependent', required: false),
+ cxx.find_library('HLSL', required: glslang_req),
+- cxx.find_library('OGLCompiler', required: glslang_req),
++ cxx.find_library('OGLCompiler', required: false),
+ cxx.find_library('GenericCodeGen', required: false),