summaryrefslogtreecommitdiff
path: root/media-libs/libprojectm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /media-libs/libprojectm/files
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'media-libs/libprojectm/files')
-rw-r--r--media-libs/libprojectm/files/libprojectm-3.1.3-bashisms.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libprojectm/files/libprojectm-3.1.3-bashisms.patch b/media-libs/libprojectm/files/libprojectm-3.1.3-bashisms.patch
new file mode 100644
index 000000000000..8d84ece802cb
--- /dev/null
+++ b/media-libs/libprojectm/files/libprojectm-3.1.3-bashisms.patch
@@ -0,0 +1,47 @@
+From 8a522d975890a4512be0f04285f356c6db653a57 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Thu, 14 May 2020 11:46:50 +0200
+Subject: [PATCH] configure.ac: Avoid bashisms
+
+or else we end up like this:
+
+ ./configure: 18902: ./configure: Syntax error: redirection unexpected
+
+or
+
+ ./configure: 20152: ./configure: my_CFLAGS+=-DDATADIR_PATH=\""$(pkgdatadir)"\" : not found
+ ./configure: 20153: ./configure: my_CFLAGS+=-I$(top_srcdir)/vendor : not found
+
+Gentoo-bug: https://bugs.gentoo.org/714098
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 5fa53eca5..ecf85e076 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -163,7 +163,7 @@ AC_PREFIX_DEFAULT([/usr/local])
+
+ AC_PROG_MKDIR_P
+
+-AS_IF([grep android <<< ${host}], [],
++AS_IF([echo ${host} | grep -Fq android], [],
+ [AX_CHECK_COMPILE_FLAG([-stdlib=libc++], [
+ CXXFLAGS="$CXXFLAGS -stdlib=libc++"])
+ ])
+@@ -237,10 +237,10 @@ AM_CONDITIONAL([ENABLE_EMSCRIPTEN], [test "x$enable_emscripten" = "xyes"])
+ AM_CONDITIONAL([ENABLE_PRESET_SUBDIRS], [test "x$enable_preset_subdirs" = "xyes"])
+
+
+-my_CFLAGS="-Wall -Wchar-subscripts -Wformat-security -Wpointer-arith -Wshadow -Wsign-compare -Wtype-limits "
++my_CFLAGS="-Wall -Wchar-subscripts -Wformat-security -Wpointer-arith -Wshadow -Wsign-compare -Wtype-limits"
+ #my_CFLAGS+="-fsanitize=address -fno-omit-frame-pointer "
+-my_CFLAGS+='-DDATADIR_PATH=\""$(pkgdatadir)"\" '
+-my_CFLAGS+='-I$(top_srcdir)/vendor '
++my_CFLAGS="${my_CFLAGS} -DDATADIR_PATH=\\\"\"\$(pkgdatadir)\\\"\""
++my_CFLAGS="${my_CFLAGS} -I\$(top_srcdir)/vendor"
+ AC_SUBST([my_CFLAGS])
+
+