summaryrefslogtreecommitdiff
path: root/media-libs/libsixel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-25 06:47:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-25 06:47:12 +0000
commit4dec849539ecb0ceab14d66af84960f01b9a284c (patch)
tree70e3b3443839fd480586c6a3bc5f95ac0087603d /media-libs/libsixel
parentf1e6490ffadd8d677960342b348f2b08492dd5f6 (diff)
gentoo auto-resync : 25:01:2025 - 06:47:11
Diffstat (limited to 'media-libs/libsixel')
-rw-r--r--media-libs/libsixel/Manifest2
-rw-r--r--media-libs/libsixel/libsixel-1.10.5.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/media-libs/libsixel/Manifest b/media-libs/libsixel/Manifest
index 6777f98999e3..aa18e7554861 100644
--- a/media-libs/libsixel/Manifest
+++ b/media-libs/libsixel/Manifest
@@ -2,5 +2,7 @@ AUX libsixel-meson.patch 1904 BLAKE2B d4e4b4b800e8c8e847893b7f80369f71b2cb99ae4f
AUX libsixel-musl.patch 1304 BLAKE2B 09e7a75a94edd944cca9997c74b235f9f27aeff550b2a9a02225c93d60f1faf598b9c5c304c9e8f1f207da37d7712d40115410f65cae17995c3bdaed6cfc99d7 SHA512 39b7227040e523881a9405e7f6b98362a0c4fb7f717bf50a724eabfd5cfe9779f820243f7ae0a83b61b4dd124ec4ff0070d391ea43476388095e1d4160f13cbd
AUX libsixel-static-libs.patch 240 BLAKE2B ba9091c4991c6e69f83ca7eaa35aa7ceaf81e8542b1edffd1ce64ba1bedf518ad82603cdc610f256b1a0dc4954151b7407202a27c101ef6de59ff0724021faa3 SHA512 d3c6c060e8eba47c98180e5e4e127dfcb6f77f89b11dbaa8595cfd9786eee94a884476d210deb9ca6eaa2f548c6407a9bff714cfc3f18d4fa36b60d2c1fc165e
DIST libsixel-1.10.3.tar.gz 4272940 BLAKE2B f65d9a3bdd54917f5746b7b1650dfca7084c64b505ea9cae07863c476d1189114d9fb303ec01d8fa209542e891f1d359ec6dbdc9babc4313b06b709813fab020 SHA512 ef16f9ccecec8289728ec84ce9f24145648f8a38184c1ec3df8ead3499c6cf7d3e0a0c738f8bfcb1093e16ee8ae7ce5e46d3890707c8104752ce4ab7eb3bc7ac
+DIST libsixel-1.10.5.tar.gz 4286415 BLAKE2B a05981c627529ba0bc045726d46a865b676f7057e436b2b9ed367738d655ac149b5a524e8da7379b56275eb62a113c9acbfe0f7ad8066a08fd583b29eae2277b SHA512 94fc972ee304885936d5d8fbc3dadc5feadebf1ab262bb49c9ae9b1eed19c528ed823f4d31c17326340f06a5b7ee28a1817be15ae55c3e9d0c4437cd36b3e49d
EBUILD libsixel-1.10.3-r1.ebuild 2044 BLAKE2B 23944d132ccf15e7ab84f9fd3c2f591cf40018b3dace90a707c7316d4189901dc216cf8dc968c7e975f7327cdb0307135c41860e56d359ef5b161b4e3ba3f67d SHA512 27b2f4ecd5be9018fc8d2d3101c46e31f9bf35e11f80690caeddc453cecef13dfc81c877382e5d80c4531ce1c56dd63ca2988c7488f9518dabf8b8c848c4dcce
+EBUILD libsixel-1.10.5.ebuild 1945 BLAKE2B 8f4221f0768b6d53bb01c80c8cb7d0752f982793baca9703f5b5af3e3c25f0871bfdb11f4f6c14a15d9a3cd0a59b17795695ed26e99d7469ed8b9b7af53f2f17 SHA512 d2618913b52abfa12c5af777365bd2a924185851ce59493ae3ae6be4c5706ed3654c0b5b26af25a3f2a2a668f47718a1a7709371c85cc677590f77b02eaf0fbb
MISC metadata.xml 387 BLAKE2B 71825e6924d15781b4c819089beabe6b4279b8f408452e97c5121d2892d8539f95205d2c869dc1259b3aecb0e8d7a1389548b44bca7637994afe16da0abcc8d3 SHA512 4481aef804960b1205090e2453f878fc059b009d1548f1a8b28653919443b73cd030b9020b3d0707d98623f39a82775d36f5111ccb1bd65f1f9128183915faa4
diff --git a/media-libs/libsixel/libsixel-1.10.5.ebuild b/media-libs/libsixel/libsixel-1.10.5.ebuild
new file mode 100644
index 000000000000..447a8603bc2a
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.10.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517="setuptools"
+DISTUTILS_OPTIONAL="1"
+
+inherit bash-completion-r1 distutils-r1 meson
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/libsixel/libsixel"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="curl gd gtk jpeg png python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( media-libs/libpng:0 )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ python? (
+ ${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
+ )"
+
+src_prepare() {
+ sed -i '/^have/d' converters/shell-completion/bash/img2sixel
+
+ default
+ if use python; then
+ cd python || die
+ distutils-r1_src_prepare
+ cd - >/dev/null || die
+ fi
+}
+
+src_configure() {
+ emesonargs=(
+ $(meson_feature curl libcurl)
+ $(meson_feature gd)
+ $(meson_feature gtk gdk-pixbuf2)
+ $(meson_feature jpeg)
+ $(meson_feature png)
+ $(meson_feature test tests)
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+ meson_src_configure
+ if use python; then
+ cd python || die
+ distutils-r1_src_configure
+ cd - >/dev/null || die
+ fi
+}
+
+src_compile() {
+ meson_src_compile
+ if use python; then
+ cd python || die
+ distutils-r1_src_compile
+ cd - >/dev/null || die
+ fi
+}
+
+src_install() {
+ meson_src_install
+
+ cd images || die
+ docompress -x /usr/share/doc/${PF}/images
+ docinto images
+ dodoc egret.jpg map{8,16}.png snake.jpg vimperator3.png
+ cd - >/dev/null || die
+
+ if use python; then
+ cd python || die
+ distutils-r1_src_install
+ cd - >/dev/null || die
+ fi
+}