summaryrefslogtreecommitdiff
path: root/media-libs/lilv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-22 06:42:31 +0000
commit564687d289b862b8b079569a45a2d39d7b8c3585 (patch)
tree9ec555a8f8005c24f9d8198ba4941cc6f002a413 /media-libs/lilv
parent30c47f3c341cb37e4808aaa3842b679d0ca420e8 (diff)
gentoo auto-resync : 22:01:2025 - 06:42:31
Diffstat (limited to 'media-libs/lilv')
-rw-r--r--media-libs/lilv/Manifest2
-rw-r--r--media-libs/lilv/lilv-0.24.26.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/media-libs/lilv/Manifest b/media-libs/lilv/Manifest
index e40d1212026f..2c8d2b116125 100644
--- a/media-libs/lilv/Manifest
+++ b/media-libs/lilv/Manifest
@@ -1,3 +1,5 @@
DIST lilv-0.24.24.tar.xz 105684 BLAKE2B 4228248e8dbee228cee193e259d95b2e66f9f2e3516702dfad0dc126273076230274538c32a857ae9ad8a58545bbf48e7791254441dd4d6e537715de9e5e5be6 SHA512 93a3842a5e000a9c59bf3493c2c10df35a803a7edf6cff09f43e155a7e83d0c7c81bc24a6243828dc141d30187c3f60ef9799f319f72e5b6c3e2d022de757185
+DIST lilv-0.24.26.tar.xz 106044 BLAKE2B 23b7a029fd40099420e9e8de222b2534b124a93f899c03c5ada27673fc47431c95866d7d4bc5f34b80110b5142e6564e95390fd56d686ac9958ad8bf71ca6033 SHA512 3d360d63391554f62d1dd44b9ba0fc28e4ccde9640da1e28ef3f127c23c9f03974b66c5bbb83f022f18810284a0e25060127d580ca2fad6213fe88920618c2ae
EBUILD lilv-0.24.24.ebuild 1703 BLAKE2B c1aab919df9d199c15a08f9a9ebadcaf1a3bfa4869730f87b47d56b6b58a380ffc3e7d635c678c3e5f5ed017063008a63f2909051365642fb562d4fe23ea9ab9 SHA512 40e062b9ef6255bd8056f094f411f8115ca00cc0af180427b677ff3d247bf71f82ee3157e56897418e3c28fafdc03ee7096b3c708ee7d26300019b7b51e5d878
+EBUILD lilv-0.24.26.ebuild 1721 BLAKE2B 1f982e9ee254c04d7d4c2827078eb42312695797c836f3bef8267d486f8c6332a1d147482ee5a2b8bd04f3d66ba631abc1b9423d7a42690386769b63375d2762 SHA512 cb5bf747a5fe15df65f60509c42e77921a72028f2abf9cd67bfa6d951741fc86afc5559bb46bbcfe5d5ae13154090ed6e7c2385587536344e78e7a7ef6e5b9c4
MISC metadata.xml 694 BLAKE2B 95d755914e68f4f5f1a3b5e04bea2cdb2cb2068d03e83f5d4dfba74e72b124e3db964c634c9f092e1f7201798ad405724a9d29190ce2086f39a9e674bdab8d2e SHA512 671fc5f358b6e5bf4ea212af706ea6c4695f399866050d9822c05dea0f8467c8b8f207887615397a7e686f399be809ab31367dfeb1a6ad62ff2680480d591f47
diff --git a/media-libs/lilv/lilv-0.24.26.ebuild b/media-libs/lilv/lilv-0.24.26.ebuild
new file mode 100644
index 000000000000..336c4916f412
--- /dev/null
+++ b/media-libs/lilv/lilv-0.24.26.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} python3_13t )
+PYTHON_REQ_USE='threads(+)'
+
+inherit meson-multilib python-single-r1
+
+DESCRIPTION="Library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="https://drobilla.net/software/lilv.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc python test tools"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-text/doxygen
+ dev-python/sphinx
+ dev-python/sphinx-lv2-theme
+ dev-python/sphinxygen
+ )
+"
+# Take care on bumps to check minimum versions!
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/serd-0.30.10[${MULTILIB_USEDEP}]
+ >=dev-libs/sord-0.16.16[${MULTILIB_USEDEP}]
+ >=dev-libs/zix-0.4.0[${MULTILIB_USEDEP}]
+ media-libs/libsndfile
+ >=media-libs/lv2-1.18.2[${MULTILIB_USEDEP}]
+ >=media-libs/sratom-0.6.10[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ default
+
+ # fix doc installation path
+ sed -iE "s/versioned_name/'${PF}'/g" doc/html/meson.build doc/singlehtml/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature doc docs)
+ $(meson_feature python bindings_py)
+ $(meson_feature test tests)
+ $(meson_feature tools)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+ python_optimize
+}
+
+multilib_src_install_all() {
+ local DOCS=( AUTHORS NEWS README.md )
+ einstalldocs
+
+ newenvd - 60lv2 <<-EOF
+ LV2_PATH=${EPREFIX}/usr/$(get_libdir)/lv2
+ EOF
+}