summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /media-libs/mesa/mesa-9999.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'media-libs/mesa/mesa-9999.ebuild')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index e3fd921bbaa0..5829adce48f2 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -27,13 +27,13 @@ RESTRICT="
"
RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 intel iris lima nouveau panfrost v3d vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} crocus freedreno i915 i965 intel iris lima nouveau panfrost v3d vc4 virgl vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic d3d9 debug +egl +gallium +gbm gles1 +gles2 +llvm
+ +classic cpu_flags_x86_sse2 d3d9 debug +egl +gallium +gbm gles1 +gles2 +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
vulkan-overlay wayland +X xa xvmc zink +zstd"
@@ -45,6 +45,7 @@ REQUIRED_USE="
vulkan? ( video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
wayland? ( egl gbm )
+ video_cards_crocus? ( gallium )
video_cards_freedreno? ( gallium )
video_cards_intel? ( classic )
video_cards_i915? ( || ( classic gallium ) )
@@ -139,9 +140,10 @@ RDEPEND="${RDEPEND}
# 1. List all the working slots (with min versions) in ||, newest first.
# 2. Update the := to specify *max* version, e.g. < 10.
# 3. Specify LLVM_MAX_SLOT, e.g. 9.
-LLVM_MAX_SLOT="12"
+LLVM_MAX_SLOT="13"
LLVM_DEPSTR="
|| (
+ sys-devel/llvm:13[${MULTILIB_USEDEP}]
sys-devel/llvm:12[${MULTILIB_USEDEP}]
sys-devel/llvm:11[${MULTILIB_USEDEP}]
)
@@ -253,11 +255,12 @@ llvm_check_deps() {
pkg_pretend() {
if use vulkan; then
- if ! use video_cards_i965 &&
+ if ! use video_cards_freedreno &&
+ ! use video_cards_i965 &&
! use video_cards_iris &&
! use video_cards_radeonsi &&
! use video_cards_v3d; then
- ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain i965, iris, radeonsi, or v3d"
+ ewarn "Ignoring USE=vulkan since VIDEO_CARDS does not contain freedreno, i965, iris, radeonsi, or v3d"
fi
fi
@@ -466,6 +469,7 @@ multilib_src_configure() {
fi
fi
+ gallium_enable video_cards_crocus crocus
gallium_enable video_cards_iris iris
gallium_enable video_cards_r300 r300
@@ -486,6 +490,7 @@ multilib_src_configure() {
fi
if use vulkan; then
+ vulkan_enable video_cards_freedreno freedreno
vulkan_enable video_cards_i965 intel
vulkan_enable video_cards_iris intel
vulkan_enable video_cards_radeonsi amd
@@ -514,6 +519,9 @@ multilib_src_configure() {
$(meson_use osmesa)
$(meson_use selinux)
$(meson_feature zstd)
+ $(meson_use video_cards_crocus prefer-crocus)
+ $(meson_use video_cards_iris prefer-iris)
+ $(meson_use cpu_flags_x86_sse2 sse2)
-Dvalgrind=$(usex valgrind auto disabled)
-Ddri-drivers=$(driver_list "${DRI_DRIVERS[*]}")
-Dgallium-drivers=$(driver_list "${GALLIUM_DRIVERS[*]}")