summaryrefslogtreecommitdiff
path: root/media-libs/munt-mt32emu/munt-mt32emu-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 02:09:39 +0000
commit517343fddd94e620e94be97ae22eca4b57dc7625 (patch)
tree70b62f663c2d6f154c8808e55e827c69509918bd /media-libs/munt-mt32emu/munt-mt32emu-2.7.0.ebuild
parent6554f04b9a44e1ffe5d2f614201c11deed2703bd (diff)
gentoo auto-resync : 18:02:2023 - 02:09:39
Diffstat (limited to 'media-libs/munt-mt32emu/munt-mt32emu-2.7.0.ebuild')
-rw-r--r--media-libs/munt-mt32emu/munt-mt32emu-2.7.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/munt-mt32emu/munt-mt32emu-2.7.0.ebuild b/media-libs/munt-mt32emu/munt-mt32emu-2.7.0.ebuild
new file mode 100644
index 000000000000..a0d63213fbc7
--- /dev/null
+++ b/media-libs/munt-mt32emu/munt-mt32emu-2.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="libmt32emu_${PV//./_}"
+DESCRIPTION="Library for emulating the Roland MT-32, CM-32L, CM-64 and LAPC-I"
+HOMEPAGE="https://github.com/munt/munt"
+SRC_URI="https://github.com/munt/munt/archive/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/munt-${MY_P}/mt32emu"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.1-docs.patch
+)
+
+src_configure() {
+ local libdir=${EPREFIX}/usr/$(get_libdir)
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${libdir}"
+ -Dlibmt32emu_PKGCONFIG_INSTALL_PREFIX="${libdir}"
+ )
+
+ cmake_src_configure
+}